11 Replies Latest reply: Oct 22, 2009 1:34 PM by 843802 RSS

    "Upgrading Java Applet Cache" in 1.6.0_02

    843802
      We deployed 1.6.0_02 recently for a large intranet Applet that runs exclusively on Windows machines running XP sp2.
      We're finding that after installation some users get a Dialog from the plugin that states:
      "Upgrading Java Applet Cache
      Please wait while your stored Java applets are updated for Java SE 6"

      This takes about a minute and a half.
      But the problem is they get this message every time they start the applet, not just the first time.
      So it takes over a minute to get the applet running, which of course the users aren't fond of.

      Is anyone else seeing this?
        • 1. Re: "Upgrading Java Applet Cache" in 1.6.0_02
          843802
          I am having the same problems.
          I have tried everything and I can't fix this bug.
          does anyone have any ideas?
          • 2. Re: "Upgrading Java Applet Cache" in 1.6.0_02
            843802
            I only saw this message the once.

            Have you tried completely emtying the cache on machines where you see this.

            ie Open Control Panel, General tab, Temporary Internet Files, Settings..., Delete files...

            just an idea...
            • 3. Re: "Upgrading Java Applet Cache" in 1.6.0_02
              843802
              yes,I have tried that.
              I have tried everything I think.
              and nothing works.
              I still get the updating Java applet message.
              when I hit cancel, then Java does load most of the time, but sometimes it crashes my system too.
              it is very annoying since I use a lot of sites that require Java.
              B
              • 4. Re: "Upgrading Java Applet Cache" in 1.6
                843802
                I am also experiencing the same annoying problem, in my two WinXP PCs.

                The whole ordeal began after I upgraded to Java 1.6.

                I cannot run anything related to JaWS/JNLP either, and the symptoms seem to be closely related to the "upgrading applet" issue.

                I have tried every single post 1.6 version, JRE, SDK and early Java release, but the problem remains.

                I am extremely disappointed at Sun at the Java community for this bug.

                -Ramon
                • 5. Re: "Upgrading Java Applet Cache" in 1.6.0_02
                  843802
                  I tried everything including uninstalling Java and reinstalling, but no luck.

                  It is about time Sun sorted this major problem out, as it is very annoying. Will there be an upgrade or patch due out soon to fix it?
                  • 6. Re: "Upgrading Java Applet Cache" in 1.6.0_02
                    843802
                    Go into the control panel open the java control panel applet.

                    On the general tab under the Temporary internet files click Settings

                    Click delete files on this page.

                    close out of the control panel applet and try running your app again.

                    This solved the problem for me

                    Socc
                    • 7. Re: "Upgrading Java Applet Cache" in 1.6.0_02
                      843802
                      I was having the same problem. I disabled the "Java Quick Starter" service & its working for me. I get no more upgrade messages. I'm using 1.6.0_11-b03 with XP, IE6.
                      • 8. Re: "Upgrading Java Applet Cache" in 1.6.0_02
                        843802
                        I am running XP and Java 1.6.0_14-b08 and IE8. I just upgraded from IE7 to IE8, and I also upgraded Java. (I do not know the previous version of Java.) When I try to get to a page that uses Java, I get "Upgrading Java applet cache". It sits for a long time, displaying up to 8 bars, and then quits. I have tried the "settings - delete files" and restarting IE8. Under "Advanced - Miscellaneous" I see only "Place Java icon in system tray". I do not see the other item referenced in this forum to disable JQS. I could manually delete any cached applets if I knew in what directory they are stored.
                        • 9. Re: "Upgrading Java Applet Cache" in 1.6.0_02; Java Quick Starter
                          843802
                          Try the Java Control Panel | Advanced | Java Plug-in.

                          In my setup (default), the Miscellaneous didn't show that Java Quick Starter was enabled, but the Java Plug-in was.
                          • 10. Re: "Upgrading Java Applet Cache" in 1.6.0_02; Java Quick Starter
                            843802
                            I too had this issue, browsing a java-intensive site on firefox. I was able to resolve it using geckohale's hint.

                            That is, I went to control panel -> Java control panel -> "advanced" tab.

                            Click the plus sign beside Java Plug-in and uncheck the box "Enable the next generation Java plug-in".

                            After I restarted my browser I again had unimpeded Java access via my browser.
                            • 11. Re: "Upgrading Java Applet Cache" in 1.6.0_02; Java Quick Starter
                              843802
                              Unchecking the box worked for me. As I do not have admin privileges on the XP machine, I had to get my system administrator to uncheck the box. When I tried it myself, I could not do it; the system error message stated that a browser was still open. This was NOT the case, and I figured it was a permissions problem. What I do not understand is this - If Java needed to update the applets, why do I have to UNcheck the "enable next generation plugin" box? I would have expected that what Java needed to do was update a plugin, and unchecking that box DISabled any updates. But as a former IBM mainframe systems programmer, I will never fully understand the workings of the MS Windows operating system.