3 Replies Latest reply: Apr 15, 2010 6:15 AM by 843804 RSS

    jdk1.6.0_19 issues

    843804
      Due to a security finding, I have a need to upgrade from jdk1.6.0_17 to jdk1.6.0_19. The install is successful, however, when I try to start my content server, Coldfusion8, I get the following java exception:
      Exception in thread "main" java.lang.NoSuchFieldError: strm
      at java.util.zip.Inflater.initIDs(Native Method)
      at java.util.zip.Inflater.<clinit>(Inflater.java:68)
      at java.util.zip.ZipFile.getInflater(ZipFile.java:266)
      at java.util.zip.ZipFile.getInputStream(ZipFile.java:212)
      at java.util.zip.ZipFile.getInputStream(ZipFile.java:180)
      at java.util.jar.JarFile.getBytes(JarFile.java:361)
      at java.util.jar.JarFile.getManifestFromReference(JarFile.java:161)
      at java.util.jar.JarFile.getManifest(JarFile.java:148)
      autorestart: Process died in less than 30 seconds; not restarting

      If I roll back to jdk1.6.0_17, Coldfusion8 starts without issue. I have also tried to install patches 125136-21 and 125137-21 from the java website and at install I get a message that the downloads are corrupt. Any one have any advice?
        • 1. Re: jdk1.6.0_19 issues
          843804
          Hi Mike,

          Perhaps this is a ColdFusion8 issue rather than a JDK issue.
          Looking at the System Requirements for ColdFusion8 from http://www.adobe.com/products/coldfusion/coldfusion8/systemreqs/, it looks as though only JDK 1.6.0_04 is supported, though this is far from the expertise of the people on this alias.

          I'm going to move this thread to one of the Java Forums, as I think you've a better chance of getting a reply there (this forum is geared towards issues with the patches, such as installation or backout issues, while your issue seems to be a problem with the patches deliverables).

          HTH,
          -Don
          • 2. This Thread is now moved
            843804
            Note: This thread was originally posted in the [Patch Issues|http://forums.sun.com/forum.jspa?forumID=1028] forum, but moved to this forum for closer topic alignment.
            • 3. Re: jdk1.6.0_19 issues
              843804
              Hi Mike,

              >
              I have also tried to install patches 125136-21 and 125137-21 from the java website and at install I get a message that the downloads are corrupt. Any one have any advice?
              Can you give me some details about the corrupt download of 125136-21 and 125137-21 and I can follow up?

              I have been able to successfully download and unzip these files from SunSolve - i.e.:
              http://sunsolve.sun.com/pdownload.do?target=125136-21&method=h
              http://sunsolve.sun.com/pdownload.do?target=125137-21&method=h

              so the patches themselves seems to download and unzip ok.

              Best,
              -Don