0 Replies Latest reply: Oct 2, 2008 1:26 AM by 843804 RSS

    Weblogic 9 upgrade

    843804
      Hi,

      I'm not sure if this is the right place for this post but I'm trying...

      I upgrade WL 8 to 9 (9.2), so I installed the JDK 1.5 as well but I fail on:

      <Sep 29, 2008 10:18:23 AM IDT> <Critical> <WebLogicServer> <BEA-000386> <Server subsystem failed. Reason: java.lang.NoClassDefFoundError
      [exec] java.lang.NoClassDefFoundError
      [exec] at weblogic.diagnostics.instrumentation.engine.xbean.WlsEngineDocument$Factory.parse(WlsEngineDocument.java:193)
      [exec] at weblogic.diagnostics.instrumentation.engine.InstrumentationEngineConfiguration.parse(InstrumentationEngineConfiguration.java:208)
      [exec] at weblogic.diagnostics.instrumentation.engine.InstrumentationEngineConfiguration.<init>(InstrumentationEngineConfiguration.java:187)
      [exec] at weblogic.diagnostics.instrumentation.engine.InstrumentationEngineConfiguration.getInstrumentationEngineConfiguration(InstrumentationEngineConfiguration.java:134)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationLibrary.loadInstrumentationEngineConfiguration(InstrumentationLibrary.java:119)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationLibrary.getInstrumentationLibrary(InstrumentationLibrary.java:96)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationManager.getAvailableMonitors(InstrumentationManager.java:248)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationManager.<init>(InstrumentationManager.java:105)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationManager.getInstrumentationManager(InstrumentationManager.java:121)
      [exec] at weblogic.diagnostics.instrumentation.InstrumentationSupport.getMonitor(InstrumentationSupport.java:44)
      [exec] at weblogic.jdbc.common.internal.ConnectionPool.<clinit>(ConnectionPool.java)
      [exec] at java.lang.Class.forName0(Native Method)
      [exec] at java.lang.Class.forName(Class.java:164)
      [exec] at weblogic.kernel.FinalThreadLocalList.initialize(FinalThreadLocalList.java:44)
      [exec] at weblogic.t3.srvr.PreConfigBootService.start(PreConfigBootService.java:69)
      [exec] at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:374)
      [exec] at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:125)
      [exec] at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:630)
      [exec] at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:402)
      [exec] at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:361)
      [exec] at weblogic.Server.main(Server.java:67)
      [exec] >
      [exec] <Sep 29, 2008 10:18:23 AM IDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
      [exec] <Sep 29, 2008 10:18:23 AM IDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
      [exec] <Sep 29, 2008 10:18:23 AM IDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>

      any idea???

      Thanks