0 Replies Latest reply on Aug 26, 2010 9:17 PM by 843804

    Java 6 U 21 fails to run anything java related

      I recently installed Java 6 u 21 on a PC running XP SP3 and IE8. I went to verify the install and got nothing but a white box with the words "Error: click here for details." It then freezes my browser for a few minutes until it starts running again, but it never actually loads the java object. Anything that has to do with java seems to cause this to happen. I've tried reinstalling java, verifying it's not being blocked by IE or firewalls, even a system restore didn't seems to fix it. It worked fine with update 20. I even tried reformatting the computer entirely and when I try to install java (which is the first thing I did right after windows updates) this message still comes up.

      The error message I get that pops up occaisionally is:

      Java Plug-in 1.6.0_21
      Using JRE version 1.6.0_21-b07 Java HotSpot(TM) Client VM
      User home directory = C:\Documents and Settings\Username

      c: clear console window
      f: finalize objects on finalization queue
      g: garbage collect
      h: display this help message
      l: dump classloader list
      m: print memory usage
      o: trigger logging
      q: hide console
      r: reload policy configuration
      s: dump system and deployment properties
      t: dump thread list
      v: dump thread stack
      x: clear classloader cache
      0-5: set trace level to <n>

      load: class jreCheck.class not found.
      java.lang.ClassNotFoundException: jreCheck.class
           at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
           at java.lang.ClassLoader.loadClass(Unknown Source)
           at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
           at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
           at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: open HTTP connection failed:http://www.java.com/jsp_utils/jreCheck/class.class
           at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
           at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
           at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
           at java.security.AccessController.doPrivileged(Native Method)
           ... 9 more
      Exception: java.lang.ClassNotFoundException: jreCheck.class

      I've more or less run out of ideas on how to fix this entirely. Has anyone else had this problem?

      Edited by: Evernight on Aug 26, 2010 2:17 PM