3 Replies Latest reply on Mar 18, 2010 4:57 PM by 843810

    Bad class file

      This is probably a very basic issue but here it goes: I've been developing a web application in tomcat. Originally we were using the JWSDP 1.3 bundle. I decided to download tomcat 4.1.3 and tried to run the application. I keep getting "bad class errors" and something about tag pool 13 of 10. Any clue as to what is causing the problem? I think it has something to do with the classpath environment variable in windows XP, unfortunately the IT people must have changed my user rights b/c I can no longer edit/change the System variables., I've tried adding a user variable CLASSPATH with the new path to the application, but it still doesnt seem to work.

      Thanks for any help
        • 1. Re: Bad class file
          database/DeleteBean.java [18:1] cannot access database.DBAccess
          bad class file: C:\TOMCAT\webapps\cecomproj\src\database\DBAccess.class
          bad constant pool tag: 13 at 10

          both files DeleteBean.java and DBaccess.java contain the line:

          package database;

          NetBeans doesn't seem to have any problems compiling other classes (even with dependancies on other packages). Just all the files in my tomcat project.

          Any help would be appreciated.
          • 2. Re: Bad class file
            ok.... I figured out my problem... nothing to do with Classpaths, more something to do with checking class files out of CVS (I think) once I deleted the class files, everything else compiled fine.
            • 3. Re: Bad class file
              Because this is the only post Google returns for "netbeans bad constant pool tag", I'd like to add this (even though the post is many years old):
              The original post mentions Windows XP and CVS - so my recent experience may be relevant.
              I moved a bunch of Netbeans projects via Windows onto a Linux server to add them to a CVS repository.
              When I reentered the Projects into Netbeans all hell broke loose : for example: projects compiled clean but the IDE red-flagged them; libraries showed up on the Project Property sheets but were absent in the Libraries tab under the Project in the Projects tree. Netbeans itself appeared to be "in distress".
              I had noticed that many java sources were now double-spaced (a blank line inserted after each original line). I suspected somewhere during the journey from Windows to Linux the old carriage-return + line-feed glitch had happened. But, hey-ho, this doesn't effect the java and could be filtered out later.
              Then the moment of revelation: most of the XML and .properties files had also been double-spaced.
              So code that originally read (for example):


              now read:




              This (subtle) introduction of the extra lines ruins everything ... but once you realise what's happened, it is easily fixed !