3 Replies Latest reply on Dec 19, 2002 8:35 AM by 327524

    Error in running sample AQ code !

    327524

      hello,
      i have been trying to test the Oracle9i Advanced Queuing Sample. i have compiled and deployed the application following the "install.heml" instructions.
      when i enter the user name and password n login . i get the following error :

      *******************************************************
      500 Internal Server Error
      oracle.xml.parser.schema.XSDException: Element 'schema' has invalid namespace: 'http://www.w3.org/1999/XMLSchema'
           at oracle.xml.parser.schema.XSDBuilder.buildSchema(XSDBuilder.java:492)
           at oracle.xml.parser.schema.XSDBuilder.build(XSDBuilder.java:300)
           at oracle.xml.parser.schema.XSDBuilder.build(XSDBuilder.java:282)
           at ControllerServlet.parseXML(ControllerServlet.java:304)
           at ControllerServlet.init(ControllerServlet.java:126)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].server.http.HttpApplication.loadServlet(HttpApplication.java:1949)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].server.http.HttpApplication.findServlet(HttpApplication.java:4338)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].server.http.HttpApplication.getRequestDispatcher(HttpApplication.java:2477)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:592)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].server.http.HttpRequestHandler.run(HttpRequestHandler.java:248)
           at com.evermind[Oracle9iAS (9.0.3.0.0) Containers for J2EE].util.ThreadPoolThread.run(ThreadPoolThread.java:64)

      ********************************************************

      Please help,
      Chhimi
        • 1. Re: Error in running sample AQ code !
          3330
          Hi Chhimi,
          There is some mismatch between the namespace expected by the XML parser and the namespace provided by the AQ jar files.
          Please check the versions of database and OC4J that you are using against the ones mentioned in the "Version Dependencies" section.
          Also make sure that you have followed the Step 7 of Install.html correctly.

          Thanks,
          Rajat
          • 2. Re: Error in running sample AQ code !
            327524
            thanks rajat for ur prompt reply !
            I was testing on OC4J 903. Now i redeployed to OC4J 902 and followed each of the steps carefully !
            I managed to login and do some operations. But when i try to place an order and submit the generated SOAP message (using AQServlet)
            I get the following error !

            **********************************************************

            java.lang.UnsatisfiedLinkError: no ocijdbc9 in java.library.path
                 at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1312)
                 at java.lang.Runtime.loadLibrary0(Runtime.java:749)
                 at java.lang.System.loadLibrary(System.java:820)
                 at oracle.jdbc.oci8.OCIDBAccess.logon(OCIDBAccess.java:298)
                 at oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:315)
                 at oracle.jdbc.oci.OracleOCIConnection.<init>(OracleOCIConnection.java:64)
                 at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:439)
                 at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:321)
                 at java.sql.DriverManager.getConnection(DriverManager.java:517)
                 at java.sql.DriverManager.getConnection(DriverManager.java:146)
                 at oracle.jdbc.pool.OracleOCIConnectionPool.createConnectionPool(OracleOCIConnectionPool.java:726)
                 at oracle.jdbc.pool.OracleOCIConnectionPool.<init>(OracleOCIConnec[i]
            Long postings are being truncated to ~1 kB at this time.
            • 3. Re: Error in running sample AQ code !
              327524
              Further...
              I hav loaded all the oci9 libraries now i get the below error:
              java.lang.NoSuchFieldError: OCIEnvHandle
                   at oracle.jdbc.oci8.OCIDBAccess.make_c_state(Native Method)
                   at oracle.jdbc.oci8.OCIDBAccess.logon(OCIDBAccess.java:309)
                   at oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:307)
                   at oracle.jdbc.oci.OracleOCIConnection.<init>(OracleOCIConnection.java:64)
                   at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:439)
                   at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:321)

              Wher hav i gone wrong
              Thanks,
              Chhimi