1 Reply Latest reply on Jan 4, 2005 6:18 PM by 796254

    abt pathsetting for j2ee

    807596
      I have problem with installing J2EE 1.4 SDK.
      i downloded it from http://java.sun.com/j2ee/1.4/download.html
      and installed all bundles as per the instractions .
      Then I set the path in System properties as follows

      CLASSPATH.;c:\jdk\bin;c:\lib\j2ee.jar;c:\jdk\lib\tools.jar;.
      PATH c:\jdk\bin;c:\jdk\jre\bin;c:\jdk\jre\bin\client;c:\bin
      JAVA_FONTS %SYSTEMROOT%\FONTS
      J2EE_HOME c:\
      JAVA_HOME c:\jdk

      The OS that i use is WinXp.
      when i did start j2ee -verbose in by comand prompt
      windows give a error message that it cant find j2ee .
      so how can i solve the problem.
      when i do set comand in my command promot it displays :

      C:\Documents and Settings\Rakhi>set
      ALLUSERSPROFILE=C:\Documents and Settings\All Users
      APPDATA=C:\Documents and Settings\Rakhi\Application Data
      CLASSPATH=.;c:\jdk\bin;c:\lib\j2ee.jar;c:\jdk\lib\tools.jar;.
      CLIENTNAME=Console
      CommonProgramFiles=C:\Program Files\Common Files
      COMPUTERNAME=RAKHIPREM
      ComSpec=C:\WINDOWS\system32\cmd.exe
      HOMEDRIVE=C:
      HOMEPATH=\Documents and Settings\Rakhi
      J2EE_HOME=c:\
      JAVA_FONTS=C:\WINDOWS\FONTS
      JAVA_HOME=c:\jdk
      LOGONSERVER=\\RAKHIPREM
      NUMBER_OF_PROCESSORS=1
      OS=Windows_NT
      Path=c:\jdk\bin;c:\jdk\jre\bin;c:\jdk\jre\bin\client;c:\bin;C:\\bin
      PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
      PROCESSOR_ARCHITECTURE=x86
      PROCESSOR_IDENTIFIER=x86 Family 15 Model 4 Stepping 10, AuthenticAMD
      PROCESSOR_LEVEL=15
      PROCESSOR_REVISION=040a
      ProgramFiles=C:\Program Files
      PROMPT=$P$G
      SESSIONNAME=Console
      SystemDrive=C:
      SystemRoot=C:\WINDOWS
      TEMP=C:\DOCUME~1\Rakhi\LOCALS~1\Temp
      TMP=C:\DOCUME~1\Rakhi\LOCALS~1\Temp
      USERDOMAIN=RAKHIPREM
      USERNAME=Rakhi
      USERPROFILE=C:\Documents and Settings\Rakhi
      windir=C:\WINDOWS

      when i did start deploytool my out put is like

      Usage: java [-options] class [args...]
      (to execute a class)
      or java [-options] -jar jarfile [args...]
      (to execute a jar file)

      where options include:
      -client to select the "client" VM
      -server to select the "server" VM
      -hotspot is a synonym for the "client" VM [deprecated]
      The default VM is client.

      -cp <class search path of directories and zip/jar files>
      -classpath <class search path of directories and zip/jar files>
      A ; separated list of directories, JAR archives,
      and ZIP archives to search for class files.
      -D<name>=<value>
      set a system property
      -verbose[:class|gc|jni]
      enable verbose output
      -version print product version and exit
      -version:<value>
      require the specified version to run
      -showversion print product version and continue
      -jre-restrict-search | -jre-no-restrict-search
      include/exclude user private JREs in the version search
      -? -help print this help message
      -X print help on non-standard options
      -ea[:<packagename>...|:<classname>]
      -enableassertions[:<packagename>...|:<classname>]
      enable assertions
      -da[:<packagename>...|:<classname>]
      -disableassertions[:<packagename>...|:<classname>]
      disable assertions
      -esa | -enablesystemassertions
      enable system assertions
      -dsa | -disablesystemassertions
      disable system assertions


      please find my error give a satisfactionary reply.
        • 1. Re: abt pathsetting for j2ee
          796254
          and installed all bundles as per the instractions .
          It sounds like you put all the J2EE stuff at root level. That sounds like a terrible idea to me.
          CLASSPATH.;c:\jdk\bin;c:\lib\j2ee.jar;c:\jdk\lib\tools.jar;.
          I find that setting a system CLASSPATH is a bad idea, too. I don't have one.
          PATH
          c:\jdk\bin;c:\jdk\jre\bin;c:\jdk\jre\bin\client;c:\bin
          What about the Windoze %SYSTEM% stuff? The PATH doesn't look right to me.
          JAVA_FONTS %SYSTEMROOT%\FONTS
          J2EE_HOME c:\
          JAVA_HOME c:\jdk

          The OS that i use is WinXp.
          when i did start j2ee -verbose in by comand prompt

          windows give a error message that it cant find j2ee
          .
          so how can i solve the problem.
          Figure out why Windoze doesn't think j2ee.bat is in your PATH.
          please find my error give a satisfactionary reply.
          Your PATH is obviously bad.

          %