This discussion is archived
1 Reply Latest reply: Feb 22, 2010 4:40 AM by 843830 RSS

Cannot deploy HL7BC pass-through jsb - start error

843830 Newbie
Currently Being Moderated
After having configured and built a HL7 BC pass-through I am now having problems deploying it on a glassfish esb. I am getting the following error.

C:\Documents and Settings\als\My Documents\NetBeansProjects\HL7athenatohislisApp\nbproject\build-impl.xml:192: Start failure.
BUILD FAILED (total time: 7 seconds)

which refers to the following line:

<jbi-deploy-service-assembly serviceAssemblyID="${jbi.service-assembly.id}" serviceAssemblyLocation="${basedir}/${dist.jar}" netBeansUserDir="${netbeans.user}" j2eeServerInstance="${j2ee.server.instance}"/>

I have not received this error on similar projects, before.

Any ideas?

Edited by: allan3670 on Feb 21, 2010 9:14 AM
  • 1. Re: Cannot deploy HL7BC pass-through jsb - start error
    843830 Newbie
    Currently Being Moderated
    a little extra info..I can see that it is a problem with sun-hl7-binding which fails to initialize.

    ERROR: Successful execution of Start: HL7athenatohislisApp
    WARNING: (JBIMA0405) Start of service assembly HL7athenatohislisApp succeeded partially; some service units failed to start.
    * Component: sun-hl7-binding
    ERROR: (HL7BC_INIT_1) HL7BC-E0159: Failed to initialize service unit HL7athenatohislisApp-sun-hl7-binding due to :
    * Component: sun-bpel-engine
    INFO: (JBIMA0409) Lifecycle operation start succeeded for Service Unit HL7athenatohislisApp-HL7athenatohislis.