10 Replies Latest reply on Jan 23, 2003 1:53 PM by 807594

    an applet explanation

    807594
      after installing jdk 1.4.1 plug-in, it's made my applet fail. i know it's because of the new plugin and IE 6.0.28. i saw the applet before when the browser was using MS VM but now when i try going back to it, it doesn't work anymore. how can i get it to work again? i've tried going back and forth with using the plug-in then the VM and vice versa. do i need to downgrade my IE browser? i've also tried netscape 6.0 and it doesn't work there either. also, if this helps, i recently did a windows update for windows 2000.

      any good explanation for this?
        • 1. Re: an applet explanation
          807594
          doh, my apologize, i meant netscape 7.0. :)
          • 2. Re: an applet explanation
            798701
            Is this just one applet or do all applets fail now?

            Is there any error message given in the java console?
            • 3. Re: an applet explanation
              807594
              just this one applet that worked fine before. i've tried other applets before and some work and some don't.

              i do have the error messages in the java console ... i'll post them up as soon as it's down loading. for some strange reason, it takes a few minutes.
              • 4. Re: an applet explanation
                807594
                status bar message: Applet Corf_Scroller notinited

                java console message on my machine:

                load: class Corf_Scroller.class not found.
                java.lang.ClassNotFoundException: Corf_Scroller.class
                     at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:153)
                     at sun.plugin.security.PluginClassLoader.findClass (PluginClassLoader.java:168)
                     at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
                     at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:114)
                     at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
                     at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:506)
                     at sun.applet.AppletPanel.createApplet(AppletPanel.java:566)
                     at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1775)
                     at sun.applet.AppletPanel.runLoader(AppletPanel.java:495)
                     at sun.applet.AppletPanel.run(AppletPanel.java:292)
                     at java.lang.Thread.run(Thread.java:536)
                Caused by: java.net.SocketException: Connection reset
                     at java.net.SocketInputStream.read(SocketInputStream.java:168)
                     at java.net.SocksSocketImpl.readSocksReply(SocksSocketImpl.java:72)
                     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:348)
                     at java.net.Socket.connect(Socket.java:426)
                     at sun.net.NetworkClient.doConnect(NetworkClient.java:137)
                     at sun.plugin.net.protocol.http.HttpClient.doConnect(HttpClient.java:93)
                     at sun.net.www.http.HttpClient.openServer(HttpClient.java:386)
                     at sun.net.www.http.HttpClient$3.run(HttpClient.java:435)
                     at java.security.AccessController.doPrivileged(Native Method)
                     at sun.net.www.http.HttpClient.privilegedOpenServer(HttpClient.java:432)
                     at sun.net.www.http.HttpClient.openServer(HttpClient.java:579)
                     at sun.net.www.http.HttpClient.<init>(HttpClient.java:303)
                     at sun.net.www.http.HttpClient.<init>(HttpClient.java:264)
                     at sun.plugin.net.protocol.http.HttpClient.<init>(HttpClient.java:39)
                     at sun.plugin.net.protocol.http.HttpClient.New(HttpClient.java:66)
                     at sun.plugin.net.protocol.http.HttpURLConnection.privBlock(HttpURLConnection.java:116)
                     at sun.plugin.net.protocol.http.HttpURLConnection$PrivilegedBlockAction.run(HttpURLConnection.java:460)
                     at java.security.AccessController.doPrivileged(Native Method)
                     at sun.plugin.net.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:167)
                     at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:375)
                     at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:238)
                     at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:250)
                     at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:42)
                     at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:143)
                at java.security.AccessController.doPrivileged(Native Method)
                     at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:140)
                     ... 10 more

                on another machine, java console error:

                load: class Corf_Scroller.class not found.
                java.lang.ClassNotFoundException: Corf_Scroller.class
                     at sun.applet.AppletClassLoader.findClass(Unknown Source)
                     at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)
                     at java.lang.ClassLoader.loadClass(Unknown Source)
                     at sun.applet.AppletClassLoader.loadClass(Unknown Source)
                     at java.lang.ClassLoader.loadClass(Unknown Source)
                     at sun.applet.AppletClassLoader.loadCode(Unknown Source)
                     at sun.applet.AppletPanel.createApplet(Unknown Source)
                     at sun.plugin.AppletViewer.createApplet(Unknown Source)
                     at sun.applet.AppletPanel.runLoader(Unknown Source)
                     at sun.applet.AppletPanel.run(Unknown Source)
                     at java.lang.Thread.run(Unknown Source)
                Caused by: java.io.IOException: open HTTP connection failed.
                     at sun.applet.AppletClassLoader.getBytes(Unknown Source)
                     at sun.applet.AppletClassLoader.access$100(Unknown Source)
                     at sun.applet.AppletClassLoader$1.run(Unknown Source)
                     at java.security.AccessController.doPrivileged(Native Method)
                     ... 11 more
                • 5. Re: an applet explanation
                  798701
                  The site is screwed, not your computer.

                  All you can do is bug the site maintainers. Did you find a "webmaster" or "feedback" link somewhere?
                  • 6. Re: an applet explanation
                    807594
                    the previous site maintainers are currently working on it. i'm the new person they brought in and am trying to see what the problem is. since i'm new to java, i'm having a harder time with this then i intended.

                    there are two web servers in which this applet resides in. on the production server, it works just fine on my machine with ie 6 and plug-in. the development server is the one giving me problems. does this help: when i tried browsing that applet directly on the development server (running linux), a message comes up and says "this page contains info of a type (application/x-java-vm) that can only be viewed with the appropriate plug-in." should that have anything to do with why i can't see the applet on there anymore? i was able to see the applet before i made text changes to it and installed plug-in. any help on that? thx!
                    • 7. Re: an applet explanation
                      798701
                      i was able to see the applet
                      before i made text changes to it
                      To what, the applet? Or the HTML code of the page that has the applet?

                      First, are the HTML codes for the applet on the dev machine and production machine identical?

                      The error message says "class Corf_Scroller.class not found", but ".class" is never a part of the class name, so it could be that e.g. the code attribute in the applet tag has the wrong value.
                      • 8. Re: an applet explanation
                        807594
                        sorry, the text is within the applet code:

                        <applet code="Corf_Scroller.class" codebase=".." width="440" height="25" alt="If you could run this applet, you'd see scrolling text">
                        <PARAM NAME="Corf_Timer" VALUE="20">
                        <PARAM NAME="Corf_Link" VALUE="special.htm">
                        <PARAM NAME="Corf_Text" VALUE="****">
                        <PARAM NAME="Corf_ForeGround" VALUE="000000">
                        <PARAM NAME="Corf_Size" VALUE="1">
                        <PARAM NAME="Corf_Thickness" VALUE="2">
                        <PARAM NAME="Corf_Font" value="verdana">
                        Your browser is completely ignoring the <APPLET> tag!
                        </applet>

                        Yes, the HTML codes are identical on both the prod and dev machines.

                        In the applet code, ".class" is a part of the class name. Is there another reason why that error exists, "class Corf_Scroller.class not found?" Thx!
                        • 9. Re: an applet explanation
                          798701
                          <applet code="Corf_Scroller.class" ...
                          Try changing that to
                          <applet code="Corf_Scroller" ...
                          Is there another reason why that error exists,
                          "class Corf_Scroller.class not found?" Thx!
                          I'm not sure how the class loader would build its error messages, but never the proper class name ends with ".class".
                          Yes, the HTML codes are identical
                          on both the prod and dev machines.
                          Can you find the file "Corf_Scroller.class" one directory level up the html code? That's where the code is pointing to. i.e. the dir structure should be

                          /foo/yourHTMLfile.html
                          /Corf_Scroller.class

                          If it's there check that you can access it from the web.
                          • 10. Re: an applet explanation
                            807594
                            The Corf_Scroller.class is actually in the same directory as the HTML code. Is that a problem?

                            I just found out recently that the spanish text version of the applet located on the same server (development), works just fine. I'm thinking it might be the source code but then again I just change the text for the applet, which works fine in the production server. Any explanation for why it works for the spanish page and not the english when the source code is the same and on the same server with the only exception of the applet text being different?

                            Thx again!