This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Nov 19, 2012 6:25 AM by crs13 RSS

Datapump and error on virtual columns (second)

790441 Newbie
Currently Being Moderated
I've asked for that problem already two month ago.

The problem:
I've some tables with calculated/virtual columns. And we use DataPump to copy the real data on a testing machine.
All tables with calculated columns are empty due to an error (ORA-31693 → ORA-54013).
Now I've two choices:
not to use virtual columns in dayly work
or transfer the lost data by handmade INSERT-statements.

Now I've found a discussion in an other forum and they mentioned a bug 6357106.
Is it possible to see this bug?
Are there other people that suffers on it?
Is there any hope for a solution next month?


http://kr.forums.oracle.com/forums/thread.jspa?threadID=853393

I recently used expdp (Export Datapump) to export a schema to another Database.
When I used impdp (Import Datapump) the insert failed for the table containing a Virtual Column.
ORA-31693: Table data object "SCHEMA"."TABLENAME" failed to load/unload and is being skipped due to error:
ORA-54013: INSERT operation disallowed on virtual columns
Are there any plans anyone knows of that to fix this? If not, then what would be the explanation as to why?
Cheers,
Mike
Satish Kandi:
Metalink reveals this to be classified as a bug 6357106 for 11.1.0.6.0 (under different circumstances) and there is no fix available yet.
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points