This discussion is archived
6 Replies Latest reply: Jul 26, 2009 11:56 PM by 843833 RSS

Problem running Java Pet Store

843833 Newbie
Currently Being Moderated
Hello All,

I downloaded the Java Pet Store demo, and I followed the instruction to install the application. However, when I type in localhost:8000/petstore, I got 404 error. But if I type in localhost:8000/admin, I can get to the admin page. That is weird. But then, when I click on "launch the rich client", the client came up with a fatal error that has no error description.

So my questions are:
1. Does anyone know what's wrong and how to resolve it?
2. Can this Pet Store demo be installed on JBoss or Tomcat instead?

I looked around the download site and read the FAQs, but I cannot find the answer.

My setups are:
J2SE SDK 1.4.2
J2EE SDK 1.3.1
Windows 2000 pro
(I don't know if this matters or not, but I am running jboss-3.2.1_tomcat-4.1.24 and tomcat-4.1.24 standalone on different ports.)

Any help will be very much appreciated.
  • 1. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated
    I do not have any idea what I'm talking about which is why I was searching the forums for JBoss to find out a bit more! But should it not be 8080?
  • 2. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated
    It was just a typo.
  • 3. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated

    I am also having no luck starting the RI Application Server
    with the configuration you describe (J2EE SDK 1.3.1/J2SE 1.4.2
    on Windows 2000 Pro). I tried installing the J2EE SDK 1.4b2
    bundle and the server still fails to start. I have all of
    necessary ports available on my machine. Here is the last line
    I get in the app server log:

    <[INFO][j2eesdk1.4_beta2][][][10][javax.enterprise.system.tools.admin][07.November.2003 17:48:51:422 CST][ADM0102: Starting a thread for tracking manual changes]>

    I just want to get the Pet Store application running. Any ideas
    what issue I'm having?
  • 4. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated

    I have now been able to start the Application Server successfully
    and deploy the Pet Store with the J2EE 1.4b2 bundle, after changing
    the HTTP listen port from 1024 to 8000.

    Now it appears there is a bug in the Pet Store application, upon
    trying to enter the application for the first time
    (http://localhost:8000/petstore/populating.jsp?forcefully=false)
    A SQLException is thrown due to an invalid table name "CustomerEJB".
    I just tried to log this in Sun's Bug Database, which also failed when I tried to submit the report.

    I'm about to give up. Anybody been able to use the Pet Store app
    after installing this bundle (j2eesdk-1_4-beta2-windows-eval.zip)?

    Greg

  • 5. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated
    My guess is that the petstore and OPC applications were not installed successfully. The client will come up fine but it can not connect to the OPC and thus failed. You may want to watch the output of running the setup.bat script carefully to see if any errors were reported. You can also check the logs of the J2EE 1.3.1 to see what errors are reported.

    You will not be able to run the petstore only on tomcat since it needs EJBs. This version will not run on JBoss automatically, but I have seen JBoss versions of the petstore, so check their website or search on google.
  • 6. Re: Problem running Java Pet Store
    843833 Newbie
    Currently Being Moderated
    Sorry for deviation from topic, but ccould anyone tell me that which version of Petstore is compatible with JBoss 5.0 ???