0 Replies Latest reply: Dec 7, 2005 1:53 AM by 843844 RSS

    Can i use Weblogic 6.1 SP6 with J2SDK 14.2

    843844
      Hi it was working very fine with weblogic 6.1 SP6 with J2SDK 1.3.2 . But recently i changed to J2SDk 1.4.2 with same weblogic 6.1 SP6 and tried to start the Weblogic Server first i got following error.

      java.lang.SecurityException: Unable to locate a login configuration
      at com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:97)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           � lines deleted
      at javax.security.auth.login.LoginContext$1.run(LoginContext.java:170)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.login.LoginContext.init(LoginContext.java:167)
      at javax.security.auth.login.LoginContext.<init>(LoginContext.java:393)
      at weblogic.security.internal.ServerAuthenticate.main(ServerAuthenticate)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:200) at weblogic.Server.main(Server.java:35)

      Some how i solved this problem by creating login configuration login.config file and using jaas.jar file.

      But now again i am getting someother problem when i am strating the weblogic server given below

      Error loading servlet: 'Initializer'
      java.lang.ExceptionInInitializerError
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
      at java.lang.Class.newInstance0(Class.java:308)
      at java.lang.Class.newInstance(Class.java:261)
      at javax.rmi.CORBA.Util.createDelegateIfSpecified(Util.java:339)
      at javax.rmi.CORBA.Util.<clinit>(Util.java:51)
      at javax.rmi.PortableRemoteObject.createDelegateIfSpecified(PortableRemoteObject.java:179)
      at javax.rmi.PortableRemoteObject.<clinit>(PortableRemoteObject.java:58)
      Lines deleted           
      at javax.servlet.GenericServlet.init(GenericServlet.java:258)
      at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:744)
      at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:671)
      at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:616)
      at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2419)
      at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2360)
      at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:571)
      at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
      at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
      at java.lang.Thread.run(Thread.java:534)
      Caused by: java.lang.RuntimeException: could not find or instantiate any UtilDelegate class
      at weblogic.iiop.UtilDelegateImpl.<clinit>(UtilDelegateImpl.java:74)
      ... 25 more
      Any help would be greatly appreciated.........