0 Replies Latest reply on Feb 15, 2008 10:15 AM by 843844

    i can't run the structs application -It shows 404 error(page not found)

    843844
      Hi friends,

      i am using small tiles application in struts. Here i wrote my code which is in the web.xml and struts-config.xml. I am using Tomcat 5.0 server

      I included pulg-in tag in the struts-config.xml as shown in below.
      =-===========================================

      <plug-in className="org.apache.struts.tiles.TilesPlugin" >
      <!-- Path to XML definition file -->
      <set-property property="definitions-config" value="/WEB-INF/tiles-defs.xml" />
      <!-- Set Module-awareness to true -->
      <set-property property="moduleAware" value="true" />
      </plug-in>

      and mapping also done in struts-config.xml:
      ===============================
      <action-mappings >
      <action path="/click" forward="Tiles.Examaple"></action>
      </action-mappings>

      here i used exta one xml filenamed as tiles-defs.xml
      =======================================
      here the tag in tiles-defs.xml
      <tiles-definitions>
      <definition name="Tiles.Example" page="/tiles/template.jsp">
      <put name="title" type="string" value="Welcome" />
      <put name="header" value="/tiles/top.jsp" />
      <put name="menu" value="/tiles/left.jsp" />
      <put name="body" value="/tiles/content.jsp" />
      <put name="bottom" value="/tiles/bottom.jsp" />
      </definition>

      <definition name="${YOUR_DEFINITION_HERE}">
      </definition>
      </tiles-definitions>