0 Replies Latest reply: Sep 18, 2008 5:03 PM by 843849 RSS

    CDC on Netbeans

    843849
      I am using Netbeans 6.1 and I have jdk1.5 and CDCTK10. I generate a CDC project
      and I setup some code - however at compilation it fails complaining about String
      not having a contains method or about generics. This means that the compiler
      has to be older than 1.5. I check the project properties and it shows javac target
      and source to be 1.4. First of why is that the case? I look at the Java Platform
      in the menu and it shows the 1.5 installed. Why is it showing 1.4 in the properties
      file. Also since I don't have 1.4 installed on my machine, why I am getting compilation
      errrors as if the 1.4 is being used?

      Any ideas ?

      Thanks