This discussion is archived
1 Reply Latest reply: Jul 9, 2009 8:06 AM by 843851 RSS

Probleme with Java SE for Embedded 6 on a ARM9

843851 Newbie
Currently Being Moderated
Hello!
I try to run the ejre1.6.0_10 soft float jvm on my device with a ARM9 from Marvell.
I've checked the requires(I've got kernel 2.6.22, gcc 4.2.1 and glibc 2.5 ) but running java on my device return a :

[root@myDev ejre1.6.0_10]# java
Illegal instruction

Any Idea about this error? how can i get more information?


May be there is no link, but I also try to launch it on a Scratchbox (Emulation evironement) adapted to my system and I get:
[sbox-myDev: ~/ejre1.6.0_10/bin] > ./java
Inconsistency detected by ld.so: ../sysdeps/unix/sysv/linux/dl-origin.c: 48: dlget_origin: Assertion `linkval[0] == '/'' failed!


Thanks for any help!