8 Replies Latest reply: Dec 20, 2012 6:33 PM by JV123 RSS

    DAC is running Full load instead of Incremental Load

    Ranganathan
      Hi Everyone,

      The Excecution plan in the dac is running Fullload for every one run instead of Incremental Load. I checked the EP,Tasks and Tables no where it is set as Full load always. the issue came in the Prod but in the DEV and Test it is working fine..

      Please help me in it we are in Prod

      Thanks
      Ranga
        • 1. Re: DAC is running Full load instead of Incremental Load
          RAM CH
          check the execution plan in execute tab. you have an option called Full Load allways. if this option is ticked DAC will all ways execute full loads.
          • 2. Re: DAC is running Full load instead of Incremental Load
            Ranganathan
            Hi Ram,

            Thanks for ur reply, but i have checked all the options at EP level at table level and task level but no where the full load or truncate always is checked .

            Is there any thing i missed

            Ranga
            • 3. Re: DAC is running Full load instead of Incremental Load
              66787
              By default the second run (after first full run) of ETL in DAC is incremental run, it looks at the time stamp of each table and runs incremental load unless you reset the data...
              Why do you think it is running full ETL for all tables? Some tables may be reloaded every ETL run but that is by design.
              • 4. Re: DAC is running Full load instead of Incremental Load
                user11173172
                Please verify the following

                1.Can you verify if the refresh dates are stamped for your source and DW tables. Go to Setup-->Physical Data Sources--> ( Click on your connection name and in the bottom pane click on Refresh Dates
                2. Check the Execution Plan if the Full Load Always check box is selected in the bottom Edit Pane
                3. Did your previous execution plan complete successfully. DAC stamps Refresh Date time stamps for the table only if execution plan is successfully completed.
                4. Check if all the tasks are running in FULL, if not as Shyam explained some tables will be reloaded for every ETL run which is by design

                Hope this helps
                • 5. Re: DAC is running Full load instead of Incremental Load
                  Ranganathan
                  Hi Guys,

                  I checked all the Refresh dates but no output.

                  At last i justed assembled the subject area and generate the parameters in EP and BUild it then the Refresh dates are inserted


                  Regards
                  Ranga
                  • 6. Re: DAC is running Full load instead of Incremental Load
                    822118
                    Hi All DAC Gurs,

                    It is pretty good answer.

                    However in the first point u said click on "Refersh dates". After clicking refersh I am not able to see any thing.

                    Does I need to click on "New" or any other setting is required.

                    Could you please clarify more on this......................

                    I am running Incremental Load I am facing same issue.

                    am not able to find how to setup incremental load.

                    Select $$LAST_EXTRACT_DATET in Source system parameter

                    Edit value button then new window will appear

                    Choosen Runtime button and select variable as @DAC_SOURCE_PRUNED_REFRESH_TIMESTAMP
                    Choosen Custom Format from drop down Function
                    Mention the date format as MM/DD/YYYY HH24:MI:SS

                    I am having Following values in "Runtime" drop down box
                    @DAC_ETL_START_TIME
                    @DAC_ETL_START_TIME_FOR_SOURCE
                    @DAC_ETL_START_TIME_FOR_TARGET
                    @DAC_ETL_PRUNED_START_TIME
                    @DAC_ETL_PRUNED_START_TIME_FOR_SOURCE
                    @DAC_ETL_PRUNED_START_TIME_FOR_TARGET
                    @DAC_CURRENT_TIMESTAMP
                    @DAC_SOURCE_REFERSH_TIMESTAMP
                    @DAC_TARGET_REFERSH_TIMESTAMP
                    @DAC_SOURCE_PRUNED_REFERSH_TIMESTAMP
                    @DAC_TARGET_PRUNED_REFERSH_TIMESTAMP

                    Please reslove my issue.
                    • 7. Re: DAC is running Full load instead of Incremental Load
                      881478
                      iam facing same problem , please did anyone found a solution for this ???
                      • 8. Re: DAC is running Full load instead of Incremental Load
                        JV123
                        You should run full load for the first time using DAC and after full load refresh dates registerd in DAC and all subsequent runs will be automatically incremental run unless you reset refresh dates in dac. never check always run full load.

                        if you still not clear try synchronize all tasks, assemble subject areas, genertae parameters and build execution plan and run full load and once full load is completed then run same execution plan and it will do incremental by default.

                        Thanks
                        Jay.