2 Replies Latest reply: Mar 30, 2009 5:14 AM by 807557 RSS

    Problems installing jRTS in a debian distribution

    807557
      After the instalation of jRTS2.1, I executed java but it didn't work. I think there is a problem with libgc but I am not able to fixe it. Can somebody help me out with it?

      # The way I invoke java
      pbasanta:~/jrts2.1/bin$ ./java
      dl failure on line 820Error: failed /var/home/pbasanta/jrts2.1/jre/lib/i386/client/libjvm.so, because /lib/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /var/home/pbasanta/jrts2.1/jre/lib/i386/client/libjvm.so)
      pbasanta:~/jrts2.1/bin$

      #My linux distribution
      pbasanta@:~/jrts2.1/doc$ dmesg
      Linux version 2.4.27-3-386 (pbuilder@dl360-g3) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 Wed Dec 6 00:38:33 UTC 2006
      BIOS-provided physical RAM map:

      #libpthread version
      pbasanta@:~/jrts2.1/doc$ strings /lib/libpthread.so.0 |grep GLIBC_
      GLIBC_2.0
      GLIBC_2.1
      GLIBC_2.1.1
      GLIBC_2.1.2
      GLIBC_2.2
      GLIBC_2.2.3
      GLIBC_2.2.6
      GLIBC_2.3.2
      GLIBC_PRIVATE
      GLIBC_2.1.3
      GLIBC_2.3

      Any idea of what is wrong in my config?
      Thanks,
      Pbl

      Edited by: pbasanta@ on Mar 29, 2009 10:37 AM
        • 1. Re: Problems installing jRTS in a debian distribution
          807557
          Sorry that isn't a supported Linux platform. From the release notes:

          http://java.sun.com/javase/technologies/realtime/reference/doc_2.1/release/JavaRTSReleaseNotes.html

          "... but currently the OS configuration needs to include a *2.6.21* Linux kernel or later with the latest RT patch. (See the site http://www.kernel.org/pub/linux/kernel/projects/rt/ to obtain the appropriate RT patch.) In addition, Java RTS will not run on a system with a glibc version prior to *2.4*; furthermore, to reduce issues with priority inversion, Java RTS needs either a system with glibc 2.5 or later, or else a system that has explicitly patched glibc with the necessary priority-inheritance mutex support from 2.5."

          David Holmes
          • 2. Re: Problems installing jRTS in a debian distribution
            807557
            I'll update the kernel,
            thanks,
            Pablo