11 Replies Latest reply on Apr 13, 2009 7:25 PM by 807557

    Error Updating Flash PROM on E250

    807557
      Hi,

      Can someone help me please.

      I new to SUN, I have bought a sun E250 server, installed Solaris 10.
        {0} ok .version
      Release 3.16 Version 1 created 1999/04/19 07:55
      OBP 3.16.1 1999/04/19 07:55
      POST 6.0.9 1999/04/19 07:57
      OBDIAG 4.5.1 1999/04/19 07:56
      I am trying to upgrade the PROM to the latest version 106503-09 (current version above , I have followed the instructions on the patch website and copied the file to / but I get the below error:
        {0} ok boot disk /flash-update-250-latest
      Boot device: /pci@1f,4000/scsi@3/disk@0,0 File and args: /flash-update-250-latest
      -
      Can't open /flash-update-250-latest 
      I have a EIS and SUE dvd's but the E250 does not have a dvd drive.

      Any help will be much appreciated.

      Thanks

      Edited by: racs on Feb 3, 2009 1:09 PM
        • 1. Re: Error Updating Flash PROM on E250
          807557
          Are the permission ok ?

          # chmod 755 /flash-update*
          • 2. Re: Error Updating Flash PROM on E250
            Copy the patch file(s) back to the root directory of your E250 boot drive and overwrite what's there, one more time. If you are FTP-ing it across to the E250 then do so in binary mode. The current copy might just be inadvertantly corrupt or incomplete.

            There is a Flash PROM write protect jumper on the systemboard, at locaton J2704.
            It can be difficult to reach, with some of the cables to the removable media drivebay in the way.

            Check that the jumper is in the factory default write-enable position, in case someone moved it in past years.
            [http://www.sunshack.org/data/sh/2.1/infoserver.central/data/syshbk/Devices/System_Board/SYSBD_E250.html#5440]
            • 3. Re: Error Updating Flash PROM on E250
              807557
              Thanks for the quick replies guys, this is what I've tried so far:

              Download the patch on a intel PC:
              - unzip and burn it on CD, then copy to / and chmod 755.
              - copy the .z file to a vmware solaris 10, mount the shared dir from the e250, copy and unzip to /

              I've downloaded and coped several times, no luck.

              The jumper is in the write enable position.

              If I was to download this directly to the e250, how could I do this as there is no gui.

              Thanks
              • 4. Re: Error Updating Flash PROM on E250
                It's been quite some time since I needed to do this, but all I ever did was get the downloaded file to the system in question. I would copy it to a working temporary directory and uncompress and untar it there.

                Then, following the guidance in [Step #4 of the README file for prom patch 106503|http://sunsolve.sun.com/search/advsearch.do?collection=PATCH&type=collections&queryKey5=106503&toDocument=yes] , you just copy the needed files to the root of your boot drive.

                The rest of the instructions are straightforward, including the syntax of
                boot disk /flash-update-250-latest
                from the OK prompt.

                Oh. I never bother with the signed version of those patches.
                The unsigned ones used to be the smaller file and I just got into a routine that ignored the signed version (which is un-jarred to get the contents out of it).
                • 5. Re: Error Updating Flash PROM on E250
                  799949
                  you have to follow the directions... it is only command line... make sure of the name of the update, sometimes the names get truncated. when the E250 just posts --- splash screen--- press the stop key AND the A key... then follow the instructions...

                  yes, make sure the files are in / directory... not in a folder...

                  haroldkarl
                  • 6. Re: Error Updating Flash PROM on E250
                    807557
                    Yes, the file is in the root / directory.....getting a bit frustrated, only other option is to go on eBay for a SCSI DVD drive, though they are expensive (more than I paid for the server).
                    • 7. Re: Error Updating Flash PROM on E250
                      799949
                      when you get the files unzipped and on the / directory, what are the names of the files? Are they identical to how they are listed on the patch page? sometimes the names are truncated (didn't I say this before?)... I don't know what a dvdrom drive will do to help, it would be nice to have, but ebay sellers think they are made of gold!

                      you should be able to unzip the files in Solaris... it does take a while, you will lose hair, but it is possible... sorry, it has been too long since I have had to update a Sun box... it did take several tries... don't even ask me about updating the firmware on the Sun dvdrom drive... I had to take it out of the sun box and attach it to a peecee to get it done.

                      hang in there,
                      haroldkarl
                      • 8. Re: Error Updating Flash PROM on E250
                        807557
                        hi,

                        I can see the full name of the file as per the readme file, not truncated.

                        Apparently the SUE or EIS dvd has firmware for most servers, I thought booting from a dvd might work.
                        • 9. Re: Solved!
                          807557
                          Hi Guys,

                          I've managed to update the prom. I managed to get hold of Solaris 7 1 99, installed it on the another disk and them update worked first time.

                          I could have sworn that Solaris 10 was not on the list of OS on the flash website, hence I went hunting for an older version. But now I see S 10 is listed and it says OS dont matter......but I think it does.

                          Thanks for all your help.
                          • 10. Re: Error Updating Flash PROM on E250
                            807557
                            I have been having the same problem as everyone else in this thread with both my E220R and my E250. I have an idea of why the problem occurs and why some of the workarounds worked, but haven't been able to test the solution. I'm hoping someone else can work this angle also:

                            When the version of OBP for these older machines was written, it recognized the 'then' current version of the ufs filesystem. Solaris 10 uses an updated version of the ufs filesystem that the older OBP couldn't anticipate, and therefore, can't read. When an older version of Solaris is installed, the flash works because the filesystem is a version that the OBP recognizes.

                            The only older versions I have been able to try are 2.5 and 2.6 and I haven't been able to get them to work, yet. I'm trying to find Solaris 7 or 8 to try since others had success with them.

                            Can anyone else verify this as the problem?
                            • 11. Re: Error Updating Flash PROM on E250
                              807557
                              I finally found a copy of Solaris 7 and installed it on 'disk1'. I copied the OBP update to that disk and booted from it and the update worked fine--just like others have found. After restarting, I booted from 'disk0' with Solaris 10 on it and continued working.