7 Replies Latest reply on Jul 11, 2006 3:03 AM by 807557

    gmake gtrouble

    807557
      Hello. I am in the midst of installing php according the the directions on http://meljr.com/~meljr/PHPSolaris10.html. Right now I am trying to gmake in /usr/libxml2-2.6.12. When I enter "gmake", terminal returns:
      make  all-recursive
      /bin/bash: make: command not found
      gmake: *** [all] Error 127
      Gmake is in /usr/sfw/bin, which is in my path. When I enter
      "which gmake && gmake --version | head -2"
      terminal returns:
      /usr/sfw/bin/gmake
      GNU Make 3.80
      Copyright (C) 2002  Free Software Foundation, Inc.
      and it seems that all is well.
      I found a thread that dealt with a similar problem: http://forum.sun.com/thread.jspa?threadID=22642&messageID=73859. A poster there attributed a gmake crisis to a defunct /usr/bin/ar. I have no such directory, nor do I think I have the SUNWbtool package that supposedly fixed the problem.
      Also, this "/bin/bash: make. . ." business confuses me becuase last I knew I was using the bourne shell.
      Does anyone have any ideas? Thank you in advance.

      JJ
        • 1. Re: gmake gtrouble
          Robert Cohen
          I suspect that the makefile is invoking a recursive make command and not realising that it needs to use "gmake" instead of make.

          try something like "gmake MAKE=gmake"

          Or executing

          MAKE=gmake
          export MAKE

          before you do the compilation

          If that doesnt work you can try putting a symlink called make to gmake somewhere thats in your path
          • 2. Re: gmake gtrouble
            807738
            Add /usr/ccs/bin to your command search path. This is where the standard Sun 'make' and related tools live.
            • 3. Re: gmake gtrouble
              807557
              No dice. I added /usr/ccs/bin to my path and gmake ran partway, only to return something like: "Fatal error: command failed for target 'all-recursive'."

              I also had problems with the other suggestions:
              # gmake MAKE=gmake
              [lines omitted]
              gmake[2]: *** [libxml2.la] Error 1
              gmake[2]: Leaving directory `/usr/libxml2-2.6.23'
              gmake[1]: *** [all-recursive] Error 1
              gmake[1]: Leaving directory `/usr/libxml2-2.6.23'
              gmake: *** [all] Error 2
              
              # MAKE=gmake
              # export MAKE
              # gmake
              [lines omitted]
              make: Fatal error: Command failed for target `all-recursive'
              Current working directory /usr/libxml2-2.6.23
              gmake: *** [all] Error 1
              Any ideas? Thank you both for your responses.

              JJ
              • 4. Re: gmake gtrouble
                807557
                I got desparate and started over from scratch. I am pretty sure it worked like a charm. All seems to have gone perfectly. If I find out any different I'll be back begging for help again. Thank you.
                • 5. Re: gmake gtrouble
                  807557
                  Please I would like to know how did you solve your problem
                  • 6. Re: gmake gtrouble
                    807557
                    I also have same trouble plase ehlp!!!
                    • 7. Re: gmake gtrouble
                      807557
                      Or executing

                      MAKE=gmake
                      export MAKE

                      before you do the compilation
                      This worked perfectly for me, once I reran ./configure, which might explain the original poster's apparent resolution of the problem after he restarted from scratch.

                      (Erm.. no it didn't, I now get the

                      gmake[2]: *** [libxml2.la] Error 1

                      error.)

                      Message was edited by:
                      Naib