5 Replies Latest reply: Aug 26, 2010 9:22 PM by Robert Cohen RSS

    Sun Fire V240 won't display OK prompt

    807567
      Hello all, I have Sun Fire V240 which I just re-built with a new OS.
      I switched the display type form ttyb back to ttya so I could use the default console.
      The system will no longer display the > for me to boot into normal mode or single user etc...
      Is there a way to reset via jumpers or other physical switch from the motherboard so it defaults back to factory settings?
      I tried swapping JP13,e.g shut down the box, swapped the shortting device, started it up, brought it back down and swapped it back.
      I even tried removing the battery for 30 minutes while doing another task but so far no joy.

      Eric Jones
        • 1. Re: Sun Fire V240 won't display OK prompt
          807567
          Hi.
          On this server ALOM alvays on port ttya (Serial MGT)

          http://docs.sun.com/source/819-4208-10/alom.html#pgfId-1007299

          So try:
          1) Connect to Serial MGT
          2) Press Enter.
          If no output, try switch from Console to ALOM. Press #.

          3) To reset parameters to default:
          sc> bootmode reset-nvram
          sc> reset


          Regards.
          • 2. Re: Sun Fire V240 won't display OK prompt
            807567
            Hello, Thanks for the information.
            I tried it but nothing has changed.
            The system when started does its POST and sees the drives but then no lights on the front panel.
            It appears to be off even though power is being supplied and you can here the drives spinning up.
            The NET MGT port goes green for a bit but switches off.
            No other activity is visible.
            I tried removing and replacing the SCC card after reading the PDF on it but that didn't work.
            According to the documentation you can switch those cards between systems and it will start the system up in a default mode based on the system it came from.
            I thought I removing one from another system and trying it but have not done that yet.

            ej
            • 3. Re: Sun Fire V240 won't display OK prompt
              Robert Cohen
              Are you connecting your serial cable to the serial mgmt port?
              Are you seeing the alom prompt?
              • 4. Re: Sun Fire V240 won't display OK prompt
                807567
                Ok here is the situation and the answer.
                I was rebuilding the web development server.
                Unbeknownst to me ttya doesn't work so it was switched to ttyb for console access through a laptop.
                I upgraded a drive to Solaris 10 10/09 and ZFS vice UFS.
                I was unable to access the box because it no longer booted at startup and I had no access via the hyperterminal.
                the fix I employed after doing some research was to:
                1. modify a similar V240 so it booted and power on e.g. # eeprom 'auto-boot?=true'
                2. Reboot that system and make sure it auto boots into the OS at power on.
                3. Shut down that system, turn off power and remove the System Configuration Card.
                4. Take the SCC From the non booting system, put in the newly modified one and turn on the power. You should see on the screen that the new card is being modified
                to take on the new settings. Wait until you see the request to login and then shut down that box and restart it making sure it boots up without manual help.
                Shut that box down and remove the card.
                5. Take that card and place it in the target box and power it on. This should boot the system into the OS without manual intervention.
                6. As soon as the box is up connect via network using SSH and modify the eeprom to use ttyb, # eeprom input-device=ttya and # eeprom output-device=ttyb.
                7. type in # eeprom to make sure the settings have taken and to make sure auto-boot? is set to true still then type # init 6.
                8. The box should boot into the OS with no problem.
                9. Make sure you secure the cards with plastic zip ties so no one comes along and removes them.

                If you have no way to connect to the box via network you will have to use a laptop with the proper cabling.
                You can use a DB9/RJ45 cable plugging in the DB9 end to the laptop and the RJ45 to the serial port on the server or switch them and use the DB9 on the 9 pin connector and the RJ45 on the laptop.
                This last configuration has you connected to ttyb on the target server. Set the hyperterminal to 9600, 8, N, 1 no matter what unless you know for sure the speed settings and the other settings are different.
                It took 5 hours of work, trial and error, to figure out the correct process.
                I used "tip hardwire" at one point to set the box to ttyb which even though it appeared to work the settings on the server hadn't changed.

                Well that's about it lots of work but I got it down and my dev server back.
                Thanks for the help.

                ej
                • 5. Re: Sun Fire V240 won't display OK prompt
                  Robert Cohen
                  Still failing to see why you couldnt connect to the serial mgmt port instead of ttya or ttyb.