0 Replies Latest reply: Jun 10, 2010 12:13 PM by 807567 RSS

    PPPOE periodically hungs up...

    807567
      I already posted one topic for below trouble but I can't edit it, maybe a browser issue...doesn't matter...
      Lets me resume:

      STORY:

      It worked for month without any problem and I did just smpatch_updates...as recommended...
      It work on SOLARIS still but only after many many below described attempts
      The same PC runs LINUX RHEL 5.4 and it still work fine...

      SYSTEM:

      [unknown-root]@/#uname -a
      SunOS unknown 5.10 Generic_142901-06 i86pc i386 i86pc
      [unknown-root]@/#cat /etc/release
      Solaris 10 5/08 s10x_u5wos_10 X86
      Copyright 2008 Sun Microsystems, Inc. All Rights Reserved.
      Use is subject to license terms.
      Assembled 24 March 2008
      [unknown-root]@/#ifconfig -a
      lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
      inet 127.0.0.1 netmask ff000000
      nge0: flags=1100842<BROADCAST,RUNNING,MULTICAST,ROUTER,IPv4> mtu 1500 index 2
      inet 0.0.0.0 netmask 0
      ether 0:e0:4d:c:61:ac
      rtls0: flags=1100803<UP,BROADCAST,MULTICAST,ROUTER,IPv4> mtu 1500 index 3
      inet 192.168.20.100 netmask ffffff00 broadcast 192.168.20.255
      ether 0:e0:4d:7:24:2f
      sppp0: flags=10011008d0<POINTOPOINT,RUNNING,NOARP,MULTICAST,ROUTER,IPv4,FIXEDMTU> mtu 1492 index 17
      inet 188.26.196.143 --> 10.0.0.1 netmask ffff0000
      ether 0:0:0:0:0:0
      lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
      inet6 ::1/128
      nge0: flags=2100841<UP,RUNNING,MULTICAST,ROUTER,IPv6> mtu 1500 index 2
      inet6 fe80::2e0:4dff:fe0c:61ac/10
      ether 0:e0:4d:c:61:ac
      rtls0: flags=2100801<UP,MULTICAST,ROUTER,IPv6> mtu 1500 index 3
      inet6 fe80::2e0:4dff:fe07:242f/10
      ether 0:e0:4d:7:24:2f

      PPPD config in /etc/ppp/peers...:

      sppptun # what device to use
      plugin pppoe.so # initialize the
      connect "/usr/lib/inet/pppoec -v nge0" # connect string
      persist # if the connection dies, bring it back up
      user "BB7154684" # username
      noauth # Do not make the other side authenticate itself
      noipdefault # Let them give you what IP they want to give you
      noccp # No compression
      novj # No compression
      noaccomp # No compression
      nopcomp # No compression
      defaultroute # add an appropriate default route
      usepeerdns
      lcp-echo-interval 30
      debug

      I have TV cable but no modem (optic fibre I understood) ...at least close to my PC, I don't really know what device is present into the ISP box from outside my house...

      PPPD log:

      I set PPPD in debug mode and I got

      Jun 10 18:57:07 unknown pppd[1668]: [ID 702911 daemon.info] Plugin pppoe.so loaded.
      Jun 10 18:57:07 unknown pppd[1670]: [ID 860527 daemon.notice] pppd 2.4.0b1 (Sun Microsystems, Inc.) started by root, uid 0
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.debug] connect option: '/usr/lib/inet/pppoec -v nge0' started (pid 1671)
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.info] Serial connection established.
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.info] Using interface sppp0
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.notice] Connect: sppp0 <--> /dev/sppptun
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP ConfReq id=0x58 <mru 1492> <asyncmap 0x0> <magic 0x80470f96>]
      Jun 10 18:57:08 unknown pppd[1670]: [ID 702911 daemon.warning] unexpected PPPoE code 7 from 0:14:5e:41:79:b9
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP ConfReq id=0x58 <mru 1492> <asyncmap 0x0> <magic 0x80470f96>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [LCP ConfRej id=0x58 <asyncmap 0x0>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP Ident id=0x59 magic=0x0 "ppp-2.4.0b1 (Sun Microsystems, Inc.)"]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP ConfReq id=0x5a <mru 1492> <magic 0x80470f96>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [LCP ConfAck id=0x5a <mru 1492> <magic 0x80470f96>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [LCP ConfReq id=0x1 <mru 1492> <auth pap> <magic 0x5fb58b08>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP ConfAck id=0x1 <mru 1492> <auth pap> <magic 0x5fb58b08>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP EchoReq id=0x0 magic=0x80470f96 00 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f ...]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP Ident id=0x5b magic=0x80470f96 "ppp-2.4.0b1 (Sun Microsystems, Inc.)"]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] Authenticating to peer with PAP
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [PAP AuthReq id=0x1 user="BB7154684" password=<hidden>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [LCP EchoReq id=0x0 magic=0x5fb58b08]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [LCP EchoRep id=0x0 magic=0x80470f96]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [LCP EchoRep id=0x0 magic=0x5fb58b08 00 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f ...]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] lcp: validated asyncmap setting
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [PAP AuthAck id=0x1 ""]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [IPCP ConfReq id=0x87 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [IPCP ConfReq id=0x1 <addr 10.0.0.1>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [IPCP ConfAck id=0x1 <addr 10.0.0.1>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [IPCP ConfNak id=0x87 <addr 188.26.199.78> <ms-dns1 82.76.253.115> <ms-dns2 82.76.253.125>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] sent [IPCP ConfReq id=0x88 <addr 188.26.199.78> <ms-dns1 82.76.253.115> <ms-dns2 82.76.253.125>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.debug] rcvd [IPCP ConfAck id=0x88 <addr 188.26.199.78> <ms-dns1 82.76.253.115> <ms-dns2 82.76.253.125>]
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.notice] local IP address 188.26.199.78
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.notice] remote IP address 10.0.0.1
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.notice] primary DNS address 82.76.253.115
      Jun 10 18:57:11 unknown pppd[1670]: [ID 702911 daemon.notice] secondary DNS address 82.76.253.125
      Jun 10 18:57:12 unknown pppd[1670]: [ID 702911 daemon.warning] unexpected PPPoE code 7 from 0:15:17:8e:5a:11
      Jun 10 18:57:12 unknown pppd[1670]: [ID 702911 daemon.warning] unexpected PPPoE code 7 from 0:15:17:8e:61:ce
      Jun 10 19:01:17 unknown pppd[1670]: [ID 702911 daemon.debug] received PPPoE PADT; connection has been closed
      Jun 10 19:01:17 unknown pppd[1670]: [ID 702911 daemon.notice] Modem hangup
      Jun 10 19:01:17 unknown pppd[1670]: [ID 702911 daemon.notice] Connection terminated.
      Jun 10 19:01:17 unknown pppd[1670]: [ID 702911 daemon.info] Connect time 4.2 minutes.