5 Replies Latest reply on Jun 2, 2010 7:26 PM by 807567

    Solaris 10 U8 DHCP

    807567
      Hi,

      I successfully installed S10U8 on my system when connected via ethernet to a broadband router. I then installed some application software which contains a management browser ie. browse to https://myhostname:port/mgr and this all worked my Internet connection to the outside world was also perfect.

      However most of the time I will not be connected to the broadband router in this way but will be standalone so when I broke my network connection and rebooted I got

      rtls0: link down
      failed to configure DHCP
      hostname set to myhostname

      which I thought reasonable enough - however just before the JDS desktop environment starts I get a message
      popup saying

      myhostname not recognised gnome may not continue to work properly you may
      want to edit your /etc/hosts file <continue> or <try again>

      so I <continue> and login then try to do

      telnet myhostname ==> fails as unrecognised
      telnet 127.0.0.1 ==> works

      and https://myhostname:port/mgr ==>fails as myhostname is unrecognised
      but https://127.0.0.1:port/mgr ==> also fails something about being rejected

      obviously I want to keep my DHCP configuration as it works and I will be using that network connection
      but how do I get myhostname to be recognised in the standalone situation Ie. get

      telnet myhostname to work
      https://myhostname:port/mgr to work

      I am new to this so i think the fix should be easy?
        • 1. Re: Solaris 10 U8 DHCP
          alan.pae
          However most of the time I will not be connected to the broadband router in this way but will be standalone so when I broke my network connection and rebooted I got
          ???? How did you break the connection?
          rtls0: link down
          failed to configure DHCP
          hostname set to myhostname

          which I thought reasonable enough - however just before the JDS desktop environment starts I get a message
          popup saying

          myhostname not recognised gnome may not continue to work properly you may
          want to edit your /etc/hosts file <continue> or <try again>

          so I <continue> and login then try to do

          telnet myhostname ==> fails as unrecognised
          telnet 127.0.0.1 ==> works
          What does ifconfig -a and svcs -a |grep network/physical show?

          alan
          • 2. Re: Solaris 10 U8 DHCP
            807567
            I installed S10U8 in the office which had a DHCP broadband router and have not touched any of the tcp configuration files since. When I take the machine home each night there is no network so I have to boot standalone

            # ifconfig -a

            lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1

                 inet 127.0.0.1 netmask ff000000

            rtls0: flags=1004802<BROADCAST,MULTICAST,DHCP,IPv4> mtu 1500 index 2

                 inet 0.0.0.0 netmask 0

                 ether 0:25:86:e5:fb:9a


            # svcs -a | grep network/physical

            online 20:54:15 svc:/network/physical:default


            # hostname

            sagan


            # telnet sagan

            sagan: node name or service name not known


            And this is a problem since some other application software has hardcoded the hostname, sagan into its configuration.

            Thanks,
            • 3. Re: Solaris 10 U8 DHCP
              alan.pae
              Ok, as you know 0.0.0.0 is either a DHCP request or a bad address.

              So, you should have a file called /etc/hostname.rtls0 with at least one line that says: sagan.

              And hopefully /etc/hosts has the some line with sagan on it?

              And just for grins /etc/nsswitch.conf has a couple of lines that say:

              hosts: files <-- at a minimum

              and the same for ipnodes?

              alan
              • 4. Re: Solaris 10 U8 DHCP
                807567
                Well this managed to get rid of the gnome popup during login
                but still cant telnet.


                # ifconfig -a

                lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1

                     inet 127.0.0.1 netmask ff000000

                rtls0: flags=1004802<BROADCAST,MULTICAST,DHCP,IPv4> mtu 1500 index 2

                     inet 192.168.1.57 netmask ffffff00 broadcast 192.168.1.255

                     ether 0:25:86:e5:fb:9a


                # svcs | grep network/physical

                online 11:35:40 svc:/network/physical:default




                # telnet sagan

                Trying 192.168.1.57...

                telnet: Unable to connect to remote host: Network is unreachable


                # ping sagan

                ICMP Host Unreachable from gateway localhost (127.0.0.1)

                for icmp from localhost (127.0.0.1) to sagan (192.168.1.57)


                # ping localhost

                localhost is alive



                #cat /etc/defaultrouter
                192.168.1.1          #ip address of broadband router when connecting to inet with DHCP


                # cat /etc/hostname.rtls0

                sagan




                # cat /etc/hosts

                #


                # Internet host table

                #

                ::1          localhost

                127.0.0.1     localhost

                192.168.1.57     sagan     sagan.cosmos.com     loghost


                # diff /etc/hosts /etc/inet/ipnodes

                #



                # cat /etc/netmasks

                #

                192.168.1.57     255.255.255.0




                # cat /etc/nsswitch.conf


                #

                # Copyright 2006 Sun Microsystems, Inc. All rights reserved.

                # Use is subject to license terms.

                #



                #

                # /etc/nsswitch.dns:

                #

                # An example file that could be copied over to /etc/nsswitch.conf; it uses

                # DNS for hosts lookups, otherwise it does not use any other naming service.

                #

                # "hosts:" and "services:" in this file are used only if the

                # /etc/netconfig file has a "-" for nametoaddr_libs of "inet" transports.



                # DNS service expects that an instance of svc:/network/dns/client be

                # enabled and online.



                passwd: files

                group: files



                # You must also set up the /etc/resolv.conf file for DNS name

                # server lookup. See resolv.conf(4).

                hosts: files dns



                # Note that IPv4 addresses are searched for in all of the ipnodes databases

                # before searching the hosts databases.

                ipnodes: files dns



                networks: files

                protocols: files

                rpc: files

                ethers: files

                netmasks: files

                bootparams: files

                publickey: files

                # At present there isn't a 'files' backend for netgroup; the system will

                # figure it out pretty quickly, and won't use netgroups at all.

                netgroup: files

                automount: files

                aliases: files

                services: files

                printers:     user files



                auth_attr: files

                prof_attr: files

                project: files



                tnrhtp: files

                tnrhdb: files
                • 5. Re: Solaris 10 U8 DHCP
                  807567
                  Ok,

                  It looks like once the DHCP procedure fails during boot there exists a Bug? whereby the information in
                  /etc/netmasks gets ignored -- see netmask from ifconfig -a below.

                  A reset of netmask from the command line makes everything good.


                  # cat /etc/netmasks
                  192.168.1.57     255.255.0.0



                  # ifconfig -a


                  lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1

                       inet 127.0.0.1 netmask ff000000

                  rtls0: flags=1004802<BROADCAST,MULTICAST,DHCP,IPv4> mtu 1500 index 2

                       inet 192.168.1.57 netmask ffffff00 broadcast 192.168.1.255

                       ether 0:25:86:e5:fb:9a



                  # ifconfig rtls0 down

                  # ifconfig rtls0 unplumb

                  # ifconfig rtls0 plumb

                  # ifconfig rtls0 192.168.1.57 netmask 255.255.0.0 broadcast 192.168.255.255

                  # ifconfig rtls0 up

                  # /etc/default/inetinit start


                  # ping sagan

                  sagan is alive


                  # ping 192.168.1.57

                  192.168.1.57 is alive




                  Now to fix all the other problems :-)