• 15. Re: Anyone knows How to get gd library to work with this PHP?
      807567
      checking whether to enable DOM support... yes
      checking for xml2-config path... (cached) /usr/bin/xml2-config
      checking whether libxml build works... (cached) yes
      checking for ENCHANT support... no
      checking whether to enable EXIF (metadata from images) support... no
      checking for fileinfo support... yes
      checking for utimes... (cached) yes
      checking for strndup... (cached) no
      checking whether to enable input filter support... yes
      checking pcre install prefix... no
      checking whether to enable FTP support... no
      checking OpenSSL dir for FTP... no
      checking for GD support... yes
      checking for the location of libjpeg... /usr/local/bin
      checking for the location of libpng... /usr/local/bin
      checking for the location of libXpm... no
      checking for FreeType 2... no
      checking for T1lib support... no
      checking whether to enable truetype string function in GD... no
      checking whether to enable JIS-mapped Japanese font support in GD... no
      checking for fabsf... (cached) yes
      checking for floorf... (cached) yes
      checking for jpeg_read_header in -ljpeg... (cached) yes
      checking for png_write_image in -lpng... (cached) yes
      If configure fails try --with-xpm-dir=<DIR>
      If configure fails try --with-freetype-dir=<DIR>
      checking for GNU gettext support... yes
      checking for bindtextdomain in -lintl... yes
      checking for ngettext in -lintl... yes
      checking for dngettext in -lintl... yes
      checking for dcngettext in -lintl... yes
      checking for bind_textdomain_codeset in -lintl... yes
      checking for GNU MP support... no
      checking for mhash support... no
      checking whether to enable hash support... yes
      checking whether byte ordering is bigendian... (cached) no
      checking size of short... (cached) 2
      checking size of int... (cached) 4
      checking size of long... (cached) 4
      checking size of long long... (cached) 8
      checking for iconv support... yes
      checking for iconv... (cached) yes
      checking if iconv is glibc's... no
      checking if using GNU libiconv... 269yes
      checking if iconv supports errno... yes
      checking if your cpp allows macro usage in include lines... yes
      checking for IMAP support... no
      checking for IMAP Kerberos support... no
      checking for IMAP SSL support... no
      checking for InterBase support... no
      checking whether to enable internationalization support... no
      checking whether to enable JavaScript Object Serialization support... yes
      checking for ANSI C header files... (cached) yes
      checking for LDAP support... no
      checking for LDAP Cyrus SASL support... no
      checking whether to enable multibyte string support... yes
      checking whether to enable multibyte regex support... yes
      checking whether to check multibyte regex backtrack... yes
      checking for external libmbfl... no
      checking for external oniguruma... no
      checking for variable length prototypes and stdarg.h... yes
      checking for stdlib.h... (cached) yes
      checking for string.h... (cached) yes
      checking for strings.h... yes
      checking for unistd.h... (cached) yes
      checking for sys/time.h... (cached) yes
      checking for sys/times.h... yes
      checking for stdarg.h... (cached) yes
      checking size of int... (cached) 4
      checking size of short... (cached) 2
      checking size of long... (cached) 4
      checking for working const... yes
      checking whether time.h and sys/time.h may both be included... yes
      checking for working alloca.h... (cached) yes
      checking for alloca... (cached) yes
      checking for 8-bit clean memcmp... (cached) yes
      checking for stdarg.h... (cached) yes
      checking for mcrypt support... no
      checking for MSSQL support via FreeTDS... no
      checking for MySQL support... no
      checking for specified location of the MySQL UNIX socket... no
      checking for MySQLi support... no
      checking whether to enable embedded MySQLi support... no
      checking for Oracle (OCI8) support... no
      checking whether to enable pcntl support... no
      checking whether to enable PDO support... yes
      checking for PDO_DBLIB support via FreeTDS... no
      checking for Firebird support for PDO... no
      checking for MySQL support for PDO... no
      checking Oracle OCI support for PDO... no
      checking for ODBC v3 support for PDO... no
      checking for PostgreSQL support for PDO... no
      checking for sqlite 3 support for PDO... yes
      checking for PDO includes... checking for PDO includes... /download/php-5.3.2/ext
      checking for usleep... (cached) yes
      checking for nanosleep... (cached) yes
      checking for time.h... (cached) yes
      checking for fdatasync in -lrt... (cached) yes
      checking for PostgreSQL support... no
      checking for phar archive support... yes
      checking for phar openssl support... no
      checking whether to enable POSIX-like functions... yes
      checking for sys/mkdev.h... (cached) yes
      checking for seteuid... (cached) yes
      checking for setegid... (cached) yes
      checking for setsid... (cached) yes
      checking for getsid... (cached) yes
      checking for setpgid... (cached) yes
      checking for getpgid... (cached) yes
      checking for ctermid... (cached) yes
      checking for mkfifo... (cached) yes
      checking for mknod... (cached) yes
      checking for getrlimit... (cached) yes
      checking for getlogin... (cached) yes
      checking for getgroups... (cached) yes
      checking for makedev... (cached) no
      checking for initgroups... (cached) yes
      checking for getpwuid_r... (cached) yes
      checking for getgrgid_r... (cached) yes
      • 16. Re: Anyone knows How to get gd library to work with this PHP?
        807567
        checking for working ttyname_r() implementation... no, posix_ttyname() will be thread-unsafe
        checking for utsname.domainname... (cached) no
        checking for PSPELL support... no
        checking for libedit readline replacement... no
        checking for readline support... no
        checking for recode support... no
        checking whether to enable PHP sessions... yes
        checking for mm support... no
        checking whether pwrite works... (cached) yes
        checking whether pread works... (cached) yes
        checking whether to enable shmop support... no
        checking whether to enable SimpleXML support... yes
        checking for xml2-config path... (cached) /usr/bin/xml2-config
        checking whether libxml build works... (cached) yes
        checking for SNMP support... no
        checking OpenSSL dir for SNMP... no
        checking whether to enable UCD SNMP hack... no
        checking whether to enable SOAP support... no
        checking whether to enable sockets support... yes
        checking for struct cmsghdr... yes
        checking for hstrerror... no
        checking for socketpair... (cached) yes
        checking for netdb.h... (cached) yes
        checking for netinet/tcp.h... yes
        checking for sys/un.h... yes
        checking for errno.h... yes
        checking whether zend_object_value is packed... yes
        checking for sqlite support... yes
        checking whether to enable UTF-8 support in sqlite (default: ISO-8859-1)... no
        checking for PDO includes... (cached) /download/php-5.3.2/ext
        checking for lemon... no
        configure: warning: lemon versions supported for regeneration of libsqlite parsers: 1.0 (found: none).
        checking size of char *... (cached) 4
        checking for usleep... (cached) yes
        checking for nanosleep... (cached) yes
        checking for time.h... (cached) yes
        checking whether flush should be called explicitly after a buffered io... (cached) yes
        checking for standard DES crypt... (cached) yes
        checking for extended DES crypt... (cached) no
        checking for MD5 crypt... (cached) yes
        checking for Blowfish crypt... (cached) yes
        checking for SHA512 crypt... (cached) no
        checking for SHA256 crypt... (cached) no
        checking whether the compiler supports __alignof__... (cached) yes
        checking whether the compiler supports aligned attribute... (cached) yes
        checking for getcwd... (cached) yes
        checking for getwd... (cached) yes
        checking for asinh... (cached) yes
        checking for acosh... (cached) yes
        checking for atanh... (cached) yes
        checking for log1p... (cached) yes
        checking for hypot... (cached) yes
        checking for glob... (cached) yes
        checking for strfmon... (cached) yes
        checking for nice... (cached) yes
        checking for fpclass... (cached) yes
        checking for isinf... (cached) no
        checking for isnan... (cached) yes
        checking for mempcpy... (cached) no
        checking for strpncpy... (cached) no
        checking for working fnmatch... (cached) yes
        checking for fork... (cached) yes
        checking if your OS can spawn processes with inherited handles... yes
        checking for res_nsearch... no
        checking for __res_nsearch... no
        checking for res_nsearch in -lresolv... yes
        checking for dns_search... no
        checking for __dns_search... no
        checking for dns_search in -lresolv... no
        checking for __dns_search in -lresolv... no
        checking for dns_search in -lbind... no
        checking for __dns_search in -lbind... no
        checking for dns_search in -lsocket... no
        checking for __dns_search in -lsocket... no
        checking for dn_expand... yes
        checking for dn_skipname... yes
        checking for res_search... yes
        checking whether atof() accepts NAN... (cached) yes
        checking whether atof() accepts INF... (cached) no
        checking whether HUGE_VAL == INF... (cached) no
        checking whether HUGE_VAL + -HUGEVAL == NAN... (cached) yes
        checking whether strptime() declaration fails... (cached) yes
        checking for wchar.h... (cached) yes
        checking for mblen... (cached) yes
        checking for mbrlen... (cached) yes
        checking for mbsinit... (cached) yes
        checking for mbstate_t... (cached) yes
        checking for Sybase-CT support... no
        checking whether to enable System V IPC support... no
        checking whether to enable System V semaphore support... no
        checking whether to enable System V shared memory support... no
        checking for TIDY support... no
        checking whether to enable tokenizer support... yes
        checking whether to enable WDDX support... no
        checking libexpat dir for WDDX... no
        checking whether to enable XML support... yes
        checking libexpat install dir... no
        checking for xml2-config path... (cached) /usr/bin/xml2-config
        checking whether libxml build works... (cached) yes
        checking whether to enable XMLReader support... yes
        checking for xml2-config path... (cached) /usr/bin/xml2-config
        checking whether libxml build works... (cached) yes
        checking for XMLRPC-EPI support... no
        checking libexpat dir for XMLRPC-EPI... no
        checking iconv dir for XMLRPC-EPI... no
        checking whether to enable XMLWriter support... yes
        checking for xml2-config path... (cached) /usr/bin/xml2-config
        checking whether libxml build works... (cached) yes
        checking for XSL support... no
        checking for zip archive read/writesupport... no
        checking pcre install prefix... no
        checking whether to disable compressed protocol support in mysqlnd... yes
        • 17. Re: Anyone knows How to get gd library to work with this PHP?
          807567
          Configuring PEAR
          checking whether to install PEAR... yes

          Configuring Zend
          checking for bison version... (cached) invalid
          configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 2.4 2.4.1 (found: none).
          checking for inttypes.h... (cached) yes
          checking for stdint.h... (cached) yes
          checking for limits.h... (cached) yes
          checking for malloc.h... (cached) yes
          checking for string.h... (cached) yes
          checking for unistd.h... (cached) yes
          checking for stdarg.h... (cached) yes
          checking for sys/types.h... (cached) yes
          checking for sys/time.h... (cached) yes
          checking for signal.h... (cached) yes
          checking for unix.h... (cached) no
          checking for stdlib.h... (cached) yes
          checking for dlfcn.h... (cached) yes
          checking for size_t... (cached) yes
          checking return type of signal handlers... (cached) void
          checking for uint... (cached) yes
          checking for ulong... (cached) yes
          checking for int32_t... yes
          checking for uint32_t... yes
          checking for vprintf... (cached) yes
          checking for 8-bit clean memcmp... (cached) yes
          checking for working alloca.h... (cached) yes
          checking for alloca... (cached) yes
          checking for memcpy... (cached) yes
          checking for strdup... (cached) yes
          checking for getpid... (cached) yes
          checking for kill... (cached) yes
          checking for strtod... (cached) yes
          checking for strtol... (cached) yes
          checking for finite... (cached) yes
          checking for fpclass... (cached) yes
          checking for sigsetjmp... (cached) yes
          checking whether sprintf is broken... (cached) no
          checking for finite... (cached) yes
          checking for isfinite... (cached) no
          checking for isinf... (cached) no
          checking for isnan... (cached) yes
          checking whether fp_except is defined... (cached) no
          checking for usable FPUSETCW... no
          checking for usable fpsetprec... no
          checking for usable _controlfp... no
          checking for usable controlfps... no
          checking whether FPU control word can be manipulated by inline assembler... yes
          checking whether double cast to long preserves least significant bits... no
          checking for dlfcn.h... (cached) yes
          checking whether dlsym() requires a leading underscore in symbol names... no
          checking virtual machine dispatch method... CALL
          checking whether to enable thread-safety... no
          checking whether to enable inline optimization for GCC... yes
          checking whether to enable Zend debugging... no
          checking whether to enable Zend multibyte... no
          checking for inline... (cached) inline
          checking target system is Darwin... no
          checking for MM alignment and log values... done
          checking for memory allocation using mmap(MAP_ANON)... yes
          checking for memory allocation using mmap(/dev/zero)... yes
          checking for mremap... (cached) no

          Configuring TSRM
          checking for stdarg.h... (cached) yes

          Configuring libtool
          checking build system type... i386-pc-solaris2.10
          checking for ld used by gcc... (cached) /usr/ccs/bin/ld
          checking if the linker (/usr/ccs/bin/ld) is GNU ld... (cached) no
          checking for /usr/ccs/bin/ld option to reload object files... (cached) -r
          checking for BSD-compatible nm... (cached) /usr/ccs/bin/nm -p
          checking how to recognize dependent libraries... (cached) pass_all
          checking for object suffix... (cached) o
          checking for executable suffix... (cached) no
          checking the maximum length of command line arguments... (cached) 786240
          checking command to parse /usr/ccs/bin/nm -p output from gcc object... (cached) ok
          checking for objdir... (cached) .libs
          checking for ar... no
          checking for ranlib... no
          checking for strip... no
          checking if gcc supports -fno-rtti -fno-exceptions... (cached) no
          checking for gcc option to produce PIC... -fPIC
          checking if gcc PIC flag -fPIC works... (cached) yes
          checking if gcc static flag -static works... (cached) no
          checking if gcc supports -c -o file.o... (cached) yes
          checking whether the gcc linker (/usr/ccs/bin/ld) supports shared libraries... yes
          checking dynamic linker characteristics... solaris2.10 ld.so
          (cached) (cached) checking how to hardcode library paths into programs... immediate
          checking whether stripping libraries is possible... no
          checking if libtool supports shared libraries... yes
          checking whether to build shared libraries... no
          checking whether to build static libraries... yes

          creating libtool
          appending configuration tag "CXX" to libtool

          Generating files
          updating cache ./config.cache
          creating ./config.status
          creating php5.spec
          creating main/build-defs.h
          creating scripts/phpize
          creating scripts/man1/phpize.1
          creating scripts/php-config
          creating scripts/man1/php-config.1
          creating sapi/cli/php.1
          creating main/php_config.h
          creating main/internal_functions.c
          creating main/internal_functions_cli.c
          --------------------------------------------------------------------
          | License: |
          | This software is subject to the PHP License, available in this |
          | distribution in the file LICENSE. By continuing this installation |
          | process, you are bound by the terms of this license agreement. |
          | If you do not agree with the terms of this license, you must abort |
          | the installation process at this point. |
          --------------------------------------------------------------------

          Thank you for using PHP.
          • 18. Re: Anyone knows How to get gd library to work with this PHP?
            807567
            I am trying to use the ./php -version command. I am not finding ./php under my php directory /download/php-5.3.2/sapi/cgi
            • 19. Re: Anyone knows How to get gd library to work with this PHP?
              801146
              After you ran ./configure you need to run make (or gmake) to actually compile the binary.
              • 20. Re: Anyone knows How to get gd library to work with this PHP?
                807567
                I ran it again, because i forgot to enable fastcgi and I got the following error.

                Thank you for using PHP.

                Notice: Following unknown configure options were used:

                --enable-fastcgi

                Check './configure --help' for available options                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
                • 21. Re: Anyone knows How to get gd library to work with this PHP?
                  801146
                  I believe that current versions (5.3.something) of PHP now build FastCGI by default. This renders --enable-fastcgi as not-needed.

                  I use FastCGI with PHP. Here's my configure line from 5.3.2:
                  ./configure --with-openssl --with-gettext --with-zlib --with-jpeg-dir=/opt --with-gd --with-mysql=/opt --with-png-dir=/opt --with-mcrypt --enable-mbstring--enable-sockets
                  • 22. Re: Anyone knows How to get gd library to work with this PHP?
                    807567
                    After compile, I got the following.

                    bash-3.00# ./php -version
                    PHP 5.3.2 (cli) (built: Jul 18 2010 20:55:30)
                    Copyright (c) 1997-2010 The PHP Group
                    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

                    But my php is located under

                    bash-3.00# pwd
                    /download/php-5.3.2/sapi/cli

                    instead of under
                    /download/php-5.3.2/sapi/cgi

                    as described at http://developers.sun.com/webtier/reference/techart/php2.html

                    is it because of the different version?

                    How do I config the web server 7 to work with this version of php, should I follow the site
                    http://developers.sun.com/webtier/reference/techart/php2.html#4

                    or is there any difference in php-5.3.2?
                    • 23. Re: Anyone knows How to get gd library to work with this PHP?
                      801146
                      I don't recall if the PHP people have changed the name of the FCGI binary. I just did a build on CentOS and ended up with this:

                      # cd sapi/cgi/
                      # *./php-cgi -v*
                      PHP 5.3.2 (cgi-fcgi) (built: Jul 19 2010 09:04:06)
                      Copyright (c) 1997-2010 The PHP Group
                      Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

                      Notice that the binary (just after build completion) is called php-cgi, that it's in the sapi/cgi directory, and that it reports itself as "cgi-fcgi".


                      Regarding where to put it ... Look in your Web Server obj.conf file. Somewhere in there you will find a section that contains "app-path" and points to a particular location (again, this assumes that you told the PHP Add-On installer that you wanted to use FastCGI). That line is telling Web Server where to find the PHP binary to execture. Either replace that binary with the one you just built, or change the path to point to the new location of your binary. Then stop/start your Web Server and access a test PHP page with phpinfo(); inside. Verify that the page that comes back indicates that you're using PHP 5.3.2 and also contains a section with information about GD.
                      • 24. Re: Anyone knows How to get gd library to work with this PHP?
                        807567
                        Thanks, Looks like it's working, after pointing app-path in obj.conf, I restarted the web server. and tested with a phpinfo(); testing page. it shows that gd library is enabled.

                        Now, I am trying to compile also mysql into the php, but it's giving me error, can you help with that. error message is shown as follow;

                        configure: error: Cannot find MySQL header files under /data/Software/mysql-standard-5.0.27-solaris10-x86_64/include.
                        Note that the MySQL client library is not bundled anymore!

                        I am pointing --with-mysql to the mysql directory and also tried pointing to the mysql header folder. both are giving me error.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
                        • 25. Re: Anyone knows How to get gd library to work with this PHP?
                          801146
                          On Centos I have to have the mysql-devel-5.0.77-4.el5_5.3 package installed. I have no idea what it might be called on Solaris.

                          Good luck!
                          1 2 上一个 下一个