7 Replies Latest reply on Apr 17, 2008 3:57 PM by 807567

    Problem with console on provisioned machines

      When I provision Solaris 10 8/07 onto our Sun Fire X4100M2 machines using N1 System Manager 1.3.3, everything works swimmingly and the OS is provisioned to the machine. I did have problems with this earlier, but these were resolved via an IDR from Sun Technical Support.

      However, If I use the ILOM viewer app (the Java one which can be found on the machine's Web Console) to redirect the machine's console to my laptop, I can see the machine go through POST, network boot from the provisioning server, and begin the installation. A long series of dots appear across the top of the screen as the installation is initializing, however after this I see nothing....the machine appears to stop dead. However, this is not the case. If I SSH into the machine's BMC and start the serial console ( cd SP/console > start ), I can see that the installation is proceeding fine.

      Once the installation is completed, and the machine reboots into the newly-provisioned Solaris instance, the same thing happens. I cannot view the console output via redirection to the Java ILOM viewer - all I see in this case is a flashing cursor in the top-left corner of the screen. However, logging into the BMC and starting the serial console allows me to see the release information that is printed to the screen on startup, a few error messages, and a login prompt.

      Anyone else have a similar experience?
        • 1. Re: Problem with console on provisioned machines
          Great to hear that IDRs (fixes) from Sun help and work !
          A patch is already built, right now in internal testing, so hopefully you will replace the IDR by the patch very soon.

          On the console ... well
          The thing is, that the console can get redirected. I think this is what happens in your case (might happen for other HW or new FW revisions !).
          Load server or osprofile has a parameter, which can setup the console to redirect properly, if you want to spy on javaviewer.
          Most probably a simple console redirect to ttya or ttyb will be enough, not sure, but I am sure HW documentation either on your box or on your ILOM revision will have the proper redirection mentioned.
          You can also change redirection in Solaris, refer to Solaris docs how to do it (I think N1SM does this in postinstall scripts with some magic command I don't remember from top of my head).

          N1SM is becoming old, so it doesn't have all the recent knowledge and didn't do this redirection for you.
          Plan for a transitioning to xVM Ops Center, which is the latest greatest and better yet it's built on JET ;)

          • 2. Re: Problem with console on provisioned machines
            There was a patch released on April 1st, 2008 for N1SM. I have installed it, and N1SM still functions, so that's a positive development ;-)

            I have tried setting console=ttya when provisioning an OS instance, however this didn't appear to have any effect. I will dig up the ILOM docs for my machines, and go through the post-installation scripts to see if I can find that command you mentioned. Sun tech support has been working on this issue for a couple of weeks now, and they haven't dug up anything of use yet.

            We have invested quite heavily (relative to our size) in N1SM entitlements, and are slightly miffed that it is EOLed (from a Sun business case, at least, since it is now freely available) and superceded by xVM Ops Center. But, I digress....if I can get it to work as advertised before I lose my sanity, I will be a very happy man regardless.

            Thanks again for your help,
            • 3. Re: Problem with console on provisioned machines
              The lack of thoroughness on my part appears to have dragged out this issue much longer than necessary. Two weeks ago I experimented with adding "console=ttya" to the "load server ..." command when provisioning. If only I had tried the next logical combination, "console=ttyb", I would have found the solution.

              From N1SM installed on a Solaris 10 Update 4 host, I installed all patches from Sun Update, then removed IDR137229-01 and installed N1SM patch 128040-02. Then I added "console=ttyb consolebaud=9600" to the provisioning command, and voila, I get to see everything now via the Sun ILOM Remote Console.

              My installation still does not proceed properly, as it appears there is a syntax error in the sysidcfg file, somewhere around the keyboard part of the file. I have seen other threads on this forum pertaining to that problem, so I will now head over there to see what I can dig up.

              UPDATE: I had to re-apply the IDR (137229-01) in order to get Jumpstart to work. I guess N1SM patch 128040-02 doesn't fix that issue...

              Thanks again for your help!

              Edited by: C-NOOFS on Apr 16, 2008 9:55 AM
              • 4. Re: Problem with console on provisioned machines
                Slight caveat to the above-posted solution. It works fine for properly redirecting the console output of Solaris (ie: error messages, etc). However, when Solaris starts Java Desktop, the GUI is redirected to parts unknown, and I am unable to see it via the ILOM viewer. Everything is working perfectly on the provisioned machine - I can 'ssh -X' into it from another Solaris machine on the same subnet and open a Firefox window no problem.

                That's always the way it is: a solution to one problem just uncovers another problem... :S
                • 5. Re: Problem with console on provisioned machines
                  *** Removed ***
                  Forum forced me to post something when I unmarked the topic as 'Answered'

                  Edited by: C-NOOFS on Apr 16, 2008 12:04 PM
                  • 6. Re: Problem with console on provisioned machines
                    I made a short 'video' of what I see when booting up a provisioned node....hopefully it will help clarify where the problem is

                    • 7. Re: Problem with console on provisioned machines
                      Finally, a working solution...thanks to Sun's documentation: http://docs.sun.com/source/819-6596-12/Chap3.html#59965

                      The issue boils down to one line in /boot/solaris/bootenv.rc.....the console needs to be redirected to 'text':

                      (1) Open /boot/solaris/bootenv.rc
                      (2) Find the 'setprop console ...' line
                      (3) Change value to 'text' (ie: setprop console 'text')

                      Works like a charm! No idea how to get N1SM to do this on its own, though...The 'console' option for 'load server ...' does not accept 'text' as a valid input. Probably easiest to write a post-install script to modify the bootenv.rc file, and tack it on to the os profile.

                      I feel much better now that this issue is off my back :)