2 Replies Latest reply: Mar 11, 2009 6:06 AM by 807567 RSS

    SUNWbreg and Solaris 10 11/06 (smpatch)


      I am running Solaris 10 11/06.
      root@myserver # cat /etc/release
                             Solaris 10 11/06 s10s_u3wos_10 SPARC
                 Copyright 2006 Sun Microsystems, Inc.  All Rights Reserved.
                              Use is subject to license terms.
                                 Assembled 14 November 2006
      When I run smpatch analyze I get the following single patch (despite knowing that I should see around 80 or so):
      root@myserver # smpatch analyze
      121563-02 SunOS 5.10: Sun Update Connection Registration, version 1.0.3
      When I run smpatch update*, it downloads the patch but errors out. When I try to install it manually it errors out with the following message:
      root@myserver # patchadd 121563-02
      Validating patches...
      Loading patches installed on the system...
      Loading patches requested to install.
      The following requested patches have packages not installed on the system
      Package SUNWbreg from directory SUNWbreg in patch 121563-02 is not installed on the system. Changes for package SUNWbreg will not be applied to the system.
      Checking patches that you specified for installation.
      The following requested patches will not be installed because
      the packages they patch are not installed on this system.
                 0 No Packages from patch 121563-02 are installed on the system.
      No patches to install.
      Now the confusing thing is that SUNWbreg does not exist on my system as SUNWbreg was superseded by SUNWbrg in all versions of Solaris 10 06/06 or later (as stated here: http://wikis.sun.com/display/SunConnection/Known+Issues+and+Workarounds+in+Update+Manager+1.0.10)
      root@myserver # pkginfo -x SUNWbreg
      ERROR: information for "SUNWbreg" was not found
      root@myserver # pkginfo -x SUNWbrg
      SUNWbrg  SCN Basic Registration Application, Usr (/usr)
               (sparc) 1.1.0,REV=2006.
      Do I need to install package SUNWbreg / patch 121563-02, if so how do I do this. If not how can I ignore this patch so that when I run smpatch analyze that I get the full 80 or so patches that I am expecting to see.

      Apologies if this is a little unclear, happy for any questions / suggestions.

      Thanks in advance,

        • 1. Re: SUNWbreg and Solaris 10 11/06 (smpatch)
          Found a solution here:


          I removed these files from the LPS:
          rm /var/sadm/spool/patchsvr/*current.zip
          rm /var/sadm/spool/patchsvr/*detectors.jar
          and also these files from my clients:
          rm /var/sadm/spool/cache/*detectors.jar
          rm /var/sadm/spool/cache/Database/*current.zip
          I then ran "*+smpatch update+*" from the LPS, once updated I ran "*+smpatch analyze+*" from my client and it now picks up all my patches and does not request that I apply patch 121563-02.


          • 2. Re: SUNWbreg and Solaris 10 11/06 (smpatch)
            The next revision of the patchserver patch should go a long way to address problems like this which are likely caused by the files being cached too long.

            In general terms there is no harm in clearing out any non-patch files from clients and patchserver alike on a regular basis.