3 Replies Latest reply: Jul 17, 2009 6:53 AM by 807567 RSS

    How to unconfigure LDom

    807567
      I'd like to wipe out the current LDom configuration on a machine and would like to start over. Looks like removing the SUNWldm package doesn't undo the configuration.

      Right now I have only the control domain configured but no guest domain or anything else left.

      # ldm list
      NAME STATE FLAGS CONS VCPU MEMORY UTIL UPTIME
      primary active -n-cv SP 4 4G 0.0% 10m


      Could anyone advise?

      Thanks.


      - Young
        • 1. Re: How to unconfigure LDom
          807567
          To remove all the old configs, do a 'ldm ls-config' and for each config that was added, do
          a 'ldm rm-config <config-name>' until you are left with "factory-default" as the only remaining
          config (or if you want to keep the old configs just in case, do and 'ldm set-config factory-default').

          When you powercycle the control domain you will be in the "factory-default" config
          which contains all the resources in a machine.
          • 2. Re: How to unconfigure LDom
            807567
            Thanks for your suggestion. I went through it and successfully unconfigured it but I still see multiple vsw configurations I had when I tried the "ifconfig -a" command. Consequently, when I tried creating the control domain frseh, I got the following error:



            # ldm add-domain myldom1
            Multicast socket creation failed. Please set LDom MAC addresses manually.


            I appreciate your advice. Thanks.
            • 3. Re: How to unconfigure LDom
              807567
              I have the same issue, basically what happened was I did a load of configuration forgot to save it using ldm add-spconfig and when I rebooted it, it had gone, swore for a bit had a cuppa and tried to rebuild it all with the error:

              root@xxxxxxxx$ ldm add-vsw net-dev=e1000g0 e1000g0-primary-vsw0 primary
              Multicast socket creation failed.
              Please check your network.
              Automatic MAC allocation not available

              I resolved this by removing the all the network lines in /etc/path_to_inst (to be honest I could have just done the virtual switch devices but by the time I saw that I had already deleted the rest). Than running devfsadm -Cvvv and everything was fine, obviously I was connected via the console and this wasn't a production box but the issue was resolved

              Also forget to mention, make sure network/physical service is running, mine wasn't as it was trying to use /etc/hostname.vnet*

              HTH

              Tim [blue-dragon]