This discussion is archived
2 Replies Latest reply: Jan 1, 2010 12:14 PM by 807567 RSS

Issue using e1000g driver with Intel PRO/1000 GT Desktop Adapter

807567 Newbie
Currently Being Moderated
Hi,

I have been wrestling with this issue for a while now. I have a server at home with Solaris 10 10/08 installed and an Intel PRO/1000 GT Desktop Adapter. The adapter is seen and recognized by Solaris, but when I try to ping an address on that network, it just sits there and nothing happens.
Here is the output in the /var/adm/messages file when the server boots:
*Nov  8 23:20:49 columbia pcplusmp: [ID 637496 kern.info] pcplusmp: pciex8086,10b9 (e1000g) instance 0 vector 0x19 ioapic 0xff intin 0xff is bound to cpu 1*+
*Nov  8 23:20:49 columbia mac: [ID 469746 kern.info] NOTICE: e1000g0 registered*+
*Nov  8 23:20:49 columbia e1000g: [ID 766679 kern.info] Intel(R) PRO/1000 Network Connection, Driver Ver. 5.2.8*+

Here is the output of ifconfig -a:
root@columbia / # ifconfig -a+
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1+
inet 127.0.0.1 netmask ff000000+
lo0:1: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1+
zone filesrv+
inet 127.0.0.1 netmask ff000000+
rge1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2+
inet 192.168.1.18 netmask ffffff00 broadcast 192.168.1.255+
ether 0:18:e7:16:fa:66+
rge1:1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2+
zone filesrv+
inet 192.168.1.20 netmask ffffff00 broadcast 192.168.1.255+
e1000g0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3+
inet 192.168.2.10 netmask ffffff00 broadcast 192.168.2.255+
ether 0:1b:21:26:57:99+

Here is netstat -rn before a ping:
root@columbia / # netstat -rn+

Routing Table: IPv4+
Destination           Gateway           Flags  Ref     Use     Interface+
-------------------- -------------------- ----- ----- ---------- ---------+
default              192.168.1.1          UG        1          2+
*192.168.1.0          192.168.1.18         U         1          4 rge1*
*192.168.2.0          192.168.2.10         U         1          0 e1000g0*
*224.0.0.0            192.168.1.18         U         1          0 rge1*
*127.0.0.1            127.0.0.1            UH        4        115 lo0*

Here is netstat -rn after a ping:
root@columbia / # netstat -rn+

Routing Table: IPv4+
Destination           Gateway           Flags  Ref     Use     Interface+
-------------------- -------------------- ----- ----- ---------- ---------+
default              192.168.1.1          UG        1          2+
*192.168.1.0          192.168.1.18         U         1          4 rge1*
*192.168.2.0          192.168.2.10         U         1          7 e1000g0*
*224.0.0.0            192.168.1.18         U         1          0 rge1*
*127.0.0.1            127.0.0.1            UH        4        115 lo0*

Here is the output of prtconf -D:
root@columbia / # prtconf -D+
System Configuration:  Sun Microsystems  i86pc+
Memory size: 3967 Megabytes+
System Peripherals (Software Nodes):+

i86pc (driver name: rootnex)+
scsi_vhci, instance #0 (driver name: scsi_vhci)+
isa, instance #0 (driver name: isa)+
asy, instance #0 (driver name: asy)+
asy (driver name: asy)+
lp+
i8042, instance #0 (driver name: i8042)+
mouse, instance #0 (driver name: mouse8042)+
keyboard, instance #0 (driver name: kb8042)+
pci, instance #0 (driver name: npe)+
pci1043,826d+
pci1002,7912, instance #0 (driver name: pci_pci)+
display, instance #0 (driver name: vgatext)+
pci1002,7916, instance #1 (driver name: pcie_pci)+
pci8086,1083, instance #0 (driver name: e1000g)+
pci1002,7917, instance #0 (driver name: pcie_pci)+
pci1043,81aa+
pci-ide, instance #0 (driver name: pci-ide)+
ide, instance #0 (driver name: ata)+
cmdk, instance #0 (driver name: cmdk)+
cmdk, instance #1 (driver name: cmdk)+
ide, instance #1 (driver name: ata)+
cmdk, instance #2 (driver name: cmdk)+
cmdk, instance #3 (driver name: cmdk)+
pci1043,81ef, instance #0 (driver name: ohci)+
pci1043,81ef, instance #1 (driver name: ohci)+
pci1043,81ef, instance #2 (driver name: ohci)+
pci1043,81ef, instance #3 (driver name: ohci)+
pci1043,81ef, instance #4 (driver name: ohci)+
pci1043,81ef, instance #0 (driver name: ehci)+
pci1043,81ef+
pci-ide, instance #1 (driver name: pci-ide)+
ide, instance #2 (driver name: ata)+
sd, instance #0 (driver name: sd)+
cmdk, instance #4 (driver name: cmdk)+
ide (driver name: ata)+
pci1043,8249 (driver name: audiohd)+
pci1043,81ef+
pci1002,4384, instance #1 (driver name: pci_pci)+
pci-ide, instance #2 (driver name: pci-ide)+
ide, instance #4 (driver name: ata)+
cmdk, instance #5 (driver name: cmdk)+
cmdk, instance #6 (driver name: cmdk)+
ide, instance #5 (driver name: ata)+
cmdk, instance #7 (driver name: cmdk)+
cmdk, instance #8 (driver name: cmdk)+
pci10ec,8169, instance #1 (driver name: rge)+
pci1022,1100, instance #0 (driver name: mc-amd)+
pci1022,1101, instance #1 (driver name: mc-amd)+
pci1022,1102, instance #2 (driver name: mc-amd)+
pci1022,1103, instance #0 (driver name: amd64_gart)+
iscsi, instance #0 (driver name: iscsi)+
pseudo, instance #0 (driver name: pseudo)+
options, instance #0 (driver name: options)+
xsvc, instance #0 (driver name: xsvc)+
agpgart, instance #0 (driver name: agpgart)+
objmgr, instance #0 (driver name: objmgr)+
used-resources+
cpus, instance #0 (driver name: cpunex)+
cpu (driver name: cpudrv)+
cpu (driver name: cpudrv)+

I have checked the HCL and the non GT adapter is supported, but nothing on the GT version of the Desktop adapter.

When I do the ping, there is no error message in /var/adm/messages.

I was running Solaris 10 x86 u4 before and I could see the autonegotiation messages in the /var/adm/messages file, but not anymore, although here is the output from ndd /dev/e1000g0:
root@columbia / # ndd /dev/e1000g0 link_status+
*1*
root@columbia / # ndd /dev/e1000g0 link_speed+
*1000*
root@columbia / # ndd /dev/e1000g0 link_duplex+
*2*
root@columbia / # ndd /dev/e1000g0 link_autoneg+
*1*

So it looks like everything is good under the sun, but I can't see anybody on that network.
Any idea?

Thanks a lot in advance for the help,
Bertrand.