1 Reply Latest reply on May 30, 2002 12:54 PM by 807567

    problem installing java plugin from jre 1.4.0 on netscape 4.79

    807567
      We tried to install the newest java plugin on netscape
      4.79 on our Solaris 2.8 machine. Followed the instruction, we first downloaded j2re-1_4_0-solsparc.sh, ran the script to create a
      directory called j2re1.4.0, then set the NPX_PLUGIN_PATH environment variable to the directory
      containing the javaplugin.so file. When we tried to
      start netscape, we got the following error message:

      INTERNAL ERROR on Browser End: Could not load the function CreateOJIFactory

      System error?:: No such file or directory

      What is the problem? Any fix?

      Thanks
        • 1. Re: problem installing java plugin from jre 1.4.0 on netscape 4.79
          807567
          Hi,

          From your description, it seems you've read http://java.sun.com/j2se/1.4/install-solaris.html#plugin . This also states that the supported Netscape builds go up to 4.77 before moving on to Netscape 6.x. And in this case it appears that this isn't just because the documentation hasn't kept up with recent activity from Netscape. Netscape 4.79 appears to treat the plugin differently, and/or still expect the old Activator code to be in place to use it.

          I'm using the 1.4.0 JRE with no trouble at all with Netscape 7.0PR1. If anything this - and the Mozilla 1.0RC2 build that it's based on - are far more stable than any of the NS4.x releases. The only reason I can see for staying with 4.x is that it'd little more lax with the HTML it reads, and displays some bad pages that NS6/7 refuses to display.

          Recent Solaris releases come with Netscape 6 as well, and it's easily downloadable. I'm sorry I can't be more help than this.

          Mark Bowyer.

          Sun Developer Technical Support.