1 Reply Latest reply: Jan 30, 2008 11:47 PM by 807574 RSS

    TIME_WAITS prevent Gateway from establishing listening socket.

    807574
      I realize it's old but running PS 6.3 on Linux 2.6 kernel


      I've discovered that there are - normally not a worry - lots of sockets on a gateway box under any load..not a problem...

      But I've found that if I attempt to start the gateway while there are any such sockets the gateway proc. will start but will not be able to bind to the listening port on 443.

      Anyone experience and or solve this or something simillar
        • 1. Re: TIME_WAITS prevent Gateway from establishing listening socket.
          807574
          We try to solve this issue in solaris by setting ndd parameters to a small value.
          There must be something similar for linux too.

          ndd -set /dev/tcp tcp_time_wait_interval 60000
          ndd -set /dev/tcp tcp_fin_wait_2_flush_interval 67500
          ndd -set /dev/tcp tcp_conn_req_max_q 8192
          ndd -set /dev/tcp tcp_conn_req_max_q0 8192
          ndd -set /dev/tcp tcp_ip_abort_interval 60000
          ndd -set /dev/tcp tcp_keepalive_interval 90000
          ndd -set /dev/tcp tcp_rexmit_interval_max 6000
          ndd -set /dev/tcp tcp_rexmit_interval_min 3000
          ndd -set /dev/tcp tcp_rexmit_interval_initial 500
          ndd -set /dev/tcp tcp_smallest_anon_port 1024
          ndd -set /dev/tcp tcp_slow_start_initial 2
          ndd -set /dev/tcp tcp_xmit_hiwat 32768
          ndd -set /dev/tcp tcp_recv_hiwat 32768