12 Replies Latest reply on Sep 11, 2008 12:06 PM by 808160

    error: Server not responding.  IM v7.3

    3004
      imadmin status shows the services UP -

      I cannot telnet localhost or domain on port 5222 or 45222 (connection refused) - from localhost or from other machine.
      I am running an instance of the new "Convergence" Messaging 7.0 -all running in a whole-root (non-global) zone.
      Ports are forwarded from global zone to messaging zone via ipnat/ipf as I have only one IP. Everything else appears to work (mail delivery, convergence minus IM, etc).

      the SMF log has:

      [ Aug 15 14:50:33 Stopping because service disabled. ]
      [ Aug 15 14:50:33 Executing stop method ("/opt/sun/comms/im/sbin/imadmin stop") ]
      Stopping Watchdog [OK]
      Stopping Server [OK]
      Stopping Multiplexor [OK]
      Stopping agent-calendar [OK]
      [ Aug 15 14:50:40 Method "stop" exited with status 0 ]
      [ Aug 15 14:50:45 Enabled. ]
      [ Aug 15 14:50:45 Executing start method ("/opt/sun/comms/im/sbin/imadmin start") ]
      Starting Watchdog [OK]
      [ Aug 15 14:50:50 Method "start" exited with status 0 ]
      Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/im/provider/BroadcastListener$Broadcaster
      at com.iplanet.im.server.NMS.loadConfig(NMS.java:545)
      at com.iplanet.im.server.NMS.init(NMS.java:407)
      at com.iplanet.im.server.NMS.create(NMS.java:199)
      at com.iplanet.im.server.NMS.main(NMS.java:1055)
      Starting Server [OK]
      Starting Multiplexor [OK]
      Starting agent-calendar [OK]


      here is xmppd.log (nothing in mux.log)

      [15 Aug 2008 14:50:52,825] INFO xmppd [main] Starting XMPP Server: Version 7.3
      [15 Aug 2008 14:50:53,112] INFO xmppd [main] Server default domain : my.domain.com
      [15 Aug 2008 14:50:53,113] ERROR xmppd [main] Compatability mode enabled - use iim_server.jid.encoding.compat to disable it.
      [15 Aug 2008 14:50:53,113] ERROR xmppd [main] This is available only for backward compatibility. Newer features may have problems in this mode (s2s, etc).
      [15 Aug 2008 14:50:53,113] ERROR xmppd [main] Support for this will be removed in future release.


      my install failed twice during the install procedure, but succeeded on 3rd try (virtual memory issues).

      i have DEBUG logging on - not sure if log4j is doing anything - but my logs do not have much.
        • 1. Re: error: Server not responding.  IM v7.3
          807574
          Where do you have IM installed ?...Did you get the "Server not responding" message while you try login to IM through java client ?

          Regards,
          Swetha
          • 2. Re: error: Server not responding.  IM v7.3
            3004
            Hello -
            I get the error when using the Java client - also in Convergence (the new JES Messaging 7.0 webmai/calendar/IMl client), it just shows as Connecting... (but never does connect).

            It is running on the same machine as calendar and messaging server. imadmin status shows each service as UP - iim.conf specifies 5222 and 45222 as ports to run on, yet I can not telnet to these ports, even on the localhost (using the local ip, static ip, or localhost 5222, etc.).


            Thanks for any info.


            s 7
            • 3. Re: error: Server not responding.  IM v7.3
              808160
              Hi,
              Is telnet to that m/c working at all ?...Check your firewall settings...You can try connecting your client through this url if httpbind is deployed,
              In the login window,in server field change host:5222 to http://host:port/httpbind/httpbind?to=domain
              where,
              host - Fully Qualified Host name
              port - webcontainer port where httpbind is deployed
              domain - domain to which your IM server is configured for

              eg : http://test.india.sun.com:8080/httpbind/httpbind?to=india.sun.com and connect.

              This should work since firewall lets http traffic in.

              Also to connect from Convergence you need to configure IM,have you done that.
              If not,you can refer the below doc for the same,http://wikis.sun.com/display/CommSuite/Sun+Java+Communications+Suite+6+on+a+Single+Host?focusedCommentId=44598783#SunJavaCommunicationsSuite6onaSingleHost-ConfiguringSunConvergence

              Let me know if any issues

              HTH,
              Swetha
              • 4. Re: error: Server not responding.  IM v7.3
                3004
                Thanks for the info. Unfortunately I receive the same error using the httpbind URL. Also the URL in a web browser returns not found. I'm not sure if httpbind is deployed (wouldn't it eventually be talking on 5222?) I think it would be deployed during the IM install. In any event, I did set up httpbind (and another type) of string (maybe avatars) in iim.conf.

                There is also an httpbind.log under /opt/sun/comms/iwc/log

                [19 Aug 2008 08:25:03,833] INFO httpbind [httpSSLWorkerThread-80-1] Creating a
                new session - sid 2448653845939621879 , rid : 971769018

                I also have an xmppd.log

                [18 Aug 2008 18:51:12,522] INFO xmppd [main] Starting XMPP Server: Version 7.3
                [18 Aug 2008 18:51:12,773] INFO xmppd [main] Server default domain : foo.bar.moose.com
                [18 Aug 2008 18:51:12,773] ERROR xmppd [main] Compatability mode enabled - use iim_server.jid.encoding.compat to disable it.
                [18 Aug 2008 18:51:12,774] ERROR xmppd [main] This is available only for backward compatibility. Newer features may have problems in this mode (s2s, etc).
                [18 Aug 2008 18:51:12,774] ERROR xmppd [main] Support for this will be removed in future release.



                I have configured IM according to the instructions in that document. I should mention the install failed twice, but completed successfully on a third try.

                Should I uninstall and reinstall (how)? As mentioned earlier, imadmin status shows the services as UP yet telnet on local and remote hosts to 5222 or 45222 or 5269 is refused. The server is running in a whole root zone. All necessary ports including 5222 and 45222, etc. are forwarded via pfil and ipnat to the appropriate place.The ports have not been a problem for any other Convergence app, so I'm pretty sure IM is just not running.

                The passwords for httpbind and avatars in iim.conf are clear text while the passwds in httpbind.conf are encrypted.
                • 5. Re: error: Server not responding.  IM v7.3
                  808160
                  Hi,
                  Sorry for the delayed response.You cannot access httpbind url from the browser.You need to enter it in the server field of the IM login window.If httpbind is deployed it would be talking to 5269 not 5222.
                  I suggest you to please check if you have all the IM packages installed.You need to have "SUNWiimdv" package installed into the global zone,which is a shared component of IM.
                  Also please check SMF logs for any exceptions,errors ? Yes the passwords in iim.conf are in clear text,this is a known issue.

                  HTH,
                  Swetha
                  • 6. Re: error: Server not responding.  IM v7.3
                    3004
                    Thanks for your reply.

                    SUNWiimdv was already installed in the global and my whole-root messaging zone.

                    I removed it from the global and it was removed from the whole-root zone as well during pkgrm.

                    It had been installed in the global zone with an earlier version of the JES.

                    I reinstalled (but did not configure) IM with the new commpkg installer in the global zone.

                    After restarting all the services in my whole-root messaging zone, IM came up in Convergence.

                    Can I chat with people using other Jive servers? I have only been able to get it working with users in the same Convergence domain.

                    Thanks,
                    s7
                    • 7. Re: error: Server not responding.  IM v7.3
                      808160
                      Yes SUNWiimdv is a shared component of IM and hence you would have to manually remove that package.The uninstaller does not remove it.

                      Yes you can chat with people on "OpenFire" but you need to enable Server to Server communication between the jive server and Sun IM server.

                      Let me know if you need any other clarification.

                      Regards,
                      Swetha
                      • 8. Re: error: Server not responding.  IM v7.3
                        3004
                        Thanks Swetha,

                        How do you enable server-to-server communication between IM servers?
                        Is there some setting in iim.conf (or elsewhere)?
                        What if 1 of the other servers I want to chat with is SSL only? How do I generate a certificate for my instance?
                        What additional ports should I make sure are open, etc.
                        • 9. Re: error: Server not responding.  IM v7.3
                          807574
                          starman7 wrote:
                          How do you enable server-to-server communication between IM servers?
                          Information on Federating IM servers is available here:

                          http://www.sun.com/bigadmin/hubs/comms/files/fed_deploy_im_servers.html
                          What if 1 of the other servers I want to chat with is SSL only? How do I generate a certificate for my instance?
                          Refer to the manuals:

                          http://docs.sun.com/app/docs/doc/819-4412/achbu?a=view

                          Regards,

                          Shane.
                          • 10. Re: error: Server not responding.  IM v7.3
                            3004
                            Thanks,

                            I added iim_server.openfederation.enabled = "true" and refreshed but still can't talk to gmail/gtalk.

                            I then also added the certificate and refreshed the server - I think the certs are OK because on a previous go, IIM wouldn't startup (I think):

                            from iim config dir:

                            keytool -genkey -alias IIM -keyalg RSA -keypass secretpass -storepass secretpass -keystore keystore.jks
                            keytool -export -alias IIM -storepass secretpass -file server.cer -keystore keystore.jks
                            keytool -import -v -trustcacerts -alias IIM -file server.cer -keystore cacerts.jks -keypass secretpass -storepass secretpass

                            I have these new files:
                            -rw-r--r-- 1 root root 688 Sep 2 15:36 cacerts.jks
                            -rw-r--r-- 1 root root 624 Sep 2 15:35 server.cer
                            -rw-r--r-- 1 root root 1395 Sep 2 15:34 keystore.jks



                            The doc mentioned IIM will look at SRV records - the domain I am using is setup in such a way that the machine foo.bar.com is the domain - e.g. jsmith@bar.com doesn't exist - where jsmith@foo.bar.com does. I am not sure if that is relevant with regard to the problem or what IIM does with SRV. I am not using a white or black list. I do not control the DNS.

                            Should I bother try to whitelist the servers I want to chat with? How can I troubleshoot? I can telnet and get responses on 5222 and 45222. Do I need to add an alias for my server?


                            Thanks,
                            s7


                            here is some xmppd.log:


                            which seems to show a dns (srv?) problem - is there any workaround? i don't control the dns for this machine (there currently A and MX records for the IP to foo.this.that.bar.com):




                            [02 Sep 2008 15:58:05,261] INFO xmppd [default-iim_server-worker 0] sent CMD_PING ack
                            [02 Sep 2008 15:58:42,032] INFO xmppd [default-iim_server-worker 1] [ServerAcceptorSelection][0.0.0.0:5269] accepted /209.85.162.129
                            [02 Sep 2008 15:58:42,055] INFO xmppd [default-iim_server-worker 1] [ServerAcceptorSelection][0.0.0.0:5269] accepted /209.85.162.129
                            [02 Sep 2008 15:58:42,090] INFO xmppd [default-iim_server-worker 1] domain returned : foo.this.that.bar.com for searchbase being ignored since it is not the configured domain for : this.that.bar.com




                            [02 Sep 2008 16:02:38,533] INFO xmppd [default-iim_server-worker 2] Domain specified is not known : foo.this.that.bar.com
                            org.jabberstudio.jso.StreamException: Domain specified is not known : foo.this.that.bar.com
                            at net.outer_planes.jso.AbstractStream.firePacketTransferredEvent(AbstractStream.java:697)
                            at net.outer_planes.jso.AbstractStream$Input$1.addExtendedData(AbstractStream.java:116)
                            at net.outer_planes.jso.AbstractStream$Input.process(AbstractStream.java:204)
                            at net.outer_planes.jso.AbstractStream.process(AbstractStream.java:1176)
                            at com.iplanet.im.server.OutConnection.process(OutConnection.java:179)
                            at com.iplanet.im.server.OutConnection.dataAvailable(OutConnection.java:988)
                            at com.iplanet.im.common.io.TerminalChannel.readable(TerminalChannel.java:152)
                            at com.iplanet.im.common.io.TerminalChannel.access$200(TerminalChannel.java:21)
                            at com.iplanet.im.common.io.TerminalChannel$ChannelSelection$2.run(TerminalChannel.java:196)
                            at org.netbeans.lib.collab.util.Worker.run(Worker.java:244)
                            at java.lang.Thread.run(Thread.java:595)

                            Edited by: starman7 on Sep 3, 2008 5:51 AM
                            • 11. Re: error: Server not responding.  IM v7.3
                              807574
                              starman7 wrote:
                              I added iim_server.openfederation.enabled = "true" and refreshed but still can't talk to gmail/gtalk.
                              Or it may be that gmail cannot talk to you:

                              "If you are building your own XMPP service, refer to the XMPP specs. If you are using a commercial or open-source jabber server such as ejabberd, then federation should just work. One important thing to note is that we use dial-back for authentication."

                              http://code.google.com/apis/talk/open_communications.html#service
                              The doc mentioned IIM will look at SRV records - the domain I am using is setup in such a way that the machine foo.bar.com is the domain - e.g. jsmith@bar.com doesn't exist - where jsmith@foo.bar.com does. I am not sure if that is relevant with regard to the problem or what IIM does with SRV. I am not using a white or black list. I do not control the DNS.
                              This may indeed be relevant for google talk to dial-back to your system. Hopefully another forum reader that has successfully enabled federation with google can comment.

                              Regards,

                              Shane.
                              • 12. Re: error: Server not responding.  IM v7.3
                                808160
                                Hi,
                                Could you check if you are able to ping google.com,talk.google.com from the host where you are connecting ?
                                Also enable debug logs for IM in log4j.conf and check if any errors in xmppd.log,dialback should suceed for you to connect.

                                Regards,
                                Swetha