9 Replies Latest reply on Aug 18, 2005 12:16 PM by 807573

    NSMMReplicationPlugin - Unable to acquire replica

    807573
      10/Mar/2003:16:54:56 -0500] NSMMReplicationPlugin - Unable to acquire replica "cn=ims, cn=replica, cn="o=ims.com", cn=mapping tree, cn=config (host sun172.ims.deco.com, port 389)": permission denied. The bind dn "cn=Replication Manager,cn=config"
      does not have permission to supply replication updates to the replica. Will retry later.

      That is the error iam getting when ever i intialise the Master. Is any body know what is this error means. I followed the document as it specified.
      Is there any permission do i need to specify while iam creating agreements?

      Thanks in advance
        • 1. Re: NSMMReplicationPlugin - Unable to acquire replica
          807573
          Make sure you have configured the bindDN correctly in the cn=replica configuration on the consumer.
          • 2. Re: NSMMReplicationPlugin - Unable to acquire replica
            807573
            yes , i checked the cn=replica , cn=mapping tree branch .The value is getting created when i create a replication.
            Another thing here is, when i put replication name as "ims" , but the replication error show it is looking from "ims.com", but it gets created as ims, because that what i gave name as, when my replication is getting created.

            Can u please tell me what is this means "bindDB correctly in the cn=replica configuration" . As for as my knowledge it gets created under cn=mapping tree,... right ?
            • 3. Re: NSMMReplicationPlugin - Unable to acquire replica
              807573
              On your master/supplier, make sure you have entered the correct values for the replication user bind DN and password in the replication agreement configuration. Also, on the consumer, make sure you have created that user's entry, and make sure in the replica configuration you have specified that user's DN as the replica bind DN.

              Also, look at the access log on the consumer to look for the BIND operation to see what the exact bind DN is and what error code is being returned.
              • 4. Re: NSMMReplicationPlugin - Unable to acquire replica
                807573
                [11/Mar/2003:09:49:52 -0500] conn=23 fd=28 slot=28 connection from 162.9.101.132 to 162.9.101.133
                [11/Mar/2003:09:49:52 -0500] conn=23 op=0 BIND dn="cn=Replication Manager,cn=config" method=128 version=3
                [11/Mar/2003:09:49:52 -0500] conn=23 op=0 RESULT err=0 tag=97 nentries=0 etime=0 dn=""
                [11/Mar/2003:09:49:52 -0500] conn=23 op=1 SRCH base="" scope=0 filter="(objectClass=*)" attrs="supportedControl supportedExtension"
                [11/Mar/2003:09:49:52 -0500] conn=23 op=1 RESULT err=0 tag=101 nentries=1 etime=0
                [11/Mar/2003:09:49:52 -0500] conn=23 op=2 EXT oid="2.16.840.1.113730.3.5.3"
                [11/Mar/2003:09:49:52 -0500] conn=23 op=2 RESULT err=0 tag=120 nentries=0 etime=0
                [11/Mar/2003:09:49:52 -0500] conn=23 op=3 UNBIND

                this is my access log.

                When i initailize consumer the error iam getting is "The error received by the replica is: '3 Replication error acquiring replica: permission denied'.

                I re-doing every thing including installtion software. i guess i did some thing wrong when i first setup. I really appriciate your help on this thank you very much. I will keep posting if i have any errors.
                • 5. Re: NSMMReplicationPlugin - Unable to acquire replica
                  807573
                  Hi,

                  I'm getting exactly the same error you got. Were you able to make it work? I guess I'm missing some important step.

                  Thanks a lot
                  Jorge
                  • 6. Re: NSMMReplicationPlugin - Unable to acquire replica
                    807573
                    Hi,

                    Your problem comes from your legacy consumer settings.

                    You use the same user (Legacy consumer) than
                    the one stated in your replica.

                    Try to simply disable Legacy Consumer and it will
                    work fine (or use another user)
                    Legacy Consumer is not necessary for MM replications

                    Regards,

                    Vincent MAZARD
                    • 7. Re: NSMMReplicationPlugin - Unable to acquire replica
                      807573
                      I'm getting the same error as well (it's not the Legacy Consumer settings). I have several replicas that are replicating to various places. My goal is to create a complete copy of my master to I can do some load balancing. I was able to replicate a "test" replica from my master to alt_master and then from alt_master to master. When I try to configure an exisiting replica as a MulitMaster, I get that error ...

                      NSMMReplicationPlugin - Incoming replication session was unable to acquire replica ou=CallCenter,dc=MyCompany,dc=net,dc=com - error: permission denied

                      I gotta keep banging away on this ... if anyone has a clue ... let me know ... Thanks!
                      • 8. Re: NSMMReplicationPlugin - Unable to acquire replica
                        807573
                        Any resolution to this!! I'm getting that same error..

                        "Replication error acquiring replica: permission denied. Error Code 3
                        I have the same setup on a number of boxes but a few give this..
                        -Keith
                        • 9. vincent mazard's way is right
                          807573
                          I meet the same error, so I found this topic.
                          and I did as vincent mazard said, it's ok now.

                          add a new user under "replication" folder(icon like a folder),
                          the user's uid is "mreplication"
                          and the user's dn is "uid=mreplication,dc=replication,dc=config"

                          set this dn string to Configuration tab - > Relication -> your database that want be replicated -> Replica Settings -> Current Supplier Dns

                          use this dn string and it's password to initial consumer, all're ok.
                          don't need to delete legacy consumer user(this also is cn=Replication Manager,cn=config)

                          From China