1 2 Previous Next 25 Replies Latest reply: May 7, 2008 2:14 AM by 807581 Go to original post RSS
      • 15. Re: Tomcat start problem in NetBeans
        807581
        Great! now i can start the server from "Runtime" tab but can't expand "Web Applications" node
        Also, when I switch to "Projects" and try to "Run Project" it fails and says:

        init:
        deps-module-jar:
        deps-ear-jar:
        deps-jar:
        library-inclusion-in-archive:
        library-inclusion-in-manifest:
        compile:
        compile-jsps:
        do-dist:
        dist:
        run-deploy:
        Deployment error: null. See the server log file for details.



        Also, just when I start NetBeans I get a pop up with:

        A java.lang.IllegalArgumentException exception has occurred.
        Please report this at http://www.netbeans.org/issues.html,
        including a copy of your messages.log file as an attachment.
        The messages.log file is located in your C:\Documents and Settings\.netbeans\4.1\var\log folder.
        • 16. Re: Tomcat start problem in NetBeans
          807581
          The most probable reason for these errors is that the new ide install ide is unable to work with the older user directory.

          Can you try stopping the ide, rename "C:\Documents and Settings\.netbeans\4.1" to "C:\Documents and Settings\.netbeans\4.1.old" in the explorer and restart the ide?

          Ref: http://blogs.sun.com/karthikr
          • 17. Re: Tomcat start problem in NetBeans
            807581
            thanks

            Hello,

            I did as you advised me.
            When I start NB I get a pop up with "Exception occurred in Request Processor".

            Also, I still cannot deploy my app. I get the same error.
            • 18. Re: Tomcat start problem in NetBeans
              807581
              A couple of things you can try:

              1. Deploy to the bundled appserver.
              If you had installed the bunded sun java system application server, then you can go to runtime tab and start the appserver. In your project properties, change the server to appserver8.1 (from bundled tomcat) and then try deploying.

              2. Stop the servers if running and exit the ide. Open <installdir>/etc/*.conf file and change the userdirectory to a completely new dir. (The dir doesn't have to exist; the ide will create the dir on startup). Restart the ide and try deploying the app.
              • 19. Re: Tomcat start problem in NetBeans
                807581
                Thank you for your help.

                I think I finally fixed it.
                • 20. Re: Tomcat start problem in NetBeans
                  807581
                  Here's another take on this issue...

                  If the Tomcat server bundled with NetBeans will not start when you try to deploy (run) a web application and you get the following output in the
                  Output:ProgramName(debug) window:

                  init:
                  deps-module-jar:
                  deps-ear-jar:
                  deps-jar:
                  library-inclusion-in-archive:
                  library-inclusion-in-manifest:
                  compile:
                  compile-jsps:
                  do-dist:
                  dist:
                  debug:
                  Starting debug server Bundled Tomcat (5.5.9)
                  Starting Tomcat process...
                  Waiting for Tomcat...
                  Starting of Tomcat failed.
                  C:\H-Drive\public_html\grades\gradedisplay5\nbproject\build-impl.xml:431: Deployment error:
                  Starting of Tomcat failed.
                  See the server log for details.
                  BUILD FAILED (total time: 4 seconds)

                  look in the Output:Bundled Tomcat (5.5.9) window. There you will see:

                  The JAVA_HOME environment variable is not defined correctly
                  This environment variable is needed to run this program
                  NB: JAVA_HOME should point to a JDK not a JRE
                  Using CATALINA_BASE: C:\Documents and Settings\Jesse\.netbeans\5.0\jakarta-tomcat-5.5.9_base
                  Using CATALINA_HOME: C:\Program Files\netbeans-5.0\enterprise2\jakarta-tomcat-5.5.9
                  Using CATALINA_TMPDIR: C:\Documents and Settings\Jesse\.netbeans\5.0\jakarta-tomcat-5.5.9_base\temp
                  Using JAVA_HOME: C:\Program Files\Java\jdk1.5.0_04
                  '-Djava.util.logging.manager' is not recognized as an internal or external command,
                  operable program or batch file.

                  The cause of the error is that JAVA_HOME is not correct. In the above case it's pointing to jdk1.5.0_04. It should be pointing to jdk1.5.0_06. To correct this problem:

                  (1) Shut down the NetBeans IDE.
                  (2) Go to Start->Control Panel.
                  (3) In the Control Panel, double-click the System icon.
                  (4) In the System Properties dialog box, click the Advanced tab and then the Environment Variables button.
                  (5) In the Environment Variables dialog box, highlight the entry for Java_Home in the "System variables" listbox.
                  (6) Click the Edit button.
                  (7) Change the entry to the correct path to the current JDK. In my case this is: C:\Program Files\Java\jdk1.5.0_06
                  (8) Click the OK button to close the Environment Variables dialog box. There will be a pause while the system writes out the environment variables. You can close the other open dialog boxes at this point if you wish.
                  (9) Restart the NetBeans IDE. (The environment variables are only read at startup.)
                  (10) Try to deploy (run) your web application again. It should now work!

                  Jesse Heines, UMass Lowell CS
                  • 21. Re: Tomcat start problem in NetBeans
                    807581
                    Hello
                    I am having the same problem trying to run a simple web application after a new installation of netbeans ide 5.0.
                    Is necessary a new installation of netbeans or did you rezolved this problem in another way?

                    Thanks for tour time!
                    • 22. Re: Tomcat start problem in NetBeans
                      807581
                      If you are not particular about using NB4.x, I would suggest trying

                      Netbeans 5.0
                      (http://www.netbeans.info/downloads/download.php?type=5.0)

                      or

                      Netbeans 5.5 Beta (http://www.netbeans.info/downloads/download.php?type=5.5b)

                      Note:

                      1) NB5.x is based on JDK1.5
                      2) When you install, if you are not particular about migration of userdir from 4.1, try not to import it.

                      Thanks
                      Ayub
                      • 23. Re: starting of tomcat failed in NetBeans
                        807581
                        I�m using Netbeans 5.5.1 with bundled tomcat 5.5.17. Each time, when I try to run a web app (even the sample web projects coming with Netbeans IDE), i receive the following error: "starting of tomcat failed".But when My PC is connected to the internet all works fine. I don't know why Netbeans fails to connect to Tomcat server when there is non internet connection
                        • 24. Re: Tomcat start problem in NetBeans
                          807581
                          SEVERE Error starting static Resources java.lang.IllegalArgumentException netbeans

                          go to <tomcat-directory>/conf/catlina/localhost

                          check for the projectfile which is causing the problem.there should .xml file of the project.delete this file.
                          • 25. Re: Tomcat start problem in NetBeans
                            807581
                            Hello!
                            I'm using Netbeans IDE 6.9 & Tomcat 6.0.29. When I'm trying to deploy project, I reseive:


                            Tomcat 6.0 tab in NetBeans:

                            Using CATALINA_BASE: "C:\WebServers\apache-tomcat-6.0.29"
                            Using CATALINA_HOME: "C:\WebServers\apache-tomcat-6.0.29"
                            Using CATALINA_TMPDIR: "C:\WebServers\apache-tomcat-6.0.29\temp"
                            Using JRE_HOME: "C:\Program Files\Java\jdk1.6.0_20"
                            Using CLASSPATH: "C:\WebServers\apache-tomcat-6.0.29\bin\bootstrap.jar"
                            02.09.2010 12:18:48 org.apache.catalina.core.AprLifecycleListener init
                            INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
                            02.09.2010 12:18:48 org.apache.catalina.core.AprLifecycleListener init
                            INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
                            02.09.2010 12:18:51 org.apache.coyote.http11.Http11AprProtocol init
                            INFO: Initializing Coyote HTTP/1.1 on http-8080
                            02.09.2010 12:18:51 org.apache.coyote.ajp.AjpAprProtocol init
                            INFO: Initializing Coyote AJP/1.3 on ajp-8009
                            02.09.2010 12:18:51 org.apache.catalina.startup.Catalina load
                            INFO: Initialization processed in 3362 ms
                            02.09.2010 12:18:51 org.apache.catalina.core.StandardService start
                            INFO: Starting service Catalina
                            02.09.2010 12:18:51 org.apache.catalina.core.StandardEngine start
                            INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
                            02.09.2010 12:18:51 org.apache.catalina.startup.HostConfig deployDescriptor
                            INFO: Deploying configuration descriptor host-manager.xml
                            02.09.2010 12:18:53 org.apache.catalina.startup.HostConfig deployDescriptor
                            INFO: Deploying configuration descriptor manager.xml
                            02.09.2010 12:18:53 org.apache.catalina.startup.HostConfig deployDirectory
                            INFO: Deploying web application directory docs
                            02.09.2010 12:18:53 org.apache.catalina.startup.HostConfig deployDirectory
                            INFO: Deploying web application directory examples
                            02.09.2010 12:18:54 org.apache.catalina.startup.HostConfig deployDirectory
                            INFO: Deploying web application directory ROOT
                            02.09.2010 12:18:54 org.apache.coyote.http11.Http11AprProtocol start
                            INFO: Starting Coyote HTTP/1.1 on http-8080
                            02.09.2010 12:18:54 org.apache.coyote.ajp.AjpAprProtocol start
                            INFO: Starting Coyote AJP/1.3 on ajp-8009
                            02.09.2010 12:18:54 org.apache.catalina.startup.Catalina start
                            INFO: Server startup in 3644 ms

                            Web application (run-deploy) tab in NetBeans:

                            init:
                            deps-module-jar:
                            deps-ear-jar:
                            deps-jar:
                            library-inclusion-in-archive:
                            Copying 1 file to F:\Java\Code\WebApplication3\build\web\WEB-INF\lib
                            Copying 1 file to F:\Java\Code\WebApplication3\build\web\WEB-INF\lib
                            library-inclusion-in-manifest:
                            compile:
                            compile-jsps:
                            Starting Tomcat process...
                            Waiting for Tomcat...
                            Starting of Tomcat failed.
                            F:\Java\Code\WebApplication3\nbproject\build-impl.xml:688: Deployment error:
                            Starting of Tomcat failed.
                            See the server log for details.
                            BUILD FAILED (total time: 3 minutes 10 seconds)

                            What could be done to resolve this problem?
                            Thank you!
                            1 2 Previous Next