2 Replies Latest reply: Apr 26, 2008 2:02 AM by 807581 RSS

    Problem on NetBeans 6.0.1 with Tomcat 6.0.14

      I had to uninstall and reinstall netbeans because at some point I always appeared a message in which I was reported that tomcat 8025 had already started.
      I closed and reopened the environment without result.
      In Server uninstall apache and try to put a standalone vers 5.5.25.
      It seems ok but does not appear in the list of available servers for my projects.

      If i tried to add tomcat 6.0.14 it's appear on the list but i obtain always the error:
      Starting of Tomcat failed, the server port 8025 is already in use.
      Deployment error:
      Starting of Tomcat failed, the server port 8025 is already in use.
      See the server log for details.
              at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:163)
              at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:104)
              at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
              at sun.reflect.GeneratedMethodAccessor160.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
              at org.apache.tools.ant.Task.perform(Task.java:348)
              at org.apache.tools.ant.Target.execute(Target.java:357)
              at org.apache.tools.ant.Target.performTasks(Target.java:385)
              at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
              at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
              at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
              at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
              at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:277)
              at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:460)
              at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
      Caused by: org.netbeans.modules.j2ee.deployment.impl.ServerException: Starting of Tomcat failed, the server port 8025 is already in use.
              at org.netbeans.modules.j2ee.deployment.impl.ServerInstance._start(ServerInstance.java:1270)
              at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget(ServerInstance.java:1224)
              at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget(ServerInstance.java:1035)
              at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.start(ServerInstance.java:912)
              at org.netbeans.modules.j2ee.deployment.impl.TargetServer.startTargets(TargetServer.java:417)
              at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:140)
              ... 16 more
      BUILD FAILED (total time: 0 seconds)
      For the moment i have resolved by change the port from 8025 to 8026 but i don't like this solution. :-(

      While the problem on tomcat 5.5.25 that it's not appear on the list of servers for my projects remain.
        • 1. Re: Problem on NetBeans 6.0.1 with Tomcat 6.0.14
          I am experiencing the same problem. Tomcat 5.5 does not appear in the server list when I am on the properties page for my web app.

          • 2. Re: Problem on NetBeans 6.0.1 with Tomcat 6.0.14
            I'm resolved the problem on server list, simply specifying a project as j2ee 5 can not appear tomcat 5.5 is necessary to specify j2ee 1.4.

            While for the problem on port just in use I have noticed that sometimes the server remains it isn't close, even exiting from NetBeans, for the moment i use the workaround of closing the process tomcat of linux.

            I hope that on netbeans 6.1 the problem is solved (if it had solved the problem permgen would be even more pleased, but that apparently is a problem of java and then not entered the environment from development).