5 Replies Latest reply on Jan 10, 2005 9:44 PM by 807581

    Problem starting Sun One Application - JMS Exception

    807581
      Hello,



      I'm having some trouble trying to start SunONE JMS sever via the Sun ONE application server v7 running on RedHat Linux 7.3.

      When I start the app server via the asadmin tool I receive the following exception,



      [root@sc-test1 config]# asadmin start-appserv

      Instance domain1:admin-server started

      Could not start the instance: domain1:server1

      server failed to start: abnormal subprocess termination

      Could not start one or more instances in the domain : domain1

      Could not start one or more domains



      The following exception is outputted to the server log,



      19/Sep/2003:15:47:14] INFO ( 2135): CORE1116: Sun ONE Application Server 7.0.0_00

      [19/Sep/2003:15:47:15] INFO ( 2137): CORE3016: daemon is running as super-user

      [19/Sep/2003:15:47:17] INFO ( 2137): CORE5076: Using [Java HotSpot(TM) Server VM, Version 1.4.1] from [Sun Microsystems Inc.]

      [19/Sep/2003:15:47:54] INFO ( 2137): JMS5035: Timed out after 30000 milliseconds while trying to verify if the JMS service startup succeeded.

      [19/Sep/2003:15:47:54] INFO ( 2137): JMS5036: More details may be available in the log file for the JMS service broker instance domain1_server1. Please refer to the JMS provider documentation for the exact location of this log file.

      [19/Sep/2003:15:47:54] SEVERE ( 2137): JMS5024: JMS service startup failed.

      [19/Sep/2003:15:47:54] SEVERE ( 2137): CORE5071: An error occurred during initialization

      com.sun.appserv.server.ServerLifecycleException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException

      at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:247)

      at com.iplanet.ias.server.ApplicationServer.onInitialization(ApplicationServer.java:206)

      at com.iplanet.ias.server.J2EERunner.confPreInit(J2EERunner.java:114)

      Caused by: com.sun.appserv.server.ServerLifecycleException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException

      at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:231)

      ... 2 more

      Caused by: javax.jms.JMSException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException

      at com.sun.messaging.jmq.jmsclient.ExceptionHandler.getJMSException(ExceptionHandler.java:183)

      at com.sun.messaging.jmq.jmsclient.ExceptionHandler.handleException(ExceptionHandler.java:136)

      at com.sun.messaging.jmq.jmsclient.PortMapperClient.readBrokerPorts(PortMapperClient.java:145)

      at com.sun.messaging.jmq.jmsclient.PortMapperClient.init(PortMapperClient.java:86)

      at com.sun.messaging.jmq.jmsclient.PortMapperClient.<init>(PortMapperClient.java:47)

      at com.sun.messaging.jmq.jmsclient.protocol.tcp.TCPConnectionHandler.<init>(TCPConnectionHandler.java:46)

      at com.sun.messaging.jmq.jmsclient.protocol.tcp.TCPStreamHandler.openConnection(TCPStreamHandler.java:101)

      at com.sun.messaging.jmq.jmsclient.ProtocolHandler.init(ProtocolHandler.java:501)

      at com.sun.messaging.jmq.jmsclient.ProtocolHandler.<init>(ProtocolHandler.java:930)

      at com.sun.messaging.jmq.jmsclient.ConnectionImpl.openConnection(ConnectionImpl.java:1482)

      at com.sun.messaging.jmq.jmsclient.ConnectionImpl.init(ConnectionImpl.java:403)

      at com.sun.messaging.jmq.jmsclient.ConnectionImpl.<init>(ConnectionImpl.java:234)

      at com.sun.messaging.jmq.jmsclient.UnifiedConnectionImpl.<init>(UnifiedConnectionImpl.java:33)

      at com.sun.messaging.jmq.jmsclient.QueueConnectionImpl.<init>(QueueConnectionImpl.java:32)

      at com.sun.messaging.ConnectionFactory.createQueueConnection(ConnectionFactory.java:72)

      at com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.pingProvider(JMSAdminImpl.java:733)

      at com.iplanet.ias.jms.JmsProviderLifecycle.waitForJmsProvider(JmsProviderLifecycle.java:284)

      at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:224)

      ... 2 more



      [19/Sep/2003:15:47:54] SEVERE ( 2137): CORE3186: Failed to set configuration



      I can confirm that the default JMS port (7676) is not be used elsewhere / by another process on the server and that netfilter/iptables are not active/running.

      I have also tried different/alternative ports for the JMS server however it still fails to startup.



      Any help much appreciated.



      Thanks and Regards,

      Rachel Gilmer
        • 1. Re: Problem starting Sun One Application - JMS Exception
          807581
          hi, i am desperate with the same problem. could anyone help. i am in redhat linux 8.0, and i also tried to put a rule to accept any input at 7676. doesn't work too with the same exception. so it is not problem with the port. just suspect whether the start script really starting a listener for listening at 7676
          • 2. Re: Problem starting Sun One Application - JMS Exception
            807581
            Hi,

            What is the JMS service port for the relevant appserver instance ?

            asadmin get <instance name>.jms-service.port

            e.g.
            asadmin get server1.jms-service.port

            Perhaps the JMS service port is not 7676 and whatever port it is set to
            is in conflict with
            something else.

            FYI - there is an article on JMS Service startup issues that may help:

            Article # 8270
            JMS Service startup problems
            http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsunone%2F8270&zone_110=8270%2A%20
            • 3. Re: Problem starting Sun One Application - JMS Exception
              807581
              I believe I have just cracked this problem on my Solaris system. Just as you suspected, the application server was listening on a different port to what JMS was using.
              I fixed the problem by identifying the listener port with the following command:
              /usr/ucb/ps wwwax | grep -i broker
              (or look in the server.xml file)

              - and then put this port no. into the JMS port using the SunONE appserver GUI.
              Sorted!
              • 4. Re: Problem starting Sun One Application - JMS Exception
                807581
                I have encountered similar problem when running Sun Application server 7 in Fedora Core 2.

                It seems that problem was due to improper shutdown of my system.

                Following was what I did to resolve the problem:

                Look for the JMS installation directory (installed & created together with the application server). Mine is in /var/opt/imq. In the dir,
                look for directory instances/domain1_server1 (if your server is running in domain1 server1). Look for a file called lock. Remove the lock file (rename if you are not sure).
                After that I was able to successfully start the server.
                • 5. Re: Problem starting Sun One Application - JMS Exception
                  807581
                  The SunSolve article URL has changed apparently - I managed to
                  track down the new URL:

                  JMS Service startup problems
                  http://sunsolve.sun.com/search/document.do?assetkey=1-9-68270-1&searchclause=68270

                  regards,
                  -i
                  http://www.sun.com/software/products/message_queue/index.xml