This discussion is archived
2 Replies Latest reply: Jul 7, 2009 10:09 PM by 807581 RSS

MEP client application does not work on Nokia simulator

807581 Newbie
Currently Being Moderated
Hi ,
I have build the MEP client that works fine on the WTK emulator and blackberry simulator.however when i try to deploy the same application on Nokia 95 simulator, the application installs but does not excute.

Another problem that i am facing is, i tried to use J2me Polish to improve the GUI of the application that works fine on WTK and Blackberry. But as soon as i try to use j2me polish the application doesn't work on WTK and blackberry.

Please suggest me some quick ways to improve the GUI of the existing application.

Thanks
  • 1. Re: MEP client application does not work on Nokia simulator
    807581 Newbie
    Currently Being Moderated
    The only issue I've run into when going from the WTK emulator (with a basic LCDUI based SGMP client app) to the Nokia simulator is specifying the file system root:

    //#if NokiaE61Config
    //# syncMgr = new SyncManager(".obj", securityMgr, "Memory card/");
    //#else
    syncMgr = new SyncManager(".obj", securityMgr);
    //#endif

    The Nokia devices seem to have different symbolic names for the filesystem roots. In this case, I'm using NB's preprocessor directives to support multiple devices. When I'm building my app for an E61, I have to specify "Memory card/" as the filesystem root, but I don't have to do that for my other configurations.

    I haven't used J2ME Polish, so I can't help with that issue....
  • 2. Re: MEP client application does not work on Nokia simulator
    807581 Newbie
    Currently Being Moderated
    hey.. thanks a lot...
    it worked