9 Replies Latest reply: Sep 8, 2008 8:00 AM by 807581 RSS

    UDS on Vista

    807581
      Anyone working with UDS on Vista? Tried installing development on vista and get a TCP/IP error (Windows NT TCP/IP needs to be installed) though system does have tcp installed..any feedback greatly appreciated..thanks
        • 1. Re: UDS on Vista
          807581
          What version are you trying to install ?

          If it's a pre 3.0.N.0 / 3.5 Install Shield is looking for a registry key that is not present on post NT 4.0 win versions.

          from regedit :
          go to the folder:
          HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tcpip\CurrentVersion\

          add a string for which:
          Value name = Title
          and
          Value Data = TCP/IP

          If you can't edit the registry you'd have to unpack the IShield bundle using a utility called ICOMP.EXE can't remember where to get it from though ... but I've got a copy handy.

          Cheers,
          B.
          • 2. Re: UDS on Vista
            807581
            UDS DEV 5.2 - am able to install it fine in Win2k though without any problems .. error occurs with Vista..thanks
            • 3. Re: UDS on Vista
              807581
              Oh VISTA that made the TCP/IP stack so much better.

              Is this a "fresh" Vista install?

              If not try to reset the TCP stack with

              netsh int ip reset aVoidTCPlog.txt

              from the command line, make sure you run this in the Administrator's context

              or try to figure out what registry key IShield cannot find and add it yourself.

              Since Fort� is highly dependent on TCP/IP I would copy a clean XP install of Fort� on the Vista machine to make sure it's just a IShield issue.
              • 4. Re: UDS on Vista
                807581
                yes, it is a fresh Vista install. The exact message I get is "This Windows NT system does not have TCP/IP installed. Please install the TCP/IP package before installing"..

                How do I figure out what registry key IShield cannot find?

                All I have access to is a set of UDS Dev installation files with a SetUp.exe which is what I run to install the development version...how do I come up with a clean install of Forte from this? ... any help appreciated. Thanks.
                • 5. Re: UDS on Vista
                  807581
                  OOkey dookey,

                  Since I don't have a Vista of my own and don't plan to ... but I don't have the win IS install version of UDS 5.2 would it be possible for you to e-mail me the SETUP.INS file that comes with your Setup.exe.

                  The IShield answer is in there but I'm not too sure where ... it'd be easier for me to have a look.

                  Cheers,
                  B.
                  • 6. Re: UDS on Vista
                    807581
                    I am attaching the Setup.ins file.. hope you can help me with this..
                    >
                    -------------------------------------------------------------------------------------------
                    I would guess the key it is looking for is

                    type: REG_SZ
                    name: DisplayName
                    value: TCP/IP Protocol Driver

                    in the following registry location:
                    MyComputer/HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Tcpip

                    check in the registry and add accordingly (I don't think the datavalue matters) ... let me know if it works or not.

                    This should allow for the IShield to run thru.

                    Cheers,

                    B

                    --------------------------------------------------------------------------
                    Hi Fortever,

                    This worked and I was able to install without any issues..the key did exist but had a different datavalue and once I changed it, it worked...appreciate all your help with this! Thanks again
                    • 7. Re: UDS on Vista
                      807581
                      Thanks for letting me know it worked,

                      I don't know why Fort� is still checking for that Reg key, it was used on win95 when WINSOCK was not part of the OS and you had a choice between PC-NFS, DECnet(not on Win) or Winsock as Fort� transport protocols.

                      You may want to reset the data value to what it was ... you never know :o(

                      Cheers.
                      B.
                      • 8. Re: UDS on Vista
                        807581
                        I'm having the same problem. What entries need to be changed in the registry?
                        • 9. Re: UDS on Vista
                          807581
                          Hello,

                          Grab uds 5.2.31 which is vista compatible (and also last version)

                          cordialement