1 Reply Latest reply on Nov 5, 2002 8:35 PM by 807581

    Null pointer exception when running servlet in S1AS7

    807581
      I have deployed a WAR file on S1AS7 using Apache SOAP 2.3.1 and Xerces 1.4.4. When the client sends a SOAP request to the server, S1AS7 returns a 500 Internal Error with the following trace:

      java.lang.NullPointerException
           at org.apache.catalina.session.StandardSession.setId(StandardSession.java:363)
           at org.apache.catalina.session.ManagerBase.createSession(ManagerBase.java:563)
           at org.apache.catalina.session.StandardManager.createSession(StandardManager.java:335)
           at org.apache.catalina.connector.HttpRequestBase.doGetSession(HttpRequestBase.java:1239)
           at org.apache.catalina.connector.HttpRequestBase.access$000(HttpRequestBase.java:112)
           at org.apache.catalina.connector.HttpRequestBase$PrivilegedGetSession.run(HttpRequestBase.java:127)
           at java.security.AccessController.doPrivileged(Native Method)
           at org.apache.catalina.connector.HttpRequestBase.getSession(HttpRequestBase.java:1193)
           at org.apache.catalina.connector.HttpRequestFacade.getSession(HttpRequestFacade.java:214)
           at org.apache.catalina.connector.HttpRequestFacade.getSession(HttpRequestFacade.java:224)
           at COM.inovie.services.integration.applicationRegistry.server.ApplicationRegistryServlet.doPost(Unknown Source)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
           at org.apache.catalina.core.StandardWrapperValve.invokeServletService(StandardWrapperValve.java:720)
           at org.apache.catalina.core.StandardWrapperValve.access$000(StandardWrapperValve.java:118)
           at org.apache.catalina.core.StandardWrapperValve$1.run(StandardWrapperValve.java:278)
           at java.security.AccessController.doPrivileged(Native Method)
           at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:274)
           at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:505)
           at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:212)
           at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:505)
           at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:203)
           at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:505)
           at com.iplanet.ias.web.connector.nsapi.NSAPIProcessor.process(NSAPIProcessor.java:157)
           at com.iplanet.ias.web.WebContainer.service(WebContainer.java:598)

      This same servlet runs fine on S1WS6. Is this a problem with my servlet or with S1AS7? Has anyone experienced a similar problem?

      Thanks for your help.
      --
      David