1 2 Previous Next 18 Replies Latest reply on Jul 26, 2005 12:55 PM by 448218

    OraOLEDB error '80004005'  ??

    403183
      I am trying to access a table in an Oracle 9i db with ASP. I've included my code below.
      --
      Dim objCon
      Set objCon = Server.CreateObject ("ADODB.Connection")
      objCon.ConnectionString = "Provider=OraOLEDB.Oracle;User ID=test_acct;Password=acct_test;Data Source=TestDB;"
      objCon.Open
      objCon.Close
      Set objCon = Nothing
      --

      My error is:
      --
      OraOLEDB error '80004005'
      ??
      oraoledb_oracle.asp, line 13
      --
      Line 13 points to the following code: objCon.Open

      Any ideas?
      Thanks,

      Wills
        • 1. Re: OraOLEDB error '80004005'  ??
          15208
          '-2147467259 (80004005)' UNSPECIFIED ERROR
          It seems to be a common connection problem from ASP. Have you followed Justin Cave's pointer?
          "It's generally sufficient to grant the IIS user read & execute permissions on %ORACLE_HOME%\bin."

          You may search ASP keyword in this forum and find more details.
          • 2. Re: OraOLEDB error '80004005'  ??
            403183
            I've set the proper permissions for the Internet Guest Account to Read and Execute.

            I'll have to search for Justin Cave's pointer.

            Thanks
            • 3. Re: OraOLEDB error '80004005'  ??
              403183
              I've opened up permissions at the root level of the D:\Oracle\ora92 home and now get the following error:

              OraOLEDB error '80004005'
              ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor

              Any ideas?
              • 4. Re: OraOLEDB error '80004005'  ??
                15208
                In your Connection string, your Data Source is TestDB. TestDB must be a valid "alias" in your tnsnames.ora file and this alias can connect successfully.
                • 5. Re: OraOLEDB error '80004005'  ??
                  15208
                  Does your D:\Oracle\ora92\network\admin\tnsnames.ora have TestDB alias? You may follow the sample to crate one and test the connection with SQL*Plus.
                  • 6. Re: OraOLEDB error '80004005'  ??
                    295578
                    Hello,

                    I have had a similar problem to this but with Microsoft ODBC. I found a forum which helped me. The regedit entries were incorrect. So please look at

                    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\MTxOCI]
                    "OracleXaLib"="oraclient8.dll"
                    "OracleSqlLib"="orasql8.dll"
                    "OracleOciLib"="oci.dll"

                    My entries were still pointing at 7.3 despite installing the latest Microsoft DC! Use the link below but it does not provide information for Oracle 9, but all you have to do is change the 8 above to 9.

                    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/oledb/htm/oledboraprovider_7.asp


                    Good luck
                    Tanuja

                    • 7. Re: OraOLEDB error '80004005'  ??
                      295578
                      Hi,

                      It's me again - I forgot to say you have to reboot the PC to get it to work.

                      Tanuja
                      • 8. Re: OraOLEDB error '80004005'  ??
                        403183
                        Thanks to all. I've done everything as suggested and still no luck. I'm waiting on the dba to get back to me concerning the tnsnames.ora file. The tnsnames.ora file on the development web server has the proper entry. Just don't know if it is on the development db server. Does the db server need the entry as well?
                        Me new error:
                        --
                        OraOLEDB error '80004005'
                        ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor
                        --
                        Thanks,

                        Wills
                        • 9. Re: OraOLEDB error '80004005'  ??
                          404080
                          Changing the registry settings for 9i client did not help me either. I still have the same error.
                          • 10. Re: OraOLEDB error '80004005'  ??
                            15208
                            Besides '80004005', do you get ORA-12514 error? Have you granted appropriate privileges/permission for IIS user? Please provide more details.
                            • 11. Re: OraOLEDB error '80004005'  ??
                              15208
                              Are you using Oracle Provider for OLE DB (OraOLEDB)?
                              The above "changing registry" solution is for Microsoft OLE DB Provider for Oracle and not for OraOLEDB.
                              • 12. Re: OraOLEDB error '80004005'  ??
                                404080
                                My DBA found the solution to the Microsoft OLE DB Provider for Oracle (0x80004005)error on http://metalink.oracle.com. Please note I'm running IIS6 on Win 2003 server using 9i client and 8i engine. I had the following error, and the following solution worked like magic. I hope this helps you, too.

                                Error:      
                                Microsoft OLE DB Provider for Oracle (0x80004005)
                                Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client softaware installation. Provider is unable to function until these components are installed.

                                Solution Description:
                                Oracle 9.2 Client software requires that you give the Authenticated User privilege to the Oracle Home by following these steps:
                                1. Log on to Windows as a user with Administration privileges.
                                2. Launch Windows Explorer from the Start Menu and navigate to the ORACLE_HOME folder. This is typically the "Ora92" folder under the "Oracle" folder (i.e. D:\Oracle\Ora92).
                                3. Right-click on the ORACLE_HOME folder and choose the "Properties" option from the drop down list. A "Properties" window should appear.
                                4. Click on the "Security" tab of the "Properties" window.
                                5. Click on the "Authenticated Users" item in the "Name" or "Group or user names" list.
                                6. Uncheck the "Read and Execute" box in the "Permissions" or "Permissions for Authenticated Users" list under the "Allow" column.
                                7. Re-check the "Read and Execute" box under the "Allow" column (this is the box you just unchecked).
                                8. Click the "Advanced" button and in the "Permission Entries" list make sure you see the "Authenticated Users" listed there with:
                                Permission = Read & Execute
                                Apply To = This folder, subfolders and files

                                If this is NOT the case, edit that line and make sure the "Apply onto" drop-down box is set to "This folder, subfolders and files". This should already be set properly but it is important that you verify this.
                                9. I checked the "Replace permission entries on all child objects with entries shown here that apply to child objects" checkbox and clicked the "Apply" button. (This was not specified in the original instructions, but it worked.)
                                10. Click the "Ok" button until you close out all of the security property windows. The cursor may present the hourglass for a few seconds as it applies the permissions you just changed to all subfolders and files.
                                11. Reboot your computer to assure that these changes have taken effect.
                                12. Re-execute the application and it should now work.
                                • 13. Re: OraOLEDB error '80004005'  ??
                                  171735
                                  Hi guys,

                                  Just give you mi thanks.
                                  we've been hours looking for this solution and finally found it.

                                  Just in case: We have Oracle 9.0.2 on W2K and IIS 5.0 and ORAOLEDB.ORACLE type connection.
                                  We gave permission on IUSR_Account and it's working now

                                  Thanks again
                                  • 14. Re: OraOLEDB error '80004005'  ??
                                    277328
                                    Your advice was realy great!
                                    Thanks,
                                    Lazar
                                    1 2 Previous Next