This discussion is archived
1 Reply Latest reply: Jul 10, 2006 7:48 AM by 807581 RSS

Neebie need help with configuration on Sunone 6.0 sp8 on Rehat Linux 2.4

807581 Newbie
Currently Being Moderated
I am new to setting up Sunone on Linux (unix in general. When the I start Sunone, I can see multiple sessions of ns-httpd -d /usr/sunone/sp8/http running when I do a ps -ef | grep http. When I start and stop the server and I can see the old sessions did not terminate, they just stayed on the system. I did not see the same thing on Sun Solaris box. Is that a configuration issue?

I kept see the following error message in the error log
[06/Nov/2005:11:20:59] warning ( 1235): The server configuration may require more file descriptors than the operating system provides. If you encounter PR_PROC_DESC_TABLE_FULL_ERROR errors, you may wish to increase the operating system hard file descriptor limit from 1024 to 12038 (see your operating system documentation) or decrease one or more of the following settings: MaxFiles in nsfc.conf and ConnQueueSize, RqThrottle, and MaxKeepAliveConnections in magnus.conf.

I have set the limits.conf to
* soft nofile 12287
* hard nofile 12288

and also file-max to 24576

The server is running as root and the user is nobody.

Also, does the webserver need to be run in ksh shell? Currently, our unix admin has set the default shell to bash.

The last unix admin set the root default shell on the Solaris box as ksh shell.