4 Replies Latest reply: Jul 11, 2005 9:58 AM by 807581 RSS

    App server verison 6.5

    807581
      I have a machine running Windows 2000 5.00 2195 SP4. With app server version 6.0 installed on the machine, I can access all files under the app server hierarchy. Since I upgraded to app server version 6.5, I can only access servlets under the app server hierarchy. I get a GX error, GX Error (GX2GX) socket result code missing!!!, accessing all other content (images, HTML, JavaScript, CSS and JSP files).

      It is very easy to duplicate this issue. Under app server 6.0, if I access /NASApp/fortune/fortune.jsp, the JSP runs and displays "Your fortune is... null" because I did not run the fortune servlet. Under app server 6.5 I get the GX error. Also tested with an HTML page, /NASApp/fortune/hello.htm, that displays hello. Under app server 6.0 the page displays. Under app server 6.5, I get the GX error.
      All the other PC's in my development group are running app server 6.5 on Windows 2000 5.00 2195 SP4. They do not have this issue. Only my PC appears to be affected.

      The project I am working on stores all files on the app server. It was recent upgraded to app server 6.5 and will not run on app server 6.0. Because of the GX error, I cannot run the app at all.

      Any ideas?
        • 1. Re: App server verison 6.5 - GX ERROR
          807581
          FYI, This error only happens on my PC running windows 2000. It does not occur on the QA box, also running windows 2000. It does not occur with our production environment (app server 6.5 running on Solaris)
          • 2. Re: App server verison 6.5 - GX ERROR
            807581
            Hi !!! Not sure if your problem got resolved or not...But please ensure if these thses steps were folllowed before trying to access the fortune application. Also after following the steps please ensure that the request is sent from yuor browser as http://<server-machine>:<server-port>/NASApp/fortune/fortune .....

            Hope it helps.

            1. Go to the machine which runs the web server.
            2. Go to webconnector install directory>/ias/bin
            3. Take a backup of the the registry.
            4. Make sure that the ldap is running
            5. Open the registry by doing ./kregedit
            6. Navigate to the following key
            SOFTWARE\iPlanet\Application Server\6.5\CCS0\HTTPAPI\KeepAliveTimeOut=3600
            7. Note if that value is specified in seconds. This can be changed if you want to. The basic rule is to keep this timeout value lesser than the value you set for your firewall timeout.
            8. Restart the web server for the changes to take effect.

            Also, following is the setup which was asked to follow for setting up the iAS web-connector to run with IIS.Please verify the settings and ensure the same.


            1. Registering the Plug-in on IIS running on Windows.

            To register the Plug-in on IIS

            Go to Start >Settings> Control Panel > Administrative Tools > Computer Management

            The Computer Management window will open.

            - In the left pane, click on the + sign to expand Services and Applications > Internet Information Services > Default Web Site.
            - Right-click Cgi-bin and select Properties
            - Select the Virtual Directory tab
            - Under Applications Settings, click Create.
            - Select the pull-down menu next to Application Protection.
            - Select Low(IIS Process)
            - Click OK.

            2.
            - Rename the gxisapi.dll library to gx.dll and leave it in the cgi-bin directory of the IIS wwwroot (inetput/wwwroot/cgi-bin/).
            - Configure the ISAPI filter file, gx.dll, in the following Windows registry entry ( regedit ):
            My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\Parameters\

            A string key, Filter DLLs, should be added under Parameters, with the following value:
            <drive letter>:\inetpub\wwwroot\cgi-bin\gx.dll

            3. Grant permission on the Windows registry, following are the instructions that you need to follow to grant the permission
            - Open windows registry with command "regedt32".This is the m/c where iAS webconnector is installed.
            - Select key \\local machine\\software\\iplanet\\Appserver\\6.0\\CCS0\\HTTPAPI.
            - From menu open security---permission.
            - In the dialog box check whether any user called "Everyone" is there or not. If it is not there. ADD a user called "Everyone"
            - By default the access permission for "everyone" is special access. Change it to "full control". Be sure that the change of permission applies to sub keys also.
            - Restart the webserver(IIS) to get the effect.

            4. When you try to open http://<domain-name>:<port>/GXApp , it will throw 403 Forbidden error . To get rid of it

            Traverse to control panel ->Administrative tools ->computer management ->IIS->DefaultWebSite->right click on iAS-Samples ->
            properties->Documents->ADD index.html

            Do the same for GXApp under Default web site .

            After doing the above restart the machine and restart the iPlanet services .
            • 3. Re: App server verison 6.5 - GX ERROR
              807581
              This is still an issue. I am running Iplanet web server 6.0 and app server 6.5 on windows 2000.
              1) I can run servlets such as /NASApp/fortune/fortune. The servlet successfuly forards to the JSP page
              2) I cannot run JSP pages directly such as /NASApp/fortune/fortune.jsp. Then I get the GX error.

              Looking around the registry I noticed that the System application is not configured. The files exist in the IAS_HOME/ias/APPS/System, but the install did not load these into the registry. I have uninstalled and reinstalled the app server several times and this information is not loaded.

              The System files should be listed under, HTTPAPI/ServletPatternTrans, J2EEModule,
              ClassDef, ClassImpl and NameTrans, but they are not.

              Why was System not loaded upon instalation? I did a typical install with all the suggested values. I already had an instance of the web server on the box, I just upgraded the app server by uninstalling the 6.0 version and installing the 6.5 version.

              Is there any way to load this short of manually configuring all the entries in the registry?

              Thanks for your help,

              David
              • 4. Re: App server verison 6.5
                807581
                This was not a showstopper until recently. I installed the 6.0 version of the web server on my PC and was able to compile, install and run the application. Now that have changed the applciation to take advantage of features only available in Java3 and app server 6.5, it no longer will run on version 6.0.

                The web server is Iplanet6.

                Any ideas?

                Thanks,