7 Replies Latest reply on Nov 2, 2010 10:13 PM by jschellSomeoneStoleMyAlias

    Socket timeout or connection timeout exceptions


      We have a deployment of application on Jboss 4.20/Solaris 10 on one Network and the Database-Oracle 10 is on a Different network.

      Both the networks have good bandwidth and no wirewall or communication issues in between.

      Did a trace route from App server to DB server and there are 4 hops in between.

      Our application is memory intensive and tries to load all the rules etc., in to memory during the application start up.

      Everything is getting loaded in to memory except a set of data because it tries to load close to million records from DB in to memory in one shot so I suspect either the Network ha some latency or DB connection is getting timedout.

      I am getting the below exception/error messages:

      13:34:46,470 WARN [TxConnectionManager] Connection error occured: org.jboss.resource.connectionmanager.TxConnectionManager$TxConnectionEventListener@7aec07[state=NORMAL mc=org.jboss.resource.adapter.jdbc.xa.XAManagedConnection@116e9d8 handles=1 lastUse=1288286986564 permit=true trackByTx=false mcp=org.jboss.resource.connectionmanager.JBossManagedConnectionPool$OnePool@152833d context=org.jboss.resource.connectionmanager.InternalManagedConnectionPool@263003 xaResource=org.jboss.resource.connectionmanager.xa.JcaXAResourceWrapper@75479a txSync=null]
      java.sql.SQLException: Io exception: Socket read timed out
      at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
      at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:146)

      Is there a specific property either on the Oracle/network/jboss side to specify the connection time out or rows fetch count.

      I tried increasing the sockettimeout on the Jboss side but it did not work out.

      Tried increasing querytimeout, txquerytimeout in Oracle-xa-ds.xml but of no luck..Tried increasing the connection poolsize, Heap memory, Permsize but those did not help.

      Tried doing a fresh install as well but the same error is occuring..This can be because of 2 different networks as well...

      If there is a paramter to specify the Oracle connection timeout in the oracle-xa-ds.xml that would be helpful I think..