1 Reply Latest reply: May 3, 2010 8:59 AM by 807576 RSS

    Open SPARC T1 regression results (need help)

    807576
      Hi All,

      I made a full regression run using VCS 2009.6 on the original RTL without modification for one core only, here is a copy of the results:

      ================================================================================
      Status:core1_full | ALL |
      --------------------------------------------------------------------------------
      PASS: 791 | 791 |
      FAIL: 1 | 1 |
      Diag Problem: 0 | 0 |
      License Problem: 0 | 0 |
      MaxCycles Hit: 0 | 0 |
      Socket Problem: 0 | 0 |
      Timeout: 0 | 0 |
      LessThreads: 0 | 0 |
      Simics Problem: 0 | 0 |
      Performance: 3 | 3 |
      Killed By Job Q: 0 | 0 |
      Unknown: 4 | 4 |
      UnFinished: 0 | 0 |
      flexlm error: 0 | 0 |
      --------------------------------------------------------------------------------
      Diag Count: 799 | 799 |
      --------------------------------------------------------------------------------
      Cycles/Sec: 2423 | 2423 |
      K Cycles: 44201 | 44201 |
      #Diags Used: 792 | 792 |
      ================================================================================
      ================================================================================


      Details for core1_full
      ================================================================================
      FAIL:
      ===================
      Diag: mfarag:tlu_stb2b_trap_60:model_core1:core1_full:0:11091 FAIL (HIT BAD TRAP)
      Sat Jan 23 22:28:19 EET 2010
      sim.log: 12049247 : Simulation -> FAIL(HIT BAD TRAP)
      Cyc= 14474, Sec= 4.210, C/S=3438.0
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      ================================================================================
      ================================================================================
      Performance:
      ===================
      Diag: mfarag:chase_dram:model_core1:core1_full:0:14142 Performance
      Sat Jan 23 22:17:31 EET 2010
      sim.log: 15526747: Simulation -> PASS (HIT GOOD TRAP)
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Got '0', Expected '2' (tolerance=0)
      AnalyzeDiag: Performance Test: FAIL: DRAM_ld
      AnalyzeDiag: Got '', Expected '133' (tolerance=3)
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Performance Test: FAIL: DRAM_ld
      sims: Warning diag.pl run exited with error
      ================================================================================
      ================================================================================
      Diag: mfarag:chase_l1hit:model_core1:core1_full:0:22413 Performance
      Sat Jan 23 17:51:54 EET 2010
      sim.log: 13280911: Simulation -> PASS (HIT GOOD TRAP)
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Got '0', Expected '2' (tolerance=0)
      AnalyzeDiag: Performance Test: FAIL: L1_ld_hit
      AnalyzeDiag: Got '', Expected '3' (tolerance=0)
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      sims: midas -mmu=niagara -pal_diag_args=-lenbytes=512 -pal_diag_args=-stride=16 -pal_diag_args=-nodisablel1_warmup -pal_diag_args=-expect_time=3 -pal_diag_args=-expect_string=L1_ld_hit -diag_root=/home/mfarag/Desktop/Scratch/work/OpenSPARC_T1 diag.pal
      midas: midas -mmu=niagara -pal_diag_args=-lenbytes=512 -pal_diag_args=-stride=16 -pal_diag_args=-nodisablel1_warmup -pal_diag_args=-expect_time=3 -pal_diag_args=-expect_string=L1_ld_hit -diag_root=/home/mfarag/Desktop/Scratch/work/OpenSPARC_T1 diag.pal
      midas: pal diag.pal -lenbytes=512 -stride=16 -nodisablel1_warmup -expect_time=3 -expect_string=L1_ld_hit > build/diag.src
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Performance Test: FAIL: L1_ld_hit
      sims: Warning diag.pl run exited with error
      ================================================================================
      ================================================================================
      Diag: mfarag:chase_l2hit:model_core1:core1_full:0:13687 Performance
      Sat Jan 23 22:17:21 EET 2010
      sim.log: 21039247: Simulation -> PASS (HIT GOOD TRAP)
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Got '0', Expected '2' (tolerance=0)
      AnalyzeDiag: Performance Test: FAIL: L2_ld_hit
      AnalyzeDiag: Got '', Expected '22' (tolerance=0)
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      AnalyzeDiag: Performance Test: FAIL: Found 2 chases
      AnalyzeDiag: Performance Test: FAIL: L2_ld_hit
      sims: Warning diag.pl run exited with error
      ================================================================================
      ================================================================================
      Unknown:
      ===================
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      ================================================================================
      ================================================================================
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      ================================================================================
      ================================================================================
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      ================================================================================
      ================================================================================
      sims: group_name = core1_full
      sims: regress_date = 2010_01_23
      sims: regress_time = 17_42_24
      ================================================================================
      ================================================================================
      PASS:
      ..............

      As you can see there is one failing test, 3 performance and 4 unknowns. I do not know what is the reason for this results, I am assuming that all of the tests should pass out of the box. So any help on this matter is appreciated. The command I used to make this regression is:

      sims -sim_type=vcs -group=core1_full -novera_run -novera_build