7 Replies Latest reply on Oct 18, 2011 12:08 PM by 875117

    Has anyone got UCM 11g running on Windows 7 64bit?

    Stephan Koser
      Hi,

      I've just installed UCM 11g on a 64bit Windows 7. During installation I had some issues concerning the user rights, but now almost everything works fine.
      Except of two issues:
      1. when starting the UCM (startManagedWebLogic.cmd) I get the following exception:

      !csNativeOsUtilsError!syNativeOsUtilsNotLoaded!syJavaExceptionWrapper,java.lang.UnsatisfiedLinkError: intradoc.common.NativeOsUtilsBase.getNativeVersion()Ljava/lang/String;
      java.lang.AssertionError: !syNativeOsUtilsNotLoaded
           at intradoc.common.NativeOsUtilsBase.doLoad(NativeOsUtilsBase.java:386)
           at intradoc.common.NativeOsUtilsBase.<init>(NativeOsUtilsBase.java:352)
           at intradoc.common.NativeOsUtils.<init>(NativeOsUtils.java:26)

      But the server is running.

      2. Fulltext-Search doesn't work.

      Message in the UI:

      !csUserEventMessage,weblogic,localhost:16200!$!csSearchUnableToReturnResults
      intradoc.common.ServiceException: !csSearchUnableToReturnResults
      at intradoc.server.SearchManager.retrieveSearchInfo(SearchManager.java:269)
      at intradoc.server.SearchService.retrieveSearchInfo(SearchService.java:1811)
      at intradoc.server.SearchService.doLocalSearch(SearchService.java:1360)
      at intradoc.server.SearchService.getSearchResults(SearchService.java:654)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)

      As UCM is not certified for Windows 7 I'm not sure if this is a configuration issue or a generel problem with Windows 7.

      Has anyone got this installation run on Windows 7 (64bit)?

      --
      bye Stephan...
        • 1. Re: Has anyone got UCM 11g running on Windows 7 64bit?
          Jonathan Hult
          I have successfully run the 32bit version on Windows 7. I have not tried x64.

          It seemed to sometimes require right clicking and selecting Run as administrator for certain actions such as starting UCM/WebLogic.
          • 2. Re: Has anyone got UCM 11g running on Windows 7 64bit?
            Stephan Koser
            It seems it is currently not running correct with Windows 7, 64 Bit.
            I installed it on Windows 2003 Server (32 Bit) with the same configuration:
            - No error message about NativeOSUtils
            - FullTextSearch is working.

            bye Stephan...
            • 3. Re: Has anyone got UCM 11g running on Windows 7 64bit?
              Frank Abela -Oracle
              Stephan

              UCM is not certified to run on Windows 7, 32 or 64 bit. Windows 7 is an end-user platform. You need Windows Server 2003 SP2/R2+ or Windows Server 2008 SP1+ or R2. You can find this on the certification matrix here:

              http://www.oracle.com/technetwork/middleware/content-management/documentation/technicalinformation-097240.html

              It's worth checking the matrix because you will see that the various platforms are certified with different JDK vendors too, so you need to ensure you're running the correct JDK for your platform.

              Frank.

              Edited by: Frank Abela on Nov 8, 2010 11:07 AM
              • 4. Re: Has anyone got UCM 11g running on Windows 7 64bit?
                821021
                I have verified that the problem goes away when you "run as administrator" on windows 7.
                • 5. Re: Has anyone got UCM 11g running on Windows 7 64bit?
                  839409
                  Hi,

                  I have successfully installed UCM 11g on Win 7 64-bit.
                  You need to enable IIS on your machine since UCM runs scripts in the backend.

                  The link below will tell you how to enable IIS.

                  http://underthehood.ironworks.com/2010/01/installing-oracles-ucm-on-windows-7.html

                  After u enable the IIS, u can start installing your database, rcu,weblogic,ecm and configuring your domain.


                  Regards,
                  Richa
                  • 6. Re: Has anyone got UCM 11g running on Windows 7 64bit?
                    894836
                    I tried installing UCM 11g on Windows 7 X64 but after installing Database, RCU and Weblogic , when i try installing UCM I run into the some issue, Below are the steps I followed.
                    1) Change the properties of the installer to run in "windows 2003" compatible mode.
                    2) Run as Administrator.
                    3) Window pops up asking the path for the JRE/JDK. I enter the path for the JDK.
                    The command prompt exits and nothing happens after that.. there is no error message or any sort of indication. The application just exits.
                    4) As the user above suggested of enabling IIS, I tried all the steps and enabled IIS.
                    5) I restarted the process of "Run as administrator) for the UCM 11g installer. Same error where the prompt exits after providing the path for JDK.

                    Any help would be appreciated.

                    Thanks,
                    Raj
                    • 7. Re: Has anyone got UCM 11g running on Windows 7 64bit?
                      875117
                      Assuming that you want to install the 64 bit UCM 11g version:

                      Issue with installer closing screen could be related with JAVA_HOME variable or wrong java version.
                      1. Check if 64 bit JDK (not JRE) is installed in a directory without spaces (not default Program Files… but something like C:\Java\).
                      2. Check if windows environment variable JAVA_HOME exists and is pointing to JDK directory (like C:\Java\jdk1.6.0_24)
                      3. Open command prompt and check java version with: java –version. It should return “Java HotSpot 64-Bit Server”.

                      A little bit more deatils here: Re: Installation issues with WebCenter UCM 11g

                      Regards,
                      Boris