1 Reply Latest reply: Dec 9, 2010 7:38 AM by mjohnson RSS

    build example project

    810683
      I was trying to build the example project using the latest Coherence release and the 3.6 supported incubator example project. When I ran ant build, I got this error:

      [javac] Compiling 44 source files to C:\oracle\coherence\coherence-incubator-examples-1.2.2.1903
      4\build\classes
      [javac] C:\oracle\coherence\coherence-incubator-examples-1.2.2.19034\src\com\oracle\coherence\ex
      amples\incubator\commandpattern\CommandPatternExample.java:29: cannot access com.oracle.coherence.co
      mmon.identifiers.Identifier
      [javac] bad class file: C:\oracle\coherence\coherence-incubator-examples-1.2.2.19034\lib\coheren
      ce-common-1.7.2.19034.jar(com/oracle/coherence/common/identifiers/Identifier.class)
      [javac] class file has wrong version 50.0, should be 49.0
      [javac] Please remove or make sure it appears in the correct subdirectory of the classpath.
      [javac] import com.oracle.coherence.common.identifiers.Identifier;
      [javac] ^
      [javac] 1 error

      BUILD FAILED

      It seems like the example was looking for a different build number?

      Any suggestion is appreciated. My JDK version is build 1.5.0_08-b03