This discussion is archived
0 Replies Latest reply: Nov 22, 2010 8:18 AM by 817479 RSS

Development using LWUIT 1.4

817479 Newbie
Currently Being Moderated
Hi All,

We are about to start developing a Java ME app. Currently I am doing technical design and looking to use LWUIT 1.4 and some of the Swing like components provided in LWUIT. I have found in the documentation that LWUIT 1.4 requires JDK 1.6 or higher for development and works with MIDP 2.0 and CLDC 1.1.

I have some basic questions here:

1. To run the app developed with LWUIT 1.4, is it enough to ensure that the device supports MIDP 2.0/CLDC 1.1. Or is there any requirement w.r.t Java virtual machine version on the device?

2. Is it safe to assume that majority of the phone devices released in the last 4 years support MIDP 2.0/CLDC 1.1?

Thanks for your help.

Regards.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points