1 2 Previous Next 22 Replies Latest reply on Nov 23, 2010 4:21 PM by 471379 Go to original post
      • 15. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
        sb92075
        REBOOT then make thread as answered!

        bug is fixed in V10.2.0.4 & there is a one off back port patch that was available
        • 16. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
          471379
          Yes, I know listener not required for local connections, but since I can't get into SQLPLUS I was testing the only thing that I could get into to see if that helped with the diagnosis.

          I've poseted uptime above - when I started 199 days, now 200 days.

          Do you have a bug id and is there an OS or an Oracle patch?

          thanks muchly :-)
          • 17. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
            sb92075
            Do you have a bug id
            No not on hand & your can SEARCH as well as I
            and is there an OS or an Oracle patch?
            yes

            strace sqlplus

            You can search MOS for the system call being made in TIGHT loop

            http://forums.oracle.com/forums/ann.jspa?annID=718
            - It is considered good etiquette to reward answerers with points (as "helpful" - 5 pts - or "correct" - 10pts).
            • 18. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
              471379
              I've given u a "helpful" already!

              I'm just trying to find the exact bug number (yes I know how to search!), post this, before I close this and give a "correct".

              As it happens Oracle search is to s*** I'm not finding anything. Maybe because they have classified this bug as non-public as typically they do!

              :-(

              Edited by: sunpat on Nov 23, 2010 3:46 PM
              • 19. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
                sb92075
                http://www.lmgtfy.com/?q=oracle+linux+uptime+bug
                • 20. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
                  471379
                  I found this in Metalink
                  https://support.oracle.com

                  Patch : Bug 4612267 - OCI client spins when machine uptime >= 249 days

                  Although I never made it to 200 days so maybe a different bug


                  Oh bug 5867987 looks better
                  https://support.oracle.com/CSP/ui/flash.html#tab=KBHome%28page=KBHome&id=%28%29%29,%28page=KBNavigator&id=%28from=BOOKMARK&bmDocType=BUG&viewingMode=1143&bmDocID=5867987&bmDocDsrc=BUG&bmDocTitle=SQLPLUS%20HANGS%20-%20LIKE%20IN%20UPTIME%20BUG%204930777%29%29

                  SQLPLUS hangs, no sqlplus connections could be made to the instance locally
                  or remotely. This is NOT a RAC instance.

                  The current uptime is 202 days

                  Further ref:
                  Re: SQL*Plus 10.2.0.1.0 does not work on RHEL3


                  thanks muchly

                  Edited by: sunpat on Nov 23, 2010 4:03 PM
                  • 21. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
                    sb92075
                    Patch : Bug 4612267 - OCI client spins when machine uptime >= 249 days
                    same bug

                    I had systems as early as 186 days & as late as 263 days
                    • 22. Re: Can't connect to Oracle with sqlplus /nolog as sysdba
                      471379
                      SQL*Plus 10.2.0.1 Hangs, When System Uptime Is Long Period of Time [ID 338461.1]
                           Modified 08-JUL-2010 Type PROBLEM Status PUBLISHED      

                      In this Document
                      Symptoms
                      Changes
                      Cause
                      Solution
                      References

                      Applies to:
                      SQL*Plus - Version: 10.2.0.1 and later [Release: Oracle10g and later ]
                      Generic UNIX
                      Linux x86
                      HP-UX PA-RISC (64-bit)
                      IBM AIX on POWER Systems (64-bit)
                      Linux x86-64
                      Checked for relevance on 18-Apr-2010
                      Symptoms

                      Trying to invoke SQL*Plus hangs when machine uptime has been for a long period of time. There have been cases where problem occurs when uptime reaches 60 days and others as long as 248 days.

                      Database connection is not relevant as the 'sqlplus' executable itself hangs with or without connection information. It hangs regardless of what parameters are passed in. For example:

                      sqlplus -V

                      However, the hang does not reproduce with Instant Client version 10.1.0.4

                      Generating a stack trace using gdb debugger shows:

                      #0 0x0048a0dd in times () from /lib/tls/libc.so.6
                      #1 0x01884599 in sltrgatime64 () from ./libclntsh.so.10.1
                      #2 0x0137d70f in kghinp () from ./libclntsh.so.10.1
                      #3 0x00f86b47 in kpuinit0 () from ./libclntsh.so.10.1
                      #4 0x00f85e7a in kpuenvcr () from ./libclntsh.so.10.1
                      #5 0x01051b5e in OCIEnvCreate () from ./libclntsh.so.10.1
                      #6 0x0099787e in afidrv () from ./libsqlplus.so
                      #7 0x009702b9 in safimTerminate () from ./libsqlplus.so
                      #8 0x0098c246 in afidrv () from ./libsqlplus.so
                      #9 0x080486f6 in main ()

                      Running STRACE tool shows:

                      $ strace /oracle/home/bin/sqlplus -V 2>&1 |less
                      ......
                      old_mmap(NULL, 385024, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x41794000
                      gettimeofday({1122996561, 411035}, NULL) = 0
                      access("/usr/local/UD/conf/sqlnet.ora", F_OK) = -1 ENOENT (No such file or directory)
                      access("/usr/local/UD/lib/oracle/network/admin/sqlnet.ora", F_OK) = -1 ENOENT (No such file or directory)
                      access("/usr/local/UD/conf/sqlnet.ora", F_OK) = -1 ENOENT (No such file or directory)
                      access("/usr/local/UD/lib/oracle/network/admin/sqlnet.ora", F_OK) = -1 ENOENT (No such file or directory)
                      fcntl64(-1218313656, F_SETFD, FD_CLOEXEC) = -1 EBADF (Bad file descriptor)
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405
                      times(NULL) = -1825782405

                      It is looping on the times() function.

                      In addition to sqlplus, it has been reported that the netca and dbca tools also hang.
                      Changes
                      This may happen with a new installation of Instant Client 10.2.0.1.0 or Oracle 10.2.0.1.0 on UNIX platform, or it can just occur after some period of time with no other changes.
                      Cause

                      This is a known, unpublished bug.

                      Bug 4612267 OCI CLIENT IS IN AN INFINITE LOOP WHEN MACHINE UPTIME HITS 248 DAYS
                      Solution

                      Select one of the following two solutions:

                      1) Apply one-off patch available for 10.2.0.1.
                      a. Download one-off patch off Metalink:
                      Patch 4612267
                      Description OCI CLIENT IS IN AN INFINITE LOOP WHEN MACHINE UPTIME HITS 248 DAYS
                      Product CORE
                      Release Oracle 10.2.0.1

                      b. To apply patch on Instant Client install, please follow instructions documented in the OCI manual.
                      You can find this in:
                      http://www.oracle.com/pls/db102/db102.show_toc?which=main&partno=b14250&maxlevel=2�ion=&expand=3216

                      under "Patching Instant Client Shared Libraries on Linux or UNIX".

                      2) Apply Patchset 10.2.0.2 or higher.
                      According to unpublished Bug 4612267, this bug is fixed in version 11, and backported to 10.2.0.2 patchset.


                      thanks all for help - will apply patch before I hit 199 days! :-)
                      1 2 Previous Next