2 Replies Latest reply: Nov 27, 2010 12:24 PM by Pedro Lourenço RSS

    "ORA-24344: success with compilation error" in beginDDL

    Pedro Lourenço
      Hello,

      I'm facing a really strange problem. When i try to use dbms_wm.beginDDL in one of my versioned tables, i get the error:

      ORA-24344: success with compilation error
      ORA-06512: "WMSYS.LT", line 12178
      ORA-06512: line 2

      I just get the error if i run the procedure from SQLPlus.
      Using PLSQL Developer, for example, I get a normal execution but the LTS table it's not created and the state of the table stays 'VERSIONED'.

      I used this procedure other times in the past and there were no problems.
      Trying to identify the cause of the error, i've tried:

      (1) - run dbms_wm.beginDDL for all the other tables - No Problem
      (2) - verifiy if there were invalid objects - All valid
      (3) - verify the error tables for more details (user_, dba_, user_wm_vt_) - No entries
      (4) - generate a trace file, to search for abnormal executions - Apparently nothing really strange (but obviously I don't know what was supposed to happen)

      Any possible reasons for this to happen?
      Any ideas?
      Some help would be welcome.

      Best regards,

      Pedro Lourenço