7 Replies Latest reply: Apr 27, 2011 9:39 AM by 666794 RSS

    Deploying J2E CA 1.0 Resource Adapter on 11g

    818493
      I am currently only supplying an ra.xml file since I have not been able to get the same RAR file that worked with WLS 8 to install correctly on 11g with my weblogic-ra.xml. I receive the following error even though I do not supply a weblogic-ra.xml file as the error message states. Are 1.0 resource adapters supported? I have included a copy of the ra.xml at the bottom of message.

      Any ideas?

      Eric


      <Nov 24, 2010 2:37:04 PM MST> <Error> <Deployer> <BEA-149265> <Failure occurred
      in the execution of deployment request with ID '1290634624475' for task '0'. Err
      or is: 'weblogic.application.ModuleException: A <jndi-name> is specified for the
      resource adapter bean in weblogic-ra.xml, however no <resourceadapter-class> el
      ement is specified in ra.xml'
      weblogic.application.ModuleException: A <jndi-name> is specified for the resourc
      e adapter bean in weblogic-ra.xml, however no <resourceadapter-class> element is
      specified in ra.xml
      at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.jav
      a:229)
      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(Modu
      leListenerInvoker.java:199)
      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(Depl
      oymentCallbackFlow.java:507)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineD
      river.java:41)
      at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(Dep
      loymentCallbackFlow.java:149)
      Truncated. see log file for complete stacktrace
      >
      <Nov 24, 2010 2:37:04 PM MST> <Warning> <Deployer> <BEA-149004> <Failures were d
      etected while initiating deploy task for application 'BullHooXG8Line'.>
      <Nov 24, 2010 2:37:04 PM MST> <Warning> <Deployer> <BEA-149078> <Stack trace for
      message 149004
      weblogic.application.ModuleException: A <jndi-name> is specified for the resourc
      e adapter bean in weblogic-ra.xml, however no <resourceadapter-class> element is
      specified in ra.xml
      at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.jav
      a:229)
      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(Modu
      leListenerInvoker.java:199)
      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(Depl
      oymentCallbackFlow.java:507)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineD
      river.java:41)
      at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(Dep
      loymentCallbackFlow.java:149)
      Truncated. see log file for complete stacktrace
      >
      <Nov 24, 2010 2:37:04 PM MST> <Error> <Console> <BEA-240003> <Console encountere
      d the following error weblogic.application.ModuleException: A <jndi-name> is spe
      cified for the resource adapter bean in weblogic-ra.xml, however no <resourceada
      pter-class> element is specified in ra.xml
      at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.jav
      a:229)
      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(Modu
      leListenerInvoker.java:199)
      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(Depl
      oymentCallbackFlow.java:507)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineD
      river.java:41)
      at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(Dep
      loymentCallbackFlow.java:149)
      at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(Dep
      loymentCallbackFlow.java:45)
      at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.ja
      va:1221)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineD
      river.java:41)
      at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.j
      ava:367)
      at weblogic.application.internal.SingleModuleDeployment.prepare(SingleMo
      duleDeployment.java:43)
      at weblogic.application.internal.DeploymentStateChecker.prepare(Deployme
      ntStateChecker.java:154)
      at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(App
      ContainerInvoker.java:60)
      at weblogic.deploy.internal.targetserver.operations.ActivateOperation.cr
      eateAndPrepareContainer(ActivateOperation.java:207)
      at weblogic.deploy.internal.targetserver.operations.ActivateOperation.do
      Prepare(ActivateOperation.java:98)
      at weblogic.deploy.internal.targetserver.operations.AbstractOperation.pr
      epare(AbstractOperation.java:217)
      at weblogic.deploy.internal.targetserver.DeploymentManager.handleDeploym
      entPrepare(DeploymentManager.java:747)
      at weblogic.deploy.internal.targetserver.DeploymentManager.prepareDeploy
      mentList(DeploymentManager.java:1216)
      at weblogic.deploy.internal.targetserver.DeploymentManager.handlePrepare
      (DeploymentManager.java:250)
      at weblogic.deploy.internal.targetserver.DeploymentServiceDispatcher.pre
      pare(DeploymentServiceDispatcher.java:159)
      at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallb
      ackDeliverer.doPrepareCallback(DeploymentReceiverCallbackDeliverer.java:171)
      at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallb
      ackDeliverer.access$000(DeploymentReceiverCallbackDeliverer.java:13)
      at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallb
      ackDeliverer$1.run(DeploymentReceiverCallbackDeliverer.java:46)
      at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTunin
      gWorkManagerImpl.java:528)
      at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
      at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
      >

      <?xml version="1.0" encoding="UTF-8"?>

      <!DOCTYPE connector PUBLIC '-//Sun Microsystems, Inc.//DTD Connector 1.0//EN' 'http://java.sun.com/dtd/connector_1_0.d
      td'>

      <connector>
      <display-name>HooXG8 Line NoTxn Adapter</display-name>
      <vendor-name>Bull</vendor-name>
      <spec-version>1.0</spec-version>
      <eis-type>GCOS</eis-type>
      <version>2.1</version>
      <resourceadapter>
      <managedconnectionfactory-class>com.bull.HooX.GcosManagedConnectionFactoryImpl</managedconnectionfactory-class
      >
      <connectionfactory-interface>javax.resource.cci.ConnectionFactory</connectionfactory-interface>
      <connectionfactory-impl-class>com.bull.HooX.GcosConnectionFactory</connectionfactory-impl-class>
      <connection-interface>javax.resource.cci.Connection</connection-interface>
      <connection-impl-class>com.bull.HooX.GcosConnectionImpl</connection-impl-class>
      <transaction-support>NoTransaction</transaction-support>
      <config-property>
      <description>IP name or address</description>
      <config-property-name>ipAddress</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value></config-property-value>
      </config-property>
      <config-property>
      <description>DSA node name</description>
      <config-property-name>dsaNode</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value></config-property-value>
      </config-property>
      <config-property>
      <description>Mailbox name</description>
      <config-property-name>mailbox</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value></config-property-value>
      </config-property>
      <config-property>
      <description>Protocol to use(EGATE, LINE, NONE)</description>
      <config-property-name>protocol</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>LINE</config-property-value>
      </config-property>
        • 1. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
          818493
          I also attempted to deploy the blackboxnotx.rar in J2EE 1.3 sdk and that fails the same way.

          Eric
          • 2. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
            wilson.t
            please provide a weblogic-ra.xml
            • 3. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
              666794
              There should be a weblogic-ra.xml file in your deployment plan somewhere. The structure of the deployment plan is as follows:

              somewhere/Plan.xml
              somewhere/plan/META-INF/weblogic-ra.xml

              The resource adapter does not support you specifying a <jndi-name> for the resource adapter. You can however specify <jndi-name> for the connection instances you create after deploying the adapter. If you have a <jndi-name> for the recource adapter, simply delete it from weblogic-ra.xml (also delete empty element such as <jndi-name></jndi-name> or <jndi-name /> ). Then update the adapter from the Deployments page in Admin console.

              Here is my weblogic-ra.xml file:

              <?xml version='1.0' encoding='UTF-8'?>
              <weblogic-connector xmlns="http://xmlns.oracle.com/weblogic/weblogic-connector" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.oracle.com/weblogic/weblogic-connector http://xmlns.oracle.com/weblogic/weblogic-connector/1.0/weblogic-connector.xsd">
              <native-libdir>C:\dev\wls_domains\domain1\lib</native-libdir>
              <enable-access-outside-app>false</enable-access-outside-app>
              <enable-global-access-to-classes>true</enable-global-access-to-classes>
              <security></security>
              <outbound-resource-adapter>
              <default-connection-properties>
              <pool-params></pool-params>
              <logging></logging>
              </default-connection-properties>
              <connection-definition-group>
              <connection-factory-interface>javax.resource.cci.ConnectionFactory</connection-factory-interface>
              <default-connection-properties>
              <pool-params></pool-params>
              <logging>
              <logging-enabled>false</logging-enabled>
              <rotation-type>bySize</rotation-type>
              <number-of-files-limited>false</number-of-files-limited>
              <file-count>7</file-count>
              <file-size-limit>500</file-size-limit>
              <rotate-log-on-startup>true</rotate-log-on-startup>
              <log-file-rotation-dir></log-file-rotation-dir>
              <rotation-time>00:00</rotation-time>
              <file-time-span>24</file-time-span>
              </logging>
              </default-connection-properties>
              <connection-instance>
              <jndi-name>hoox</jndi-name>
              <connection-properties>
              <pool-params></pool-params>
              <logging>
              <log-filename>C:\dev\wls_domains\domain1\servers\AdminServer\logs\hoox.log</log-filename>
              <logging-enabled>true</logging-enabled>
              <rotation-type>bySize</rotation-type>
              <number-of-files-limited>true</number-of-files-limited>
              <file-count>7</file-count>
              <file-size-limit>10000</file-size-limit>
              <rotate-log-on-startup>false</rotate-log-on-startup>
              <log-file-rotation-dir>C:\dev\wls_domains\domain1\servers\AdminServer\logs</log-file-rotation-dir>
              <rotation-time>00:00</rotation-time>
              <file-time-span>24</file-time-span>
              </logging>
              <properties>
              <property>
              <name>mailbox</name>
              <value>XXXXXXXXXXXXXX</value>
              </property>
              <property>
              <name>dsaNode</name>
              <value>XXXXXXXXXXXXX</value>
              </property>
              <property>
              <name>ipAddress</name>
              <value>XXXXXXXXXXXXXXX</value>
              </property>
              <property>
              <name>options</name>
              <value>-TL FULL -MCMDSIZE 5</value>
              </property>
              <property>
              <name>protocol</name>
              <value>EGATE</value>
              </property>
              <property>
              <name>serviceMapPath</name>
              <value>C:\dev\wls_domains\domain1\lib\vdirmap.xml</value>
              </property>
              </properties>
              </connection-properties>
              </connection-instance>
              </connection-definition-group>
              </outbound-resource-adapter>
              </weblogic-connector>
              • 4. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
                wilson.t
                you need to provide a weblogic-ra.xml. WLS will try to use an automatically generated weblogic-ra.xml if it is not provided, but for dev env purpose only and the generated file may not work correctly in all cases.
                • 5. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
                  666794
                  I did not know that. So far I have only deployed the adapter to DEV env, and the automatically generated weblogic-ra.xml file has worked correctly after I have configured it.

                  So for TEST and PROD env, I should add the weblogic-ra.xml file to the META-INF dir in the adapter-rar-file together with the ra.xml file?

                  I would suggest however, that the thread starter (if he or she still is interested) tries the easiest approach first, that is to let WLS in DEV env automatically generate a weblogic-ra.xml file and then configure it. When things are up and running, then experiment with providing a weblogic-ra.xml file when deploying. I can provide more detailed deployment instructions for this specific adapter if necessary.
                  • 6. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
                    wilson.t
                    yes, developer/deploy is highly recommended to provide a weblogic-ra.xml instead of depending on the auto-generated one.
                    • 7. Re: Deploying J2E CA 1.0 Resource Adapter on 11g
                      666794
                      Update: I added the weblogic-ra.xml file to the resource adapter rar-file (in the META-INF dir), worked perfectly. Weblogic no longer auto-generates a weblogic-ra.xml file, only a Plan.xml file is created (I guess this is normal).