This discussion is archived
1 Reply Latest reply: Dec 6, 2010 5:43 AM by Sebastian Solbach (DBA Community) RSS

Adding ASM disk to existing disk group

755171 Newbie
Currently Being Moderated
Hi,


I tried to add one new ASm disk to an existing ASM disk group using ASMCA.
Env : Linux RHEL 5 (64 bit)
Oracle 11gR2 RAC (2 node) with ASM

First, I created the disk partitions from the raw disk using fdisk command and then created the ASM disk using oracleasm creatdisk command from the node 1.

Then, without scanning the new disk from the 2nd node (through oracleasm scandisk), I tried to add the new asm disk to an existing disk group using asmca (right click on the existing disk group and click on "Add DIsk")
After I clicked on the "OK" button, I got an error that the 2nd node cannot see the new asm disk.

After I click ok on the error message, What I see is that the new disk is no longer visible on the "Show eligible" list.
Its header has been changed to "MEMBER". But the total size of the disk group is still the old value(The new disk size is not added).

What can I do to get the new disk back to the "elligible" list so that I can try adding the new disk again. (I have run the scandisk command from the 2nd node).

Also, another point I noted that, when I click on the "show all" check box (instead of "show elligible") on asmca, it shows all the disk, but the new disk's DISK NAME is blank.

Any help please !!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points