2 Replies Latest reply: Dec 28, 2010 11:10 PM by Daniel L Williams RSS

    Primavera P6 Stand-alone installation

      Forgive me if I have posted in the incorrect thread.

      I have a user who has a stand-alone version of P6. It is asking him to configure the database connection when he tries to log in. I have made sure that the database has started and listener has started. When he enters a public userid and password, this is the error message he receives:
      Bad public user name or password. Database Server Error: ORA-12528: TNS:listener: all appropriate instances are blocking new connections
      My thought is either the username or password is not correct. Why he is getting this is beyond me. When he opens the database connection, it says page cannot be displayed -

      Any assistance would be appreciated. He is running WinXP.
        • 1. Re: Primavera P6 Stand-alone installation
          Is your TNSNAMES.ora file configured correctly? Can you TNSPING the database instance? I believe with the default P6v7 stand-alone installation it defaults to "XE" so from the command line you would run tnsping XE . If you haven't already, try rebooting that PC.

          Assuming this is Oracle XE, I believe I may have had to create an environment variable for tns_admin once (but it has been awhile since I worked with XE).

          If you can tell me specifically what version of Oracle and P6 I'll let you know if anything else stands out to check.
          • 2. Re: Primavera P6 Stand-alone installation
            Daniel L Williams
            ORA-12528 really is not related to using a bad password - it's a real issue related to something not being correct with the database.

            Here is a thread disucssing this issue which lists some diagnostics to try:

            ORA-12528: TNS:listener: all approriate instances are blocking new connecti

            The fundamental things to do are:
            1) check that tnslsnr.exe is Listening on port 1521 (netstat -abnp TCP)
            2) verify that you can tnsping the local database (tnsping localhost )
            3) if those work, use sql plus:
            sqlplus pubuser/pubuser@localhost:1521
            If that connects, then you're good to disgnose Primaver setup issues. But until you can pass those tests, the issue is with the Oracle database and its connection, not with P6.